Менажер на приложенията

 Top Next

Менажера съдържа тематично групирани в модули приложения от системата като в зависимост от правата си потребителите имат достъп до различни модули. Така изборът на приложение се осъществява в две стъпки:

1. Избор на модула, в които е приложението, чрез селектиране на връх от дървото на модулите.
2. Избор на съответното приложение.


Меню

 Top Previous Next

Главно меню

Файл

Форми

Програми

Справки

Настройки


Файл

Вход – Дава възможност на потребителя да въведе своето потребителско име и парола и да започне работа със системата. При въвеждане на невалидно потребителско име или парола достъпът се отказва и се извежда съобщение за грешка.

Изход от системата – Прекратява сесията на потребителя без да излиза от приложението.

Вход като друг потребител – Прекратява сесията на потребителя и дава възможност за вход на друг потребител.

Изход – Прекратява сесията на потребителя и затваря приложенията. Ако има отворени форми, които са в режим въвеждане или промяна, несъхранените данни и промени се изгубват.


Форми

Формите са основния инструмент за въвеждане на данни. Те са два вида – за въвеждане/промяна на информацията в базата данни и само за разглеждане като последните са отделени от останалите с черта в менюто. Форма се стартира като се избере от менюто.


Програми

Програмите служат за въвеждане на данни по нестандартен начин, обработка върху съсществуващи данни, прогнози и др. Стартират се чрез избор на съответната програма от менюто Програми.


Справки

Справките служат за извеждане и принтиране на различни разрези и анализи на данните. Стартират се чрез избор от менюто Справки.


Файл

 Top

Вход – Дава възможност на потребителя да въведе своето потребителско име и парола и да започне работа със ситемата. При въвеждане на невалидно потребителско име или парола достъпът се отказва и се извежда съобщение за грешка.

Изход от системата – Прекратява сесията на потребителя без да излиза от приложението.

Вход като друг потребител – Прекратява сеcията на потребителя и дава възможност за вход на друг потребител.

Изход – Прекратява сесията на потребителя и затваря приложенията. Ако има отворени форми, които са в режим въвеждане или промяна, несъхранените данни и промени се изгубват.


Форми

 Top

Формите са основния инструмент за въвеждане на данни. Те са два вида – за въвеждане/промяна на информацията в базата данни и само за разглеждане като последните са отделени от останалите с черта в менюто. Форма се стартира като се избере от менюто.


Програми

 Top

Програмите служат за въвеждане на данни по нестандартен начин, обработка върху съсществуващи данни, прогнози и др. Стартират се чрез избор на съответната програма от менюто Програми.


Справки

 Top

Справките служат за извеждане и принтиране на различни разрези и анализи на данните. Стартират се чрез избор от менюто Справки.


Модул Закупуване на стоки и услуги

 Top

Enter topic text here.


Указания за работа със системата

 Top

Форми

Справки


Указания за работа със системата

Форми

Справки


Форми

Формите са основният инструмент за въвеждане на данни. Те са два вида – за въвеждане/промяна на информацията в базата данни и само за разглеждане като последните са отделени от останалите с черта в менюто. Форма се стартира като се избере от менюто или от съответен бутон в

лентата с бутони за бърз достъп.

Всяка форма има 1 - меню, 2 - зона с полета за въвеждане на данни, 3 - лента с бутони и 4 - статус лента.

Команден режим

Режим на редактиране


Команден режим

При стартиране на форма тя се отваря в т.нар команден режим. Визуализира се последният запис и курсорът автоматично се позиционира в полето за търсене.

В този режим главното меню на формата е достъпно, полетата за данни са в режим забраняващ редактирането, лентата с бутони е достъпна с изключение на бутоните Запис и Отказ.

Лента с бутони

Главно меню

Филтриране на таблица


Лента с бутони

Лента с бутони в команден режим

Навигация

Разглеждането на записи във формата става посредством бутоните за навигация.

Първи запис [image] - позиционира формата на първия запис при текущото сортиране.

Предходен запис [image] - позиционира формата на предходния запис при текущото сортиране.

Следващ запис [image] - позиционира формата на следващия запис при текущото сортиране.

Последен запис [image] - позиционира формата на последния запис при текущото сортиране.

При движение по записите в най-дясното поле на статус лентата се изписва позицията на текущия запис спрямо текущото сортиране и броя на всички записи спрямо текущото филтриране [image] .

Търсене

Възможно е позиционирането върху определен запис по следния начин:

· в полето за търсене се въвежда валиден текст базиран на текущото сортиране.
· натиска се клавиша Enter или бутона Намери запис [image] .

Ако няма съвпадение на записа в полето за търсене и стойност от колоната на текущото сортиране, формата се позиционира върху запис, чиято стойност на сортираното поле започва със записа в полето.

Промяна на ключа за сортиране

Полето от базата данни по което се извършва сортиране (ключ) може да се промени чрез бутона Промяна на ключа за сортиране [image] или F7. Визуализира се прозорец с предварително зададени ключови полета. Може да се избере някое от тях или да се избира между всички полета от базата данни като се селектира Покажи всички. След като изборът е направен бутонът ОК променя ключа за сортиране, като затваря отворения прозорец. Текущият ключ за сортиране се показва в средното поле на статус лентата [image] .

Превключването между първичния и вторичния ключ за сортиране (зададени по подразбиране за формата) се извършва чрез бутона F11.

Временен филтър

Бутонът Временен филтър [image] се използва, за да се намалят временно броя записи, които се разглеждат. Той е тясно свързан с текущия ключ за сортиране - филтрира записите, оставяйки само тези, които имат стойност на полето-ключ, равна на стойността на ключа на текущия запис. Промяната се отразява в статус лентата – броят на записите намалява и в иконата на бутона –появява се червена стрелка [image] . Изключването на филтъра става с повторно натискане на бутона.

Пример: Ако разглеждаме фактури, сортирали сме записите по град и сме се позиционирали на запис,за който стойността на полето град е София. След като натиснем бутона Временен филтър, достъпни за разглеждане ще останат само записите, за които стойността на полето град е София. Ако обаче сме сортирали записите по номер на фактура и сме позиционирани на запис с номер на фактурата 123456, след натискане на бутона Временен филтър, то навигацията ще бъде възможна само за един запис, тъй като не би трябвало да съществува друга фактура със същия номер.

Режим на преглед

Режим на преглед се установява чрез натискане на бутона Режим на преглед [image] . Появява се нов прозорец, който предоставя функционалност за избор на полета от базата данни, които да са видими. Някои полета са маркирани по подразбиране, но може да се променят и да се добавят нови.

Изборът на полета е аналогичен на избора на множество файлове в Windows Explorer. Избор на допълнителни полета се осъществява като се задържа Ctrl и се изберат полетата с мишката. Ако се избира последователност от полета, се избира първото с мишката и при задържан Shift се селектира последното от тях (отново с ляв бутон на мишката). Задържането и на Ctrl при избора на първо поле дава възможност за селектиране на няколко последователности от полета.

След като желаните полета са селектирани се натиска OK. Визуализира се таблица с цялата налична информация. Тя може да бъде сортирана по дадена колона посредством кликване с ляв бутон върху заглавното и поле. При повторен клик върху заглавното поле на колоната таблицата се пресортира в намаляващ ред.

Ако таблицата е сортирана по дадена колона е възможно търсене на определен запис в нея чрез полето за търсене долу в ляво.

Пример: Ако сме сортирали по град и напишем “София” в полето за търсене ще се визуализират първите данни, за които стойността на полето град е “София”.

Таблица може да бъде филтрирана по произволно поле като се използват стандартни функционалности за таблици с филтър.

Изборът на редове от таблицата е аналогичен на избора на полета за визуализация - отново посредством комбинациите на ляв бутон на мишката и Ctrl и/или Shift.

Данните от таблицата могат да бъдат експортирани към друга програма. Това става с натискане на бутона Копирай, след избор на редовете за експорт и Paste в документ на съответната програма.

Пример: Ако искаме да експортираме селектираните редове в таблица на Microsoft Excel, натискаме Копирай, след което отваряме съответния.xls файл и избираме Paste или Paste Special от меню Edit.

Натискането на OK в режим на преглед, след като е избран ред от таблицата ще затвори прозореца и ще покаже отново формата, като тя ще бъде позиционирана на записа, съответстващ на селектирания ред.

Клавишни комбинации (shortcuts) в команден режим

F1 - Помощна информация за формата.

F5 – Визуализация на предходен запис.

F6 – Визуализация на следващ запис.

F7 – Дава възможност за избор на ключ за сортиране.

F8 – Изпълни програма (само където е приложимо).

F9 – Изпълни (покажи) справка (само където е приложимо).

F11 – Превключване между първичен и вторичен ключ.


Главно меню

Филтри

Възможно е за дадена форма предварително да бъдат зададени определено множество от филтри (различни от временните филтри). Те са достъпни през менюто Филтри на формата. За да се приложи някой от тях е необходимо да се избере от менюто. Резултатът от прилагането на временен филтър след това включва само записи, отговарящи на временния филтър и зададения от менюто филтър. За да се преустанови действието на филтъра, от менюто се избира Без филтър.

Изпълни програма

От това меню могат да бъдат извиквани различни програми обработващи данните свързвани с формата. Ако има зададена програма по подразбиране тя може да се извика с F8.

Изпълни справка

Меню за извикване на справки свързани с формата. Ако е дефинирана само една справка - по подразбиране, може да се отвори с F9.

Опресняване

Презарежда данните във формата от базата данни.

Разширено търсене

В някои форми освен обикновените единични полета за въвеждане на данни има и таблици за въвеждане на данни. Търсенето в тях не е възможно през полето за търсене, а колоните им не са в списъка с полета в режим на преглед. Това е така, защото обикновено за един запис заглавна информация има повече от един запис детайлна информация (напр. в една фактура се изброяват няколко изделия). Тази детайлна информация се визуализира във формите чрез тези таблици. За търсене, базирано на детайлната информация, се използва менюто Разширено търсене. При избиране на това меню се появява прозорец Разширено търсене.

В него има две списъчни полета – за избор на таблица (възможно е във една форма да има повече от една таблица) и на поле от избраната таблица. В полето Търси се въвежда стойност, която се търси в посоченото вече поле. След като се въведе критерий за търсене можете да се избере посоката на търсене спрямо текущия запис – Назад или Напред. Търсенето става с натискане на бутона Следващ.

Ако не е намерен запис в избраната посока се извежда съобщение, а ако бъде намерен формата се позиционира на него. Формата може да бъде разглеждана докато е активен прозореца за разширено търсене. С бутона Филтър се поставя временен филтър на формата, който показва само тези записи, които отговарят на критерия за търсене. Този филтър можете да бъде изключен чрез повторно натискане на бутона Филтър.


Филтриране на таблица

Таблици с филтър

Част от таблиците в системата например таблицата в прозореца Режим на преглед, както и в повечето програми тип браузър имат вградена функционалност за филтриране на записите, които се показват.

Забележка: Поради спецификата на формите таблиците в самите форми нямат филтриране.

Филтър може да бъде зададен за произволно поле (колона) от такава таблица, като се щракне с десен бутон на мишката върху заглавието на колоната.

Релации за филтриране

Филтърът се установява на база текста в текстовото поле (по подразбиране се попълва стойността на избрания ред от таблицата) и релация която се избира от падащото меню.

= - стойността на полето за филтриране (колоната от таблицата) е равна на текста;

<> - стойността е различна от текста;

> - стойността е по-голяма от текста спрямо стандартната подредба;

>= - стойността е по-голяма или равна от текста спрямо стандартната подредба;

< - стойността е по-малка от текста спрямо стандартната подредба;

<= - стойността е по-малка или равна от текста спрямо стандартната подредба;

Съдържа - текста се съдържа на произволно място в стойността на полето;

Не съдържа - текста не се съдържа в стойността на полето;

Започва с - Стойността на полето започва с текста;

Не започва с - Стойността на полето не започва с текста;

Завършва на - Стойността на полето завършва с текста;

Не завършва на - Стойността на полето не завършва с текста;

Е празно - Полето е празно;

Не е празно - Полето не е празно (има зададена стойност).

След натискане на бутона ОК филтъра се установява и заглавието на колоната се изписва с удебелен шрифт.

Филтърът може да бъде премахнат с натисканена бутона Премахни филтъра.

Допуска се задаване на филтър за повече от една колона от таблицата.


Режим на редактиране / добавяне на нов запис

Командния режим се променя на режим на редактиране чрез бутона „редактиране” [image] , а на режим на добавяне на нов запис чрез бутона “нов запис” [image] . Двата режима имат сходно поведение, затова ще бъдат разгледани заедно различията ще бъдат изрично отбелязвани.

При установяване на който и да е от двата режима бутоните от лентата (с изключение на “запази” и “отказ”) и менюто стават неактивни. Курсора се позиционира в първото поле в което може да се въвеждат данни. В някои полета не може да се въвеждат ръчно данни от потребителя защото са изчисляеми (по някакво правило). Тези полета са сиви и неактивни.

Когато потребителя се намира в дадено поле за въвеждане, то променя цвета си. Този цвят може да се настройва,но по подразбиране е син.

Възможно е преминаването от едно поле за въвеждане в друго чрез натискане на клавиш “enter” или “tab”. За позициониране на предишното поле може да се използва комбинацията “shift” + “tab”. Тези правила са различни, ако текущото поле е от таблица за въвеждане на данни (виж по долу).

Когато потребителя приключи с въвеждането на данни може да ги съхрани посредством натискане на бутона “запази” или да откаже промените посредством бутона “отказ”. И в двата случая трябва да потвърди избора си.

Типове полета за въвеждане

Таблици за въвеждане на детайлна информация


Текстово поле

 Top

Най-често срещаното е текстовото поле за въвеждане. В него потребителя въвежда ръчно текст, който понякога може да се форматира по специален начин (напр. телефонен номер да е във формат (код)/123-12-12) . Този вид поле има контесктно меню с базовите възможности:

Undo – възстановява предишната стойност, въведена в полето.

Copy – копира съдържанието на полето в клипборда.

Paste – вмъква съдържанието на клипборда в полето.

Delete – изтрива съдържанието на полето.

Select All – маркира текста в полето.

Default Equ (F12) – ако за полето има правило по подразбиране, форсира изпълнението на това правило. Правилото по подразбиране представлява изчисление на стойност по подразбиране на съответното поле.

Пример: При въвеждане на данни за клиент от София правилото по подразбиране ни предлага пощенския код да е 1000. Потребителя може да промени тази стойност. Ако въведе други данни (напр. 1229), то правилото по подразбиране не се прилага освен ако не се използва контекстното меню или алтернативата F12.

Old Value (F9) – Тази функция се използва, когато се въвеждат много записи последователно. Old Value (F9) установява стойност на полето равна на въведената в това поле при предходния запис.

Пример: Ако ще въвеждаме много информация за клиенти от София, за полето град от втория въведен запис нататък бихме могли да използваме Old Value или алтернативата F9 с цел да се улесни въвеждането на информация.


Поле за избор от таблица

 Top

Друг вид поле е полето за избор от таблица. То предствлява текстово поле с бутон с три точки до него. Такова поле се използва, когато стойността трябва да бъде взета от друга таблица от базата данни.

Данните могат да бъдат въвеждани и ръчно, но ако са невалидни се извежда съобщение за грешка. За да избегне въвеждането на невалидни данни, потребителят може да избере номера на поръчката от таблицата с поръчки чрез натискане на бутона или алтернативата F4. Появява се прозорец за избор на стойност, който има различно поведение според типа на въвежданите данни с цел улеснение на потребителя.

Стандартно в прозореца за избор на стойност има таблица с всички записи от базата данни, които се отнасят за това поле. Таблицата може да бъде сортирана по различните колони посредством кликване върху заглавието на колоната. Чрез полето за търсене потребителя може да намери желания запис използвайки текущото сортиране. Когато открие желаната стойност, потребителя се позиционира върху съответния ред от таблицата и натиска ОК. Изборът на стойност може да се осъществи и чрез двойно кликване върху съответния ред. Прозорецът се затваря и стойността се въвежда в текстовото поле. Възможно е за улеснение на потребителя вместо таблица в прозореца за избор на стойност да се визуализира йерархична структура от записи (дърво). Стойността се избира по аналогичен начин – чрез двоен клик или селектиране и ОК. В някои случаи за удобство прозореца за избор на стойност предоставя информацията в специфичен формат, зависещ от типа на данните, които трябва да се въведат в полето.

Пример: Във формата за фактури номера на поръчката се избира от таблицата с поръчки. Потребителят може да въведе ръчно номера на поръчката ако го знае, но ако въведе несъществуващ номер на поръчка ще се изведе съобщение за грешка и ще бъде дадена възможност за повторно въвеждане.


Поле за избор на дата

 Top

В него потребителя може да въведе ръчно дата или ако натисне триъгълничето в края на полето да избере датата от календар. Ако потребителя не въведе година, по подразбиране се приема текущата година.


Поле за избор от списък

 Top

Полето за избор от списък предоставя възможност на потребителя да избере стойност от предварително зададено неголямо множество. Обикновенно в това поле не може да се въвеждат данни ръчно. Ако потребителя се е позиционирал върху такова поле и натисне клавиш, то се избира стойност от списъка, започваща с въведения от клавиатурата символ.


Навигация в таблица

 Top

Стрелка надясно, Enter или Tab – преминаване към следваща колона, в която може да се въвеждат данни. При изпълнение на Enter или Tab, ако няма следваща колона, позиционирането е върху първата колона за въвеждане на данни от следващия ред, при липса на следващ ред – върху следващия контрол във формата.

Стрелка наляво, Shift +Tab – преминаване на предходната колона, в която е позволено въвеждане на данни. Ако Shift+Tab се изпълни върху първата колона от даден ред, позволяваща въвеждане, се преминава на последната колона за въвеждане от предходния ред. Ако се изпълни от първата колона на първия ред, се преминава към предходния контрол.


Въвеждане на данни

 Top

Въвеждането на данни в колони на таблицата зависи от типа на колоната и е аналогично на въвеждането на данни във останалите полета.


Изтриване на ред

 Top

Ред от таблицата се изтрива като първо се селектира чрез клик с мишката в началото на реда (в малкият сив правоъгълник преди първата колона) и натискане на клавиша Del (Delete). Редът се изтрива след потвърждение.


Ценови листи

 Top

Програма Ценови листи

· Служи за въвеждане и редакция на ценови листа.Използват за изчисляване и автоматично въвеждане на цени на продукти в различните модули на системата.

Лента с инструменти:

1. 2. 3. 4. 5. 6. 7. 8. 9. 10. 11. 12. 13. 14. 15.

1. Избор на ценова листа .
2. Добавя папка.
3. Преименува папка.
4. Изтрива папка.
5. Променя цените на продуктите в избраната папка.
6. Добавя нова ценова листа.
7. Редактиране на ценова листа.
8. Клониране на ценова листа.
9. Копира избраните редове от избрана папка.
10. Поставя копираните редове в избрана папка.
11. Разширено търсене на продукт по индентификационен номер или код.
12. Търсене по папки.
13. Запис на направените промени .
14. Копирай за Ecxel
15. Въвеждане на отстъпки за продукти от ценовата листа

Основни функционалности

Добавяне на нова ценова листа

Служи за добавяне на нова ценова листа с опция за глобална формула .

Промяна на цени в папка

Използва се за промяна на цени на продукти в избрана папка с зададен процент .

Таблица с цени на продукти

Изделие-индентификатор на продукта.

Тип-тип на продукта.

Описание-описанието на продукта.

Цена- поле за въвеждане на цена.

Формула за корекция на цена

Формулата се въвежда, когато цената зависи от количествено/качествено изменение на характеристиките продукта.Резултата от формулата се добавя към въведената цена.

Пример:

iif(AttrValue("COVER") = "0", -ConstValue("CoverBGN"), 0)

Ако стойноста на атрибута покритие "COVER" е равна нула, то добави в цената стойноста на константата "CoverBGN" с знак минус, в противен случай добави 0.

Контролна формула

Формулата се въвежда , когато има нужда от ограничения по зададени характеристики на продукта или техните стойности за които съответства въведената цена.

Ст1..Ст5- полета за въвеждане на контролни стойности .Използват се във в контролни формулите за реда. Инициализират се във формулите като _cv1.._cv5

Пример:

AttrValue("SHAPE") = "F" & AttrValue("DIM_A") = _cv1

Цената за този ред се отнася само за продукти, чиято стойност на атрибута "SHAPE" е равна на "F" и стойноста на атрибута "DIM_A" е равна на контролната стойност Ст1.

Въвеждане и промяна на цени на продукти в ценовите листи, добавяне на нови продукти и ценови листи.

1. Избира се ценова листа за съответната година или клиент. Ако няма такава за текущата година/клиент се създава нова или се клонира ценова листа от предходна година с ново име и се коригират всички разлики в продуктовия ценови каталог и прилежащите им цени.
2. Ако е необходимо добавяне на нов продукт се избира папка съответстваща на вида му ,а ако няма такава се добавя нова в дървото с папки .
3. Добавянето на нов продукт се извършва от страничната лента с бутони . След натискане на бутона добави нов ред се отваря прозореца за Избор на браузър, от където можем да изберем желания продукт.


Тест на Ценови листи

 Top

Тест на Ценови листи

Използва се за проверка на цени на изделия и тяхното правилно изчисление на базата на формули в съответната ценова листа.Избира се ценова листа и изделие от ПСИ на изделията и се натиска бутона Изчисли.

Цена -сумата на основната цена на изделието и допълнителната цена калкулирана от формули.

Цена2-допълнителната цена добавена към основната цена със съответния знак.


Типове полета за въвеждане

Във формите полета за въвеждане са от различен тип.

Текстово поле

Поле за избор от таблица

Поле за избор на дата

Поле за избор от списък


Текстово поле

Най-често срещаното е текстовото поле за въвеждане. В него потребителя въвежда ръчно текст, който понякога може да се форматира по специален начин (например: телефонен номер да е във формат (код)/123-12-12). Този вид поле има контекстно меню с базовите възможности:

Undo – възстановява предишната стойност, въведена в полето.

Copy – копира съдържанието на полето в клипборда.

Paste – вмъква съдържанието на клипборда в полето.

Delete – изтрива съдържанието на полето.

Select All – маркира текста в полето.

Default Equ (F12) – ако за полето има правило по подразбиране, форсира изпълнението на това правило. Правилото по подразбиране представлява изчисление на стойност по подразбиране на съответното поле.

Пример: При въвеждане на данни за клиент от София правилото по подразбиране ни предлага пощенския код да е 1000. Потребителя може да промени тази стойност. Ако въведе други данни (например: 1229), то правилото по подразбиране не се прилага освен ако не се използва контекстното меню или алтернативата F12.

Old Value (F9) – Тази функция се използва, когато се въвеждат много записи последователно. Old Value (F9) установява стойност на полето равна на въведената в това поле при предходния запис.

Пример: Ако ще въвеждаме много информация за клиенти от София, за полето град от втория въведен запис нататък бихме могли да използваме Old Value или алтернативата F9 с цел да се улесни въвеждането на информация.


Поле за избор от таблица

Друг вид поле е полето за избор от таблица. То предствлява текстово поле с бутон с три точки до него. Такова поле се използва, когато стойността трябва да бъде взета от друга таблица от базата данни.

Данните могат да бъдат въвеждани и ръчно, но ако са невалидни се извежда съобщение за грешка. За да избегне въвеждането на невалидни данни, потребителят може да избере номера на поръчката от таблицата с поръчки чрез натискане на бутона или алтернативата F4. Появява се прозорец за избор на стойност, който има различно поведение според типа на въвежданите данни с цел улеснение на потребителя.

Стандартно в прозореца за избор на стойност има таблица с всички записи от базата данни, които се отнасят за това поле. Таблицата може да бъде сортирана по различните колони посредством кликване върху заглавието на колоната. Чрез полето за търсене потребителя може да намери желания запис използвайки текущото сортиране. Когато открие желаната стойност, потребителя се позиционира върху съответния ред от таблицата и натиска ОК. Изборът на стойност може да се осъществи и чрез двойно кликване върху съответния ред. Прозорецът се затваря и стойността се въвежда в текстовото поле. Възможно е за улеснение на потребителя вместо таблица в прозореца за избор на стойност да се визуализира йерархична структура от записи (дърво). Стойността се избира по аналогичен начин – чрез двоен клик или селектиране и ОК. В някои случаи за удобство прозореца за избор на стойност предоставя информацията в специфичен формат, зависещ от типа на данните, които трябва да се въведат в полето.

Пример: Във формата за фактури номера на поръчката се избира от таблицата с поръчки. Потребителят може да въведе ръчно номера на поръчката ако го знае, но ако въведе несъществуващ номер на поръчка ще се изведе съобщение за грешка и ще бъде дадена възможност за повторно въвеждане.


Поле за избор на дата

В него потребителя може да въведе ръчно дата или ако натисне триъгълничето в края на полето да избере датата от календар. Ако потребителя не въведе година, по подразбиране се приема текущата година.


Поле за избор от списък

Полето за избор от списък предоставя възможност на потребителя да избере стойност от предварително зададено неголямо множество. Обикновенно в това поле не може да се въвеждат данни ръчно. Ако потребителя се е позиционирал върху такова поле и натисне клавиш, то се избира стойност от списъка, започваща с въведения от клавиатурата символ.


Таблици за въвеждане на детайлна информация

Таблицата за въвеждане на данни е един от често срещаните начини за въвеждане на детайлна информация. Таблицата се състои от различни колони – някои са текстови, други за избор от таблица, избор на дата, избор от списък. Някои от колоните са сиви – в тези колони не може да се въвеждат данни.

Навигация в таблица

Въвеждане на данни

Изтриване на ред


Навигация в таблица

Стрелка надясно, Enter или Tab – преминаване към следваща колона, в която може да се въвеждат данни. При изпълнение на Enter или Tab, ако няма следваща колона, позиционирането е върху първата колона за въвеждане на данни от следващия ред, при липса на следващ ред – върху следващия контрол във формата.

Стрелка наляво, Shift +Tab – преминаване на предходната колона, в която е позволено въвеждане на данни. Ако Shift+Tab се изпълни върху първата колона от даден ред, позволяваща въвеждане, се преминава на последната колона за въвеждане от предходния ред. Ако се изпълни от първата колона на първия ред, се преминава към предходния контрол.


Въвеждане на данни

Въвеждането на данни в колони на таблицата зависи от типа на колоната и е аналогично на въвеждането на данни във останалите полета.


Изтриване на ред

Ред от таблицата се изтрива като първо се селектира чрез клик с мишката в началото на реда (в малкият сив правоъгълник преди първата колона) и натискане на клавиша Del (Delete). Редът се изтрива след потвърждение.


Програми

Enter topic text here.


Справки

Стартирането на справки е еднотипно, макар и те да визуализират различен тип информация. След като се избере справка от менюто, се появява прозорец за въвеждане на филтри, подобен на следния:

След като се въведат критерии за филтър на данните се натиска бутона Печат.

Прозорец за разглеждане на справки

Прозореца предоставя функционалности за разглеждане на справките в готовия им за печат вид, отпечатване, експорт на данните и др.

Функционалностите са достъпни през лента, съдържаща следните бутони:

Отпечатване – Принтира справката

Показване на дървото на групите – Ако в справката има групирани данни при натискане на този бутон вляво от справката се показва йерархичната им структура и може да бъде избран конкретен запис от базата данни който да бъде показан.

Бутони за навигация - позволяват движение назад и напред по страниците.

Номер на страницата – В това поле се намира номера на текущата страница, която може се променя.

Търсене на текст – Предоставя възможност за търсене на текст в съдържанието на справката.

Увеличение (zoom) – Промяна на размера на справката.

Запис във файл - позволява запис на справката като файл в някои от най-популярните файлови формати - MS Word, MS Excell, pdf и др.

Опресняване - презарежда справката от базата данни.


Форми

 Top

Формите са основният инструмент за въвеждане на данни. Те са два вида – за въвеждане/промяна на информацията в базата данни и само за разглеждане като последните са отделени от останалите с черта в менюто. Форма се стартира като се избере от менюто или от съответен бутон в

лентата с бутони за бърз достъп.

Всяка форма има 1 - меню, 2 - зона с полета за въвеждане на данни, 3 - лента с бутони и 4 - статус лента.

Команден режим

Режим на редактиране


Команден режим

 Top

При стартиране на форма тя се отваря в т.нар команден режим. Визуализира се последният запис и курсорът автоматично се позиционира в полето за търсене.

В този режим главното меню на формата е достъпно, полетата за данни са в режим забраняващ редактирането, лентата с бутони е достъпна с изключение на бутоните Запис и Отказ.

Лента с бутони

Главно меню

Филтриране на таблица


Режим на редактиране / добавяне на нов запис

 Top

Командния режим се променя на режим на редактиране чрез бутона „редактиране” [image] , а на режим на добавяне на нов запис чрез бутона “нов запис” [image] . Двата режима имат сходно поведение, затова ще бъдат разгледани заедно различията ще бъдат изрично отбелязвани.

При установяване на който и да е от двата режима бутоните от лентата (с изкл. на “запази” и “отказ”) и менюто стават неактивни. Курсора се позиционира в първото поле в което може да се въвеждат данни. В някои полета не може да се въвеждат ръчно данни от потребителя защото са изчисляеми (по някакво правило). Тези полета са сиви и неактивни.

Когато потребителя се намира в дадено поле за въвеждане, то променя цвета си. Този цвят може да се настройва,но по подразбиране е син.

Възможно е преминаването от едно поле за въвеждане в друго чрез натискане на клавиш “enter” или “tab”. За позициониране на предишното поле може да се използва комбинацията “shift” + “tab”. Тези правила са различни, ако текущото поле е от таблица за въвеждане на данни (вж. по долу) .

Когато потребителя приключи с въвеждането на данни може да ги съхрани посредством натискане на бутона “запази” или да откаже промените посредством бутона “отказ”. И в двата случая трябва да потвърди избора си.

Типове полета за въвеждане

Таблици за въвеждане на детайлна информация


Справки

 Top

Стартирането на справки е еднотипно, макар и те да визуализират различен тип информация. След като се избере справка от менюто, се появява прозорец за въвеждане на филтри, подобен на следния:

След като се въведат критерии за филтър на данните се натиска бутона Печат.

Прозорец за разглеждане на справки

Прозореца предоставя функционалности за разглеждане на справките в готовия им за печат вид, отпечатване, експорт на данните и др.

Функционалностите са достъпни през лента, съдържаща следните бутони:

Отпечатване – Принтира справката

Показване на дървото на групите – Ако в справката има групирани данни при натискане на този бутон вляво от справката се показва йерархичната им структура и може да бъде избран конкретен запис от базата данни който да бъде показан.

Бутони за навигация - позволяват движение назад и напред по страниците.

Номер на страницата – В това поле се намира номера на текущата страница, която може се променя.

Търсене на текст – Предоставя възможност за търсене на текст в съдържанието на справката.

Увеличение (zoom) – Промяна на размера на справката.

Запис във файл - позволява запис на справката като файл в някои от най-популярните файлови формати - MS Word, MS Excell, pdf и др.

Опресняване - презарежда справката от базата данни.


Програми

 Top

Enter topic text here.


Модул Продажби

 Top


Модул Продажби


Форма - Оферти

Форма Оферти

Използва се за въвеждане, редактиране и отпечатване на оферти. За общи указания за работа с форми виж.

Основни полета на формата:

Оферта # - генерира се от системата.

Дата- дата на офертата.

Клиент#- идентификатор на контрагент.

Контакт#- идентификатор на контакт за връзка.

Изисквана дата за доставка/Дата за реализация/Необходим брой работни дни - срокове за изпълнение.

У-я на доставка-избор на условия за доставка.

У-я на плащане- избор на условия на плащане.

Бележки- бележки относно офертата.

Ценова листа-избор на ценова листа от която системата изчислява цени на продукти в таблицата Заявени изделия.

Коментар- въвежда се допълнителна информация за офертата.

Статуси на офертата:

· Отворен-
· Затворен-
· Затворен от служител- маркира се като затворена, ръчно от служител.

Отметки:

· Скрий клиент -

Таблици:

Заявени изделия - въвеждат се заявените продукти и услуги, техните цени и време за изпълнение.

Документи - избор на документи.

Известия - известия към офертата.

Сумарни полета:

Всичко - обща сума на офертата в избраната валута. Валутата се попълва по подразбиране в зависимост от държавата на клиента.

Отстъпка - обща отстъпка.

Данъчна основа - сума на офертата с извадена отстъпка.

ДДС %, ДДС - процент и сума на данък добавена стойност.

Обща цена - сума на офертата със ДДС.


Форма -Клиентски поръчки (Потвърждение на поръчка)

Форма Потвърждение на поръчка

Използва се за въвеждане, редактиране и отпечатване на клиентски поръчки. В полетата на формата се въвеждат всички необходими данни за двуезично (български и английски) отпечатване на потвърждение на поръчка. За общи указания за работа с форми виж.

Основни полета на формата:

Поръчка #- пореден номер на поръчка (генерира се от системата).

Дата- дата на клиентската поръчка.

Клиент #- идентификатор на контрагент - клиент.

Контакт #- идентификатор на контакт за връзка.

Адрес #- идентификатор на адрес за доставка.

Оферта #- номер оферта предхождаща текущата поръчка.

МКС N:-номер на мастер система.

Факс, E-mail, Телефон, Моб. тел - връзки с контрагента.

Отметки

· Скрий клиент-
· Вътрешна-
· Пусни за изпълнение-

Групираща рамка Адрес на фирмата- автоматично се попълва адреса по регистрация на контрагента.

Групираща рамка Адрес за доставка- по подразбиране се задава главния адрес за доставка. Промяна на адреса за доставка се извършва чрез избор на друг идентификатор на адрес за доставка.

У-я на плащане#- избор на условия на плащане.

У-я на доставка#- избор на условия на доставка.

Бележки- въвежда се допълнителна информация относно поръчката.

Кл.Ордер- въвежда се номера клиентската поръчка за покупка.

Групираща рамка Търговска дирекция - идентификатор на служител от Търговска дирекция одобрил поръчката към дата.

Групираща рамка Дирекция Производство-идентификатор на служител от Дирекция Производство, с когото е съгласувана поръчката към дата.

Групираща рамка Дирекция ОТК- идентификатор на служител от Дирекция ОТК , с когото е съгласувана поръчката към дата.

Ценова листа #- избор на Ценова листа от която системата изчислява цени в таблицата Поръчани изделия.

Банкова сметка #- избор на банкова сметка.

Статуси на клиентската поръчка:

Статус одобрение:

· Чакащ одобрение- поръчката не е одобрена или съгласувана от избраните дирекции.
· Одобрен- поръчката е одобрена

Статус изпълнение:

· Нов-
· Отворен-
· Затворен-
· Затворен от служител- маркира се като затворена, ръчно от служител.

Таблици:

Поръчани изделия

Във таблицата се въвеждат изделия по следните начини: избира се или се създава конкретна конфигурация на конфигурируемо изделие чрез функцията-конфигуратор на програмата ПСИ. В случаите когато сме сигурни, че исканата конфигурация вече е създадена, тя може да бъде избрана и през опциите Избор на изделие или Браузър продукти,или ако е налична в склад през Браузър на склад.

Пореден # - пореден номер на реда.

Отметка К-кт?- маркира се ако изделието е комплект.

К-кт #-идентификатор на комплекта.

Идент. # - идентификатор на продукта .

Код - код на продукта .

Описание - описание на продукта. Ако избрания продукт е конфигурируемо изделие, се взема съкратена форма на описанието му, включваща само тези атрибути на изделието, които са специално маркирани за това.

Бележки- бележки за избрания продукт.

К-во в к-та- количество в комплекта.

Общо к-во- общо количество на продукта от реда.

Остатък -

Ед. цена (без ДДС) - единична цена. Ако е избрана Ценова листа в която съответния продукт фигурира, се изчислява на база на ценовата листа.

Отстъпка%- отстъпка в проценти за съответния ред.

Сума (без ДДС)- произведение на количеството и единичната цена.

Групова опаковка#- идентификатор на груповата опаковка.

Описание - описание на груповата опаковка.

Опак. брой- брой групови опаковки.

Статус- статус на реда.

Пр.статус- производствен статус.

Количества и дати за изпълнение- количества и дати за изпълнение за всяко поръчано изделие и информация за наличности. Дати за освобождаване на партиди за продажба.

# -пореден номер на реда към дата на изпълнение

Дата от кл.-краен срок за изпълнение от клиентската поръчка

Дата на изп.- дата на изпълнение.

Количество-количество за изпълнение за реда.

Остатък-остатък за изпълнение.

Опак. бр.- брой опаковки.

Реализация-

Заделени- брой заделени количества.

Свободни на склад - брой свободни количества на склад.

Налични на склад-брой налични количества на склад.

Пр. Статус-производствен статус.

Групови опаковки- групови опаковки , количество.

Документи- прикачени документи към клиентската поръчка с опция за разглеждане.

Сумарни полета:

Всичко - обща сума на клиентската поръчка в избрана та валута. Валутата се попълва по подразбиране в зависимост от държавата на клиента.

Отстъпка - обща отстъпка.

Данъчна основа - сума на клиентската поръчка с извадена отстъпка.

ДДС %, ДДС - процент и сума на данък добавена стойност.

Обща цена - сума на клиентската поръчка със ДДС.

Меню Изпълни

Изпълни програма\Клониране на поръчка- клониране на поръчка.

Справки-преглед и отпечатване на справки.

За общи указания за работа с форми виж.


Фактури

Форма – Фактури.

Използва се за въвеждане, редактиране и отпечатване на фактури. В полетата на формата се въвеждат всички необходими данни за двуезично (български и английски) издаване на фактури. За общи указания за работа с форми виж.

Номериране на фактурите.

При отваряне на формата в режим на нов запис (от бутона Нов запис) в полето Запис # се попълва поредния номер на фактурата (пълното 10-цифрено изписване е в полето Документ No), като брояча на номерата се увеличава с единица. При отказ на записа брояча се връща с единица.

Системата подържа възможност за задаване на различни базови (стартови) номера на фактурите за различните складове. Например за Склад 1 номера от 0100000001 нататък, за Склад 2 от 0200000001 нататък и т.н. Кой базов номер ще се използва се определя от склада по подразбиране, който се изписва в заглавното поле на формата при отварянето и.

При отваряне на формата, за склад по подразбиране се задава складът, на който текущия потребител се явява МОЛ.

Смяна на складът по подразбиране.

Складът по подразбиране може да бъде сменен когато формата е в команден режим от менюто Изпълни\Изпълни програма\Промяна на базовия склад. Отваря се формата – Промяна на базовия склад, където може да бъде сменен склада.

Ръчни фактури.

Изборът на полето Ръчни фактури от формата Промяна на базовия склад, задава режим, в който при добавяне на нов запис полето Запис # остава празно, а брояча не се променя. Потребителят е задължен ръчно да въведе желания номер на фактурата.

Забележка: Смяната на полето Склад # във форма Фактури не води до промяна на номера на фактурата (Запис #).

Авансови фактури

Авансови фактури се въвеждат, като от полето Тип се избере Авансова фактура. В този случай таблицата Продукти и услуги не е достъпна за редактиране, а сумата на фактурата (без ДДС) се въвежда в полето Сума.

Въведената авансова фактура може да бъде прикачена към съответната фактура, като номера и бъде въведен в таблицата Авансови фактури в полето Авансова фактура #. В този случай стойността на полето Данъчна основа се намалява със сумата на авансовата фактура(и) - полето Сума по авансови фактури (без ДДС).

Основни полета на формата

Запис # - пореден номер (идентификатор) на фактурата виж Номериране на фактурите.

Дата - дата на документа. Попълва се по подразбиране с текущата дата.

Тип - тип на документа - Фактура или Авансова фактура.

Плащане - статус на плащане на документа:

· Отворен - когато фактурата не е платена или е платена частично (полето Остатък за плащане>0.00).
· Затворен - фактурата е платена - има създадени записи във формата Плащания за пълната сума на фактурата.
· Затворен от служител - маркира се като платена, ръчно от служител.

Склад # - идентификатор на склад, от който се издава фактурата. Задължително поле, при нов запис се попълва със склада по подразбиране.

Изпиши - указва съответните продукти да бъдат изписани от указания склад при записа на фактурата. Ако служителят не е МОЛ за съответния склад съответните складови операции се създават със статус Чакащ одобрение.

Анулирана - ако полето е селектирано, съответната фактура е анулирана и не се включва в последващите обработки и представяния на данните.

Ценова листа # - идентификатор на ценова листа, която ще се използва за изчисляване на цените на продуктите.

У-я за ДДС - идентификатор на условията за начисляване на ДДС различен от стандартния.

Купувач # - идентификатор на контрагент - купувач.

Получател # - идентификатор на контрагент - получател на стоките. Попълва се по подразбиране с идентификатора на купувача.

Адрес # - идентификатор на адрес за доставка на получателя.

(Транспорт) Тип - Идентификатор на типа транспорт използван за доставката.

(Транспорт) Превозвач - Идентификатор на контрагент превозвач.

Дата на сделката - дата на сделката за фактурата.

Място на сделката - място на сделката за фактурата, например Варна

(Условия на доставка) Код - код на условия на доставка - INCOTERMS.

Условия на плащане # - идентификатор на условията на плащане.

Маркирай като платена - ако е селектирано дава информация, че фактурата е платена към момента на въвеждането и.

Таблица Срокове за плащане

Съдържа данни за датите (падежите) и сумите дължими по фактурата в зависимост от избраните условия на плащане. Ако условията на плащане са Разсрочено периодични вноски потребителят трябва да въведе редове с дати и суми за съответните вноски. В останалите случаи датата и сумата се изчисляват на база на избраните условия и сумата по фактурата.

Таблица Авансови фактури - виж т. Авансови фактури.

Таблица Продукти и услуги

В таблицата се въвеждат данните за продадените изделия:

No - пореден номер на реда.

Поръчка # - Идентификатор на ред от таблицата Количества и дати на изпълнение, от форма Потвърждение на поръчка. Попълва се когато фактурата реферира съответна клиентска поръчка.

Продукт # - идентификатор на продукт (изделие, материал или услуга). Виж Избор на продукти. Ако е попълнено Поръчка #, се взима от поръчката.

Код - код на изделие (за материалите съвпада с идентификатора).

Описание - описание на продукта. Ако избрания продукт е конфигурируемо изделие, се взима съкратена форма на описанието му, включваща само тези атрибути на изделието, които са специално маркирани за това.

К-во - количество в съответната мерна единица (брой за изделията).

Ед. цена (без ДДС) - единична цена. Ако е избрана Ценова листа в която съответния продукт фигурира, се изчислява на база на ценовата листа.

Сума (без ДДС) - произведение на количеството и единичната цена.

Отстъпка % - отстъпка за реда в проценти.

Отстъпка (без ДДС) - сума на отстъпката за реда.

Забележка - бележки на български език.

Комплект - описание на комплект от клиентската поръчка.

Клиентска поръчка - бележки за относно документа за поръчка на клиента (Purchase Order)

Описание англ. - описание на изделието на английски език (отпечатва се в английската версия на фактурата)

Бележки англ. - бележки на английски език.

Комплект англ. - описание на комплект от клиентската поръчка на английски език.

Изп. от склад - указва дали съответното количество изделия вече е изписано от избрания склад като съдържа идентификатора на склада.

ID - идентификатор на реда от фактура.

Тип - тип на продукта - изделие, материал и т.н.

Данните в таблицата Продукти и услуги могат да бъдат попълнени автоматично от избрани клиентски поръчки. При кликване на линк-полето Попълни от поръчки в команден режим, се отваря прозореца Избор от поръчки.

В таблицата се показват позициите от клиентски поръчки или оферти, които са със статус Отворен (Остатък>0). В първата колона се указва дали позицията е от клиентска поръчка - "П" или оферта - "О", желаните позиции за включване към фактурата се избират като се селектира в колоната Избери или се селектира полето Избери всички. Редовете могат да бъдат филтрирани само за определена клиентска поръчка като се напише номера и, и се натисне бутона Зареди поръчка. Тогава ще бъдат показани всички позиции от поръчката независимо от техния статус.

Сумарни полета

Сума - обща сума на фактурата в избрана та валута. Валутата се попълва по подразбиране в зависимост от държавата на клиента.

Отстъпка % - обща отстъпка в проценти.

Отстъпка сума - обща отстъпка.

Данъчна основа - сума на фактурата с извадена отстъпка и сумите по авансови фактури.

ДДС %, ДДС сума - процент и сума на данък добавена стойност. Попълва се по подразбиране в зависимост от държавата на клиента.

Общо - сума на фактурата със ДДС.

Общо в лева - сума с ДДС в лева изчислено по валутния курс от полето Валутен курс.

Сума по авансови фактури без ДДС - сума на авансовите фактури.

Дата на данъчното събитие - ако не е зададена при последващите обработки се взима датата на фактурата.

Остатък за плащане - остатък за плащане по фактурата.


Форма -Кредитни/дебитни известия

Форма – Кредитни/дебитни известия.

Използва се за въвеждане, редактиране и отпечатване на кредитни/дебитни известия за корекция на вече въведени фактури. В полетата на формата се въвеждат всички необходими данни за двуезично (български и английски) издаване на кредитни/дебитни известия. За общи указания за работа с форми виж.

Номериране на известията.

Кредитните и дебитни известия получават номера от поредицата номера за фактури, съответно са валидни същите правила и функционалности както при номериране на фактури.

При отваряне на формата в режим на нов запис (от бутона Нов запис) в полето Запис # се попълва поредния номер на известието (пълното 10-цифрено изписване е в полето Документ No), като брояча на номерата се увеличава с единица. При отказ на записа брояча се връща с единица.

Системата подържа възможност за задаване на различни базови (стартови) номера на известията за различните складове. Например за Склад 1 номера от 0100000001 нататък, за Склад 2 от 0200000001 нататък и т.н. Кой базов номер ще се използва се определя от склада по подразбиране, който се изписва в заглавното поле на формата при отварянето и.

При отваряне на формата, за склад по подразбиране се задава складът, на който текущия потребител се явява МОЛ.

Смяна на складът по подразбиране.

Складът по подразбиране може да бъде сменен когато формата е в команден режим от менюто Изпълни\Изпълни програма\Промяна на базовия склад. Отваря се формата – Промяна на базовия склад, където може да бъде сменен склада.

Ръчни фактури.

Изборът на полето Ръчни фактури от формата Промяна на базовия склад, задава режим, в който при добавяне на нов запис полето Запис # остава празно, а брояча не се променя. Потребителят е задължен ръчно да въведе желания номер на фактурата/известието.

Забележка: Смяната на полето Склад # във форма Фактури не води до промяна на номера на фактурата (Запис #).

Основни полета на формата

Запис # - пореден номер (идентификатор) на известието виж Номериране на известията.

Дата - дата на документа. Попълва се по подразбиране с текущата дата.

Тип - тип на документа - Кредитно или Дебитно.

Фактура # - идентификатор на фактура, която да бъде коригирана с известието. Задължително поле.

Плащане - статус на плащане на документа (валиден е само за Дебитните известия):

· Отворен - когато известието не е платено или е платено частично (полето Остатък за плащане>0.00).
· Затворен - известието е платено - има създадени записи във формата Плащания за пълната сума на известието.
· Затворен от служител - маркира се като платено, ръчно от служител.

Срок на плащане по фактура - срок на плащане според фактурата.

Изпиши/върни - указва коригираните бройки продукти да бъдат изписани/върнати от съответния на фактурата склад при записа на известието. Ако служителят не е МОЛ за съответния склад съответните складови операции се създават със статус Чакащ одобрение.

Анулирано - ако полето е селектирано, съответното известие е анулирано и не се включва в последващите обработки и представяния на данните.

Причина за известието (бълг.) - описание на причините за издаване на известието на български език.

Причина за известието - описание на причините на английски език.

Таблица Детайли на счетоводния документ

В таблицата се въвеждат данните за коригираните редове от фактурата:

No - пореден номер на реда от таблицата.

Фак. ред # - идентификатор на реда от фактурата, който ще се коригира.

Фак. ред No - пореден номер на реда от фактурата.

Продукт #, Код, Описание - идентификатор, код и описание на продукта от фактурата.

К-во - реално (коригирано) количество на сделката в съответната мерна единица (брой за изделията). Например ако имаме кредитно известие, количеството по фактура е 10 бр., а клиентът връща 3 бр. в полето трябва да въведем 7.

Ед. цена (без ДДС) - реална (коригирана) единична цена на сделката. Например ако имаме кредитно известие, цената по фактура е 10 лв. на брой но реалната цена е 7лв - искаме да възстановим по 3лв. на брой на контрагента - въвеждаме цена 7 лв. в полето.

Сума (без ДДС) - произведение на количеството и единичната цена.

Отстъпка % - реална (коригирана) отстъпка за реда в проценти.

Отстъпка (без ДДС) - реална (коригирана) сума на отстъпката за реда.

Корекция (без ДДС) - сума на корекцията (на известието).

Описание англ. - описание на изделието на английски език (отпечатва се в английската версия на известието)

Тип - тип на продукта - изделие, материал и т.н.

Сумарни полета

Данъчна основа - сума на известието.

ДДС %, ДДС сума - процент и сума на данък добавена стойност. Попълва се по подразбиране в зависимост от данните от фактурата.

Общо - сума на известието със ДДС.

Общо в лева - сума с ДДС в лева изчислено по валутния курс.

Дата на данъчното събитие - попълва се по подразбиране в зависимост от данните от фактурата.

Остатък за плащане - остатък за плащане по дебитно известие.


Форма -Плащания

Форма Плащания

Използва се за въвеждане и редакция на плащания.За общи указания за работа с форми виж.

Основни полета на формата

Запис- генерира се пореден номер от системата.

Дата- дата на плащането.

Клиент- избор на контрагент.

Валута- избор на валута.

Тип на плащане- избор на типа на плащане.

Да се плати на- избор на банкова сметка и обменен курс.

Бележки- въвежда се допълнителна информация относно плащането.

Таблица Платени документи- избор на документи към плащането.

Тип- тип на документа.

Док.#- идентификатор на документа.

Док.No- номер на документа.

Дата- дата на документа.

Сума по док.- обща сума за плащане по документа.

Сума- платена сума.

Остатък- баланс по плащането.

Сумарни полета

Сума(без ДДС)- общата сума на плащането без ДДС.

ДДС сума- сума на данък добавена стойност.

Общо (с ДДС)- сума на плащането с ДДС.

Групираща рамка Осчетоводяване

Отметка осчетоводяване-

Статус-счетоводен статус.

Клиент-клиентска сметка.

Валутен курс-валутен курс в зависимост от валутата на плащането.

Dt вал/лв-

Парична-

Ct вал/лв-

Референция-


Избор на продукти

Прозорец за избор на браузър

В много от формите и програмите на системата в полетата за избор от таблица се избира продукт (изделие,материал,инструмент или мерител), като се използва прозореца за избор на браузър:

Различните опции избираме като селектираме желаната икона и натиснем бутон Напред.

Конфигуриране на изделие

Използва се, когато се избира/създава конкретна конфигурация на конфигурируемо изделие чрез функцията-конфигуратор на програмата ПСИ. В случаите когато сме сигурни, че исканата конфигурация вече е създадена, тя може да бъде избрана и през опциите Избор на изделие или Браузър продукти,или ако е налична в склад през Браузър на склад.

Избор на изделие

Изделието се избира като се използва браузъра на изделия в програмата ПСИ.

Браузър продукти

Могат да бъдат избирани Материали/Услуги, Изделия, Инструменти и Мерители, с помощта на програмата Браузър продукти.

Браузър на склад

Идентификатора на продукта можа да бъде избран от складовите партиди чрез програмата Браузър на склад.


Програми


Модул Производство

 Top


Ценови листи

Програма Ценови листи

Служи за въвеждане и редакция на ценови листа. Използват за изчисляване и автоматично въвеждане на цени на продукти в различните модули на системата.

Лента с инструменти:

1. Избиране на ценова листа.
2. Добавяне на папка.
3. Преименуване на папка.
4. Изтриване на папка.
5. Промяна на цени на продукти в избраната папка.
6. Добавяне нова ценова листа.
7. Редактиране на ценова листа.
8. Клониране на ценова листа.
9. Копиране на селектирани редове от папка.
10. Поставяне на копирани редове в папка.
11. Разширено търсене на продукт по идентификационен номер или код.
12. Търсене по папки.
13. Запис на направените промени.
14. Копирай за Excel.
15. Въвеждане на отстъпки за продукти от ценовата листа.

Основни функционалности

Добавяне на нова ценова листа

Служи за добавяне на нова ценова листа с опция за глобална формула, която важи за всички продукти в ценовата листа.

Промяна на цени в папка

Използва се за промяна на цени на продукти в избрана папка с зададен процент.

Таблица с цени на продукти

Изделие-идентификатор на продукта.

Тип-тип на продукта.

Описание-описанието на продукта.

Цена- поле за въвеждане на цена.

Формула за корекция на цена

Формулата се въвежда, когато цената зависи от количествено/качествено изменение на характеристиките продукта. Резултата от формулата се добавя към въведената цена.

Пример:

iif(AttrValue("COVER") = "0", -ConstValue("CoverBGN"), 0)

Ако стойността на атрибута покритие "COVER" е равна нула, то добави в цената стойността на константата "CoverBGN" с знак минус, в противен случай добави 0.

Контролна формула

Формулата се въвежда , когато има нужда от ограничения по зададени характеристики на продукта или техните стойности за които съответства въведената цена.

Ст1..Ст5- полета за въвеждане на контролни стойности. Използват се във в контролни формулите за реда. Инициализират се във формулите като _cv1.._cv5

Пример:

AttrValue("SHAPE") = "F" & AttrValue("DIM_A") = _cv1

Цената за този ред се отнася само за продукти, чиято стойност на атрибута "SHAPE" е равна на "F" и стойността на атрибута "DIM_A" е равна на контролната стойност Ст1.

Въвеждане и промяна на цени на продукти в ценовите листи, добавяне на нови продукти и ценови листи.

1. Избира се ценова листа за съответната година или клиент. Ако няма такава за текущата година/клиент се създава нова или се клонира съществуваща ценова листа с ново име и се коригират всички разлики в продуктовия каталог и прилежащите им цени.
2. Ако е необходимо добавяне на нов продукт се избира папка съответстваща на вида му ,а ако няма такава се добавя нова в дървото с папки.
3. Добавянето на нов продукт се извършва от страничната лента с бутони. След натискане на бутона добави нов ред се отваря прозореца за Избор на браузър, от където можем да изберем желания продукт.


Тест на Ценови листи

Тест на Ценови листи

Използва се за проверка на цени на изделия и тяхното правилно изчисление на базата на формули в съответната ценова листа. Избира се ценова листа и изделие от ПСИ на изделията и се натиска бутона Изчисли.

Цена1 -сумата на основната цена на изделието и допълнителната цена калкулирана от формули.

Цена2-допълнителната цена добавена към основната цена със съответния знак.


Наличности и движение на продуктите

 Top

Движение на продуктите

Наличностите и движението на продуктите в производствените участъци се описват чрез хронологични и взаимосвързани продуктови операции. Всяка операция има идентификатор на продукт, количество в съответната мерна единица и тип, като количеството се интерпретира със знак плюс или минус в зависимост от типа на операцията. Условно можем да разделим операциите на:

· входящи - указват че съответното количество е постъпило в отдела (напр. Получено от склад, Произвдено)
· изходящи - указват че количеството от продукта е излязло от участъка или е било изразходвано (напр. Прехвърлено в друг участък, Използвано з производство и т.н.). Когато се въвежда изходяща операция, задължително трябва да се укаже входящата операция, по която продукта е постъпил в отдела, като съответно остатъчното количество по тази операция се намалява.

Наличността от даден продукт следователно се формира от сумата на остатъчните количества по всички входящи операции (поле Количество в таблицата Наличност).

Съществува и особен тип операции - Изравняване, които се интерпретират като входящи или изходящи в зависимост от знака на въведеното количеството.

Пълният набор от данни за продуктовите операции се задава във формата Движение на продукти по участъци.

Можем да разглеждаме и редактираме продуктовите операции като изберем раздел Наличности в браузъра.

Достъпни са два различни изгледа в зависимост от избрания бутон в лентата с бутони.

1. По папки - бутон Папки

В този изглед можем да избираме с отделни раздели различните типове продукти - Изделия, Инструменти, Мерители и Материали, и съответните им папки като информацията за операциите за продукти от избраната папка се показва в таблиците Наличност и Движение.

Таблица Наличност

В тази таблица се показват продуктите, които са били обект на движение в съответния участък, групирани по идентификатора на продукта и качеството.

# - идентификатор на продукт

Код - код на продукта (в случаите когато продукта не е изделие съвпада с идентификатора)

Описание - описание на продукта

Количество - налично количество в съответната мерна единица (виж по-горе)

Качество - качество на продукта (ако е зададено)

Таблица Движение

Показва продуктовите операции за продукта (със съответното качество) от селектирания ред в Таблица Наличност

# - идентификатор на операцията

Дата - дата на създаване на операцията

Код на операцията - код (наименование на типа) на операцията

Количество - количество със знак

Качество - ако е зададено

Статус - статус на операцията, чакащ или утвърден

Партида - номер на складова партида от която е взет продукта (за входящите операции)

Произв. парт. # - идентификатор на производствена партида (ако продукта е произведен)

Затв. - ако е селектирано указва че входящата операция е затворена т.е. остатъка е =0

Остатък - налично количество от входяща операция

Произв. опер. # - идентификатор на производствена операция за която е изрзходвано количеството (за изходящи операции от тип Използвано за производство или Изравняване при производство)

2. За всички продукти - бутон Преглед

В този изглед са достъпни четири филтъра за показваните операции

· По продукти - показани са таблиците Наличност и Движение за всички продукти.
· Чакащи утвърждаване - показана е таблицата Движение със всички операции със статус - "чакащ утвърждаване"
· Последни 100 - табицата съдържа последните 100 операции за участъка
· Всички - таблица с всички продуктови операции за участъка. При избора на тази опция, показването на данните може да отнеме значително време, в зависмост от големината на натрупаната база данни с продуктови операции.

Контекстно меню на таблица Движение

Независимо от режима (Папки или Преглед) е достъпно контекстно меню на таблицата Движение със следните опции:

Нова операция - отваря се форма Движение на продукти по участъци в режим на нов запис, като е попълнен избрания участък и продукта от избрания ред в таблицата.

Нова изходяща операция - отваря се форма Движение на продукти по участъци в режим на нов запис, като е попълнен избрания участък, продукта от избрания ред в таблицата и идентификатора на избраната операция - като операция източник на количеството. Опцията е валидна е само за входящи операции с ненулев остатък.

Преместване в склад - отваря се форма Движение на продукти по участъци в режим на нов запис, като е попълнен избрания участък, кода на операцията - Преместено в склад, продукта от избрания ред в таблицата и идентификатора на избраната операция - като операция източник на количеството. Опцията е валидна е само за входящи операции с ненулев остатък.

Преместване в участък - аналогично на Преместване в склад, като кода на операцията е Преместване в участък.

Отваряне операция - отваря се формата Движение на продукти по участъци за избраната операция.

Утвърждаване - установява се статуса на избраната операция(и) на Утвърден.

Изписване на продукти - тази опция се използва за автоматизирано създаване на изходящи операции за продукта от избрания ред на таблицата Наличност. Типа на изходящите операции, количеството и качеството на продукта, който се изписва се избира прозореца Изписване на продукти

Забележка: Операции от тип Използвано за производство могат да се създават само за продукти, които не са маркирани, че подлежат на контролирано изписване.

Лента с бутони

От лентата с бутони могат да бъдат извиквани следните функционалности:

Бутон Отваряне операция [image] виж.

Бутон Нова операция [image] виж.

Бутон Изписване по маршрутен лист (МЛ) [image] предлага две опции:

1. Изписване по маршрутен лист (МЛ). Тази функционалност позволява автоматизираното генериране на операции по изписване на продукти от участъка въз основа на Маршрутен лист. Използва се прозореца Изписване по маршрутен лист.

В полето Маршрутен лист # се въвежда (избира) идентификатор на одобрен Маршрутен Лист .

Бутонът Зареди попълва в таблицата всички продукти дефинирани, че трябва да бъдат изразходвани в съответният учатък според маршрутния лист.

Опер. # - номер на технологична поерация по маршрутния лист.

Продукт #,Описание - идентификатор и описание на продукта

К-во по МЛ - необходимо количество според маршрутния лист.

Остатък - разликата между необходимото и вече отчетеното като изразходвано по този маршрутен лист количество.

Кач. - качество

К-во - количество което ще бъде отчетено. Не може да е по-голямо от необходимото. По подразбиране се зарежда със стойността на остатъка.

Налични - налично количество от продукта в участъка.

Бутонът Нулиране се използва за корекция на вече изпълнено изписване. След натискането му и потвърждаване се изтриват всички продуктови операции за избрания маршрутен лист.

2. Изписване на групови опаковки. Използва се за изписване на груповите опаковки на изделията от монтажните участъци.

Кл. поръчка # - избира се номер на одобрена клиентска поръчка.

Бутонът Зареди попълва в таблицата всички групови опаковки дефинирани, че трябва да бъдат изразходвани за съответната поръчка. Ако липсват такива, могат да бъдат избрани от оператора в полето Продукт #.

Останалите полета са аналогични на съответните в прозореца Изписване по маршрутен лист.

Бутон Справки [image] - достъпни са следните справки в раздел Наличности, филтрирани по избраната папка от дървото:

· Наличности в участък - наличности на продуктите към дадена дата.
· Движение по продукти - вход-изход на продукти в участъка за избран период.
· Движение на продукти по операции - показва началните и крайни салда за период, както и джижението на продуктите групирано по различните видове продуктови операции.

Бутон Опресняване [image] - презареждане на данните, показани на екрана от БД.


Производствени операции

 Top

Разглеждането и действията с незавършените производствени операции в участъка става като се изберат разделите Произв. операции или Кооперирани операции. Пълния набор от данни за производствените операции се задава във формата Операции.

Раздел Производствени операции

Таблица Чакащи операции

В таблицата са показани всички производствени операции за участъка със статус Празен, Активна и В готовност.

ТГ (текущ график) - указва дали операцията да бъде включена в справката Текущ график (операции за неотложно изпълнение) в участъка.

# - идентификатор на производствената операция.

Партида # - идетификатор на производствена партида. При щракване се отваря формата Производствени партиди.

Кл. поръчка - списък на позиициите по клиентски поръчки, към които е операцията.

Дата за изд. - Дата за издаване на позицията от клиентската поръчка.

Код - код на технологичната операция. При щракване се отваря прозореца за разглеждане на технологична операция.

Операция - описание на технологичната операция.

Статус - статус на производствената операция.

Текуща заготовка - код на изделието - текуща заготовка на производствената партида. При щракване се отваря ПСИ на изделието.

Брой за изп. - бройки за изпълнение.

Брой за обр. - бройки за обработка.

План старт - планирано начало на операцията.

План край - планирано завършване на операцията.

План р. ед. - идентификатор на работна единица, на която е планирано да се извърши операцията.

Приоритет - приоритет на производствената поръчка.

Група раб. ед. - идентификатор и наименование на групата работни единици, на които ще се извърши операцията.

Печат - маркира дали паспорта на производствената партида е отпечатан.

Забележки - забележки към производствената операция.

Таблица Текущи операции

В таблицата са показани производствените операции в участъка със статус Стартирана, т.е. операции за които е отчетено че са започнали но все още не са приключили.

Полетата - #, Партида #, Кл. поръчка, Код, Операция, Текуща заготовка, Дата за изд., Забележки са аналогични на тези от таблицата Чакащи операции.

Бр. добри - отчетени произведени добри бройки за операцията.

Остатък - разликата между отчетените добри бройки от предходната операция (ако е първа - бройките за изпълнение) и отчетените до момента добри бройки.

Бр. настр. - отчетени бройки брак при настройка на машината.

Брак - отчетени бройки брак (несъответстващи на нормите за изделието) при производството.

Старт - отчетено начало на операцията.

Раб. единица - идентификатор на работната единица, на която се извършва операцията.

Контекстно меню на таблица Чакащи операции

Маркиране "в готовност" - установява статус В готовност на избраните операции със статус Активна.

Маркиране "затворена от служител" - установява статус Затворена от служител на избраните операции.

Добави към текущия график - маркира избраните операции като част от текущия график.

Премахни от текущия график - изключва избраните операции от текущия график.

Добави партиди към текущия график - маркира всички операции за избраните производствени партиди, като част от текущия график.

Печат паспорти - отпечатва паспортите на производствените партиди за избраните операции.

Раздел Кооперирани операции

В този раздел са включени производствените операции, които се извършват от външен изпълнител (кооперант).

Таблица Чакащи операции

Таблицата е аналогична на тази в раздела Производствени операции с изключение на полето План. кооперант, показващо името на контрагента по-подразбиране, който реализира операцията.

Таблица Текущи операции

Таблицата е аналогична на тази в раздела Производствени операции с изключение на полетата Изпратени и Получени показващи съответно бройките от изделието за обработка изпратени на кооперанта с експедиционни бележки и получените бройки.

Лента с бутони

От лентата с бутони могат да бъдат извиквани следните функционалности:

Бутон Отваряне операция [image] отваря формата Операции за избраната операция.

Бутон Материали и компоненти [image]. Отваря функционалност, която показва необходимите за производствените операции материали и компоненти. Достъпни са опции изчисленията да се направят за всички операции или само за избраните .

Прозорец Необходими материали, стартови заготовки и компоненти

Таблица Материали

# - Идентификатор на материал.

Описание - Описание на материала

К-во - Необходимо количество в съответната мерна единица

Налични - налично количество във всички складове и участъци

Налични в участъка - налично количество само в избрания участък

Свободни - свободно количество (раликата между наличното и заделено по производствени поръчки количество).

За получаване - разлика между необходимото и наличното в участъка количество.

Склад - идентификатор на склад, в който има налично количество от материала.

Таблица Алтернативни материали

Съдържа алтернативните според технологиите материали на изброените в таблица Материали.

Полетата са аналогични на горе посочените, като в полето Алтернативен за е даден идентификатора на кой материал от горната таблица се явява алтернативен материала от таблицата.

За да използваме в процеса на производство алтернативния материал, трябва да го изберем като селектираме полето Използвай и потвърдим с бутона Запис.

Таблицата в раздел Заготовки и компоненти е аналогична на тази за материалите, като съдържа необходимите за монтаж компоненти или стартови заготовки за обработка.

Прозорец Създаване на искане за отпускане на материални ценности

Прозореца се извиква от бутона Искане и позволява автоматизирано създаване на Искане за отпускане на материални ценности за избрани материали или компоненти (в зависмост от избрания раздел).

Поле Получател - попълва се идентификатор на служителя получател за искането.

За отдел - идентификатор на отдела получател.

Склад - идентификатор на склад от който ще бъдат отпуснати продуктите.

В таблицата са показани следните полета:

Продукт # - идентификатор на продукта.

Описание - описание на продукта.

К-во - необходимо количество.

Налични - налично количество във всички складове и участъци

Налични в участъка - налично количество само в избрания участък

Свободни - свободно количество (раликата между наличното и заделено по производствени поръчки количество).

За получаване - разлика между необходимото и наличното в участъка количество. Това поле може да бъде редактирано от оператора.

Избери - указва дали избрания ред да бъде включен в искането. Всички редове могат да се селектират/деселектират от полето Избери всички.

При натискане на бутона Запис се създава ново искане за отпускане на материални ценности към указания склад, с избраните продукти с ненулеви количества за получаване от таблицата.

Бутон Експорт в excel [image] - експортира данните от таблицата като таблица в MS Excell.

Бутон Комплектовъчен лист [image] - отпечатва справка Комплектовъчен лист за избраните продукти.

Бутон Справки [image] - достъпни са следните справки в раздели Производствени/Кооперирани операции:

· Текущ график - отпечатва операциите селектирани в текущия график за участъка по групи работни единици.
· Текущи операции - всички операции със статус В готовност или Стартирана за участъка, по изделия.
· Извършена работа в участък за деня - извършената работа за даден ден по производствени операции.
· Извършена работа в участък - извършената работа в участък за период по групи работни единици и технологични операции.
· Извършена работа в участък по изделия - извършената работа в участък за период по групи работни единици, технологични операции и изделия.
· ОТК операции в готовност - ОТК операциите със стаус В готовност, по участъци.


Инструментална екипировка

 Top

Движението на инструменталната екипровка, групирано по инструменти и за избран период, може да бъде разгледано в раздела Инструментална екипировка.

Времевият период може да бъде зададен чрез избор на датите и натискане на бутона Покажи.

Таблицата съдържа следните полета:

Код - идентификатор на инструмент

Описание - описание на инструмента

Начално к-во - изчислено налично количество от инструмента в участъка към началната дата на периода.

Изравняване - сума на операциите от тип Изравняване

Получено от склад - сума на операциите от тип Получено от склад

Получено от участък - сума на операциите от тип Получено от участък

Предадено в склад/участък - сума на операциите от тип Прехвърлено в склад/участък

Бракувано - сума на операциите от тип Бракувано

Предадено за бракуване - сума на операциите от тип Предадено за бракуване (за инструменти с контролирано изписване).

Използвано за ремонт - сума на операциите от тип Използвано за ремонт

Амортизирани за периода - брой амортизирани инструменти за периода, изчислени на база на амортизационната норма за производствените операции зададена в технологията.

Крайно к-во - изчислено налично количество от инструмента в участъка към крайната дата на периода.


Модул Склад


Програма Браузър на склад

Браузър на склад

Програмата предоставя детайлна информация за наличности на изделия и продукти в съответните партиди и извършените складовите операции към тях.

Лента с инструменти.

1. Склад- избор на склад.
2. Разглеждане на избраната партида .
3. Опресняване на данните.
4. Справки.
5. Търсене по папки.
6. Търсене.

Справки

Наличности по папки- всички наличности от продукти в избраната папка и съответния склад.

Получени продукти- справка за получени продукти за период.

Изписани продукти по искания- справка за изписани продукти по искания в избрана папка и склад. Полета за избор на начална/крайна дата,отдел и доставчик и допълнителна отметка за съкратена версия(само продукт и количество).

Партиди по папки- справка за партиди в избрана папка и склад.

Наличности по атрибути-справка за наличности с допълнителни полета за избор на качество и атрибути.

Получени по атрибути-справка за получени продукти с допълнителни полета за избор на период, качество и атрибути.

Отпуснати по атрибути- справка за отпуснати продукти с допълнителни полета за избор на период,отдел,доставчик,качество и атрибути.

Движение по сч. сметки- справка за движение на продукти по счетоводни сметки.

Наличности към дата всички складове- обща справка за наличности към дата във всички складове.

Изписани продукти по фактури- справка за изписани продукти по фактури за период.

Счет. наличност всички складове- справка за счетоводни наличности в всички складове.

Търсене

Дава възможност за разширено търсене по различни характеристики.

Тип- тип на продукта.

ID-идентификатор.

Код изделие- код.

Описание-описание на продукта.

От-начална дата на създаване на партидата.

До дата- начална дата на създаване на партидата.

Парт. №- номер на партида.

Произв. парт.-номер на производствена партида.

Позиция- позиция в склада.

Отметки:

· За утвържд.- търсене на партиди със статус за утвърждаване.
· Точно съвпадение- търсене на точно съвпадение с въведените данни.
· Затворени- търсене на партиди със статус Затворена.

Таблица Партиди- показва всички партиди в избраната папка.

Партида#- номер на партида.

Кл. поръчка- номер на клиентска поръчка.

Произв. парт.#- номер на производствена партида.

Количество- количество на продукта.

Създадена- дата на партидата.

Движение- дата на последно движение.

Продукт- идентификатор на продукта.

Код- код на продукта.

Описание- описание на продукта.

Тип-тип на продукта.

ОТКСтатус- статус на одобрение

Качество- качество на продукта.

Склад-име на склада

Позиция в склада

Групираща рамка Наличности - налични и свободни количества от избрания продукт, разделени по качество

Таблица Операции- предоставя данни за всички операции извършени в селектираната партида.

Дата- дата на създаване на операцията

Код на операцията- вид на операцията

Количество- получено/отпуснато количество със съответния знак

Статус- статус на операцията.

Източник- идентификатор на източника.

Забележки- забележки относно извършената операция.


Форма - Партиди

Форма - Партиди

Предназначение:

За въвеждане и редакция на партиди към складове и регулация на наличностите посредством операции.За общи указания за работа с форми виж.

Основни полета на формата:

Склад #- избор на склад.

Продукт#- избор на продукт от Браузъра на Продукти.

Партида#- идентификатор на партидата.

Позиция в склада-

Налично количество- налично количество от продукта в съответната измервателна единица.

Статус - статус на партидата.

Произв. партида#- избор на производствена партида.

Групираща рамка ОТК- Ако статуса подлежи на одобрение-идентификатор на служител проверил качеството на партидата, дата на одобрение и качество.

Таблица Операции върху партидата

Дата- дата на складовата операция.

Количество- количество от продукта.

Заприходено количество- заприходено количество със съответния знак за калкулация в зависимост от вида на операцията.

Код на операцията- описание на складовата операция.

Източник #- идентификатор на източника (искане, експедиционна бележка,преместване в друг склад)

Статус:

· Отворена-
· Чакащ-
· Изпълнен-

Бележки-допълнителна информация относно операцията.

Меню Изпълни

Изпълни програма:

· Премести партидата в друг склад-преместване на текущата партида в друг склад.
· Категоризация-избор на качество за съответни бройки в партидата.

Справки-отпечатване на справки.


Форма - Дефиниции на складове

Форма - Дефиниции на складове

Форма за въвеждане и редакция на дефиниции на складове.За общи указания за работа с форми виж.

Основни полета на формата

Сkлад#- идентификатор на склада.

Име на склада- име.

Счет. номер-

Базов номер на ф-ри- възможност за задаване на различни базови (стартови) номера на фактурите за различните складове

Фрейм № на брояча-

Отдел#- отдел отговарящ за склада.

Описание-кратко описание, особености.

Локация- местоположение на склада.

Каса BGN-номер на сч. сметка.

Отметки:

· Готова продукция-
· Не се сумира-
· Отпаднал-

Таблица Отговорници на склада

Избират се служители отговарящи за склада.


Форма-Искане за отпускане на материални ценности

Форма-Искане за отпускане на материални ценности

Форма за създаване и редакция на искания за отпускане на материални ценности, експедиционни бележки към контрагенти и изписвания в друг склад.За общи указания за работа с форми виж.

Основни полета на формата

Искане#-идентификатор на искането(генерира се от системата)

Тип:

· Искане за отпускане на материални ценности-
· Експедиционна бележка-
· Изписване в друг склад-

Статус:

· Чакащ-не са изпълнени необходимите операции върху склада.
· Изпълнен-
· Отхвърлен- искането е отхвърлено

Причина за искането- кратко описание на причината за искането.

Дата- дата на искането.

Склад#-избор на склад.

Счет. тип:

· Материали по произв. технологии-
· Други спомагателни материали-

Експед. бел. тип:

· Продажба на консигнация-
· Кооперирана операция-
· Рекламация по протокол-
· Мостри-
· Изпратено на контрагент-

Таблица Отпуснати продукти- избор на продукти от Браузър на склад.

Продукт#- идентификатор на продукта

Тип-тип продукт.

Код- код на продукта (за материалите съвпада с идентификатора).

Описание- подробно описание на продукта.

Партида#- идентификатор на партидата.

Пр. парт. - идентификатор на производствената партида.

Операция-идентификатор на операцията.

К-во- количество за отпускане.

Кач.- качество на продукта

Налични на склад - налични на склад в избраната партида

Свободни- свободни количества.

Тех. нареждане-техническо нареждане към искането.

Машина#-инвентарен номер на машина, инструмент, мерител.

Бележки- бележки относно искането

Таблица Операции върху склада- операции извършени върху съответните партиди.

Дата-дата на операцията.

Заприходено к-во- заприходено количество със съответния знак.

Статус- статус на изпълнение на операцията.

Партида- идентификатор на партидата, върху която е извършена операцията.

Код на операцията- наименование на операцията.

Групираща рамка Получено от:

Получател- идентификатор на служител-получател.

За отдел- идентификатор на отдел.

Нов склад- идентификатор на новия склад при изписване в друг склад.

Групираща рамка Изпратено на:

Контрагент#- идентификатор на контрагента-получател.

Групираща рамка Осчетоводяване

Отметка Осчетоводен-

С-ка разходи-

С-ка разпр.-

Сч. статус.-

Dt лв.-


Меню Справки

Справки:

Инвентарен опис/към дата

Наличности на продукти в избран склад/към крайна дата.

Получени продукти по складови разписки за период

Получени продукти в избран склад за период.

Получени продукти по складови разписки от доставчик

Получени продукти по складови разписки с избор на период, склад, и контрагент.

Получени продукти от участък/съкратена

Получени продукти от участък с избор на период, склад и участък.

Отпуснати продукти за период

Подробна справка за отпуснати продукти за период с избор на склад и отдел.

Отпуснати продукти за период/Искания

Справка за изписаните продукти за период сортирани по номера на искането с избор на склад и отдел.

Наличности по базово изделие

Справка за наличности по базово изделие с избор на склад.

Залежали партиди

Справка за залежали партиди в избран склад сортирани по тип на продукта.

Възли със стари версии

Справка за възлите със стари версии.

Експедиционни бележки по контрагенти

Справка за експедиционните бележки за период сортирани по идентификатора на контрагента.

Партиди без движение

Списък със партидите без движение в избран склад сортирани по тип на продукта.


Модул ПСИ

 Top

Enter topic text here.


Модул Закупуване на стоки и услуги


Форма - Плащания към доставчици

Плащания към доставчици

Форма - Плащания към доставчици

Използва се за въвеждане, редактиране и отпечатване на плащания към доставчици.За общи указания за работа с форми виж.

Запис#- идентификатор на плащането

Дата-дата на плащането

Тип на плащане-избор на тип плащане-По банков път/в брой.

Доставчик- идентификатор на контрагент - доставчик.

Валута- избор на валута

Групираща рамка Сметка на доставчика-Въвежда се име, адрес,IBAN и BIC

Групираща рамка Да се плати от

Банкова сметка- избор на банкова сметка от която да се извърши плащането

Обм.курс- обменен курс

Счет. с-ка- номер на счетоводната сметка

Име на банката-

Адрес на банката-

IBAN-

BIC-

Бележки-

Таблица Платени документи

Док.#- идентификатор на документа.

No- номер на документа.

Тип- тип на документа.

Дата- дата на документа.

Остатък(с ДДС)- остатък за плащане.

Сума(с ДДС)- платена сума.

Остатък- баланс по плащането.

Сумарни полета

ДДС сума-сума на данък добавена стойност.

Сума(без ДДС)-сума на плащането без ДДС.

Общо(с ДДС)-сума на плащането с ДДС.

Групираща рамка Осчетоводяване

Отметка осчетоводяване-

Статус-

Доставчик-сметка на доставчик от системата

Дост. по проф.-

Валутен курс-

Dt вал/лв-

Dt вал/лв-

Парична-

Ct вал/лв-

Референция-


Форма - Заявки за закупуване на стоки

Форма - Заявки за закупуване на стоки

Форма за въвеждане и редакция на заявки за закупуване на стоки. За общи указания за работа с форми виж.

Заявка#- генерира се от системата.

Дата на заявката- дата на документа.

Доставчик#- идентификатор на контрагент - доставчик.

Контакт#- идентификатор на контакт за връзка.

Начин на плащане- по банков път/в брой.

Условия на плащане- условия на плащане.

Срок на доставка(дни)- брой дни за доставка.

Статус - статус на заявката.

· Нов- заявката е в процес на дефиниране.
· Чакащ одобрение-заявката чака одобрение от съответната дирекция.
· Одобрен-заявка е одобрена.
· Неодобрен-заявката е неодобрена.

Статус получаване:

· Отворен-заявката е в процес на изпълнение.
· Затворен-заявката е изпълнена.
· Затворен от служител-маркира се ръчно от служител.

Срок на доставка-краен срок за доставка.

Групираща рамка Адрес на доставчика- автоматично се попълва адреса по регистрация на избрания доставчик.

Бележки- бележки относно заявката.

Групираща рамка Търговска дирекция- име и идентификатор на служител от Търговска дирекция одобрил заявката към дата.

Групираща рамка Икономическа дирекция- име и идентификатор на служител от Икономическа дирекция одобрил заявката към дата.

Таблици:

Заявени продукти- таблица за въвеждане на продукти и статус на изпълнение на заявката.

Количества и дати на получаване- таблица за въвеждане на количества и дати на получаване на заявените продукти.

Сумарни полета:

Обща цена-обща цена на заявените продукти в избраната валута.

ДДС-сума данък добавена стойност.

Всичко-сума на заявката със ДДС.


Форма - База данни получени продукти

Форма - База данни получени продукти

Комбинирана форма позволяваща бърз достъп до данни свързани с получаване на продукти. Съдържа разделители за директна връзка с формите -Получаване на продукти, Партиди и Фактури/проформи от доставчици.


Форма - Получаване на продукти и услуги

Форма - Получаване на продукти и услуги.

За общи указания за работа с форми виж.

Разписка#- идентификационен номер на разписката

Тип-

· Счет. документ с опис на продуктите-
· Кооперирани операции и други-

Дата-дата на разписката.

Склад-идентификатор на склада

Отдел-идентификатор на отдела.

Отметка Приемане в склад-

Групираща рамка Счетоводен документ

Док.#- идентификатор на документа

Тип-

· Фактура
· Справка

Групираща рамка Несчетоводен документ

Док. N-номер на документа.

Описание-информация относно документа.

Доставчик - идентификатор на контрагент - доставчик.

Таблица Получени продукти

Документ#- идентификатор на документ.

Заявка#- идентификатор на заявка.

Произв парт#- идентификатор на производствената партида.

Продукт#- идентификатор на продукта.

Тип- тип на продукта.

Код- код на продукта от системата.

Описание- пълно описание на продукта.

Получено количество- получено количество от продукта.

Отметка Рекламация-

К-во по счет. док.- количество по счетоводни документи.

Остатък по счет.док.- остатък по счетоводни документи.

Поръчано к-во- общо поръчано количество.

Остатък по поръчка- оставащо количество по поръчката.

Поз. в склада-позиция в склада

Партида на доставчика-

Търг. код.-

Търг наименование-

Партида#-

Статус на партидата-

Опер. по произв. партида-

Отметка Анулирана-


Форма - Дневни заявки

Форма - Дневни заявки

За общи указания за работа с форми виж.

Заявка #- идентификатор на заявката.

Дата на заявката- датата на дневните заявки.

Статус Получаване:

· Одобрен-
· Неодобрен-

Статус:

· Отворен -
· Затворен-

Групираща рамка Търговска дирекция- име и идентификатор на служител от Търговска дирекция одобрил заявката към дата.

Групираща рамка Икономическа дирекция- име и идентификатор на служител от Икономическа дирекция одобрил заявката към дата.

Таблица Заявени продукти без планова заявка- съдържа всички продукти заявени за деня, без планови заявки.

Таблица Заявени продукти към планова заявка- съдържа всички продукти по планови заявки.

Групираща рамка Плащания в Брой BGN

Искана сума- обща искана сума по дневните заявки.

Одобрена сума-одобрена сума по дневните заявки.

Дължимо-обща дължима сума.

ДДС-данък добавена стойност.

Обща цена- сумата на всички цени на продукти от текущата заявка.

Групираща рамка Плащания по банков път- общата сума,валута платена по банков път.


Форма - Искане за закупуване

Форма Искане за закупуване.

Форма за въвеждане и редакция на искания за закупуване на продукти.За общи указания за работа с форми виж.

Искане#- идентификатор на искането(генерира се от системата).

Дата- дата на създаване.

Изготвил - потребител изготвил искането.

Групираща рамка Одобрение- ръководител на отдел, одобрил искането към дата.

Таблица Искани продукти

В таблицата се въвеждат продукти от Браузъра на продукти и количества.

Статус:

-Приет

-Неприет

Отметка От планова заявка -маркира се, когато продукта е от планова заявка.

Таблица Прикачени документи

Таблица за избор на прикачени документи свързани с искането.


Форма - Фактури /проформи от доставчици

Форма - Фактури /проформи от доставчици

Форма за преглед и редакция на фактури и проформи от доставчици.

Запис#- пореден номер (идентификатор) на записа.

Тип- тип на записа - Фактура или Справка/Протокол.

Документ No- номер на документа.

Дата- дата на записа.

Статус Получаване:

· Отворен-
· Затворен-
· Затворен от служител-

Статус Плащане:

· Отворен- няма извършено пълно плащане към контрагента.
· Затворен- създадени са плащания по документа в Плащания към доставчици.

Статус:

· Чакащ одобрение- записа чака одобрение от служител на Икономическа дирекция.
· Одобрен- записа е одобрен.
· Неодобрен- записа е неодобрен.

Таблица Проформи

Отметки:

· Оригинал?-
· Маркирай, че продуктите/услугите са получени/извършени-

Изготвил-служител изготвил записа.

Получена на - дата на получаване.

Групираща рамка Икономическа дирекция-идентификатор на служител одобрил записа към дата.

Доставчик- идентификатор на контрагент-доставчик.

Отметка Маркирай като платена-

У-я на плащане#- идентификатор на условията на плащане.

У-я за ДДС-условия за данък добавена стойност.

Таблица Авансови Фактури- съдържа данни за авансови фактури към текущия запис и сумата без ДДС.

Таблица Срокове за плащане- съдържа данни за срока на плащане и сумата с ДДС

Таблица Продукти и услуги-

Попълни от проформи-

Сумарни полета:

Сума- сума без ДДС и без отстъпка в избрана валута.

Отстъпка%- отстъпка в проценти.

Отстъпка- сума на отстъпката.

Сума по авансови фактури(без ДДС)- обща сума по авансови фактури(без ДДС).

Дата на данъчно събитие

Данъчна основа-сумата без ДДС с извадена отстъпка.

ДДС%- данък добавена стойност в проценти.

ДДС- сума данък добавена стойност.

Остатък за плащане- остатък за плащане по документа.

Общо- общо заплатена сума.

Таблица Получени продукти и услуги-таблицата съдържа получените продукти и услуги от съответния доставчик.

Групираща рамка Осчетоводяване-

Статус сч.-

Прот.#-

Валутен курс-

Ф-ра за транспорт-

Тип доставка -

ДК.-

Дан. осн. с ДК.-

Разходи разпр.-

Таблица Продукти-

Таблица Допълнителни разходи-

Доставчик -

Ct вал/лв-

Дост. по аванс-

Dt вал/лв-

Дост по проф-

Dt вал/лв-

Ct вал/лв-

Кредитори ВОП-

Дебитори ВОП-

Дост. на път-

лв-

вал/лв-

Dt лв-

Вид стока-

Бележки-


Форма - Кредитни/дебитни известия от доставчици

Форма - Кредитни/дебитни известия от доставчици


Програма Генератор на плащания

Програма -Генератор на плащания

Програмата се използва за автоматично генериране на плащания за съответните фактури.

Меню

Избор-

Справки-

Предишни плащания-съдържа информация за предишни плащания към избраната фактура

Неплатени документи- общ брой неплатени документи

Сума на остатъците- сума на всички остатъци за плащане в съответната валута.

Сума избрано-общата сума за плащане на избраните документи

Сума на отстъпките-обща сума на отстъпките за избраните документи.


Програма Планиране на доставките

Планиране на доставките

Лента с инструменти:

Изчисли-след избор на период и продуктова папка се изчислява средно месечното потребление за периода.

Excel-копиране на данните в Excel

Печат-преглед и печат.

Средно месечно потребление за-задава се предходен период за изчисление.

Отметка Покажи само за доставка-

Таблица Продукти

Идент#-идентификатор на продукта

Описание-пълно описание

К-во за доставка-количество за доставка .

Заделени за поръчка-количества заделени по поръчки .

Налични-налични количества.

Налични алтернативни-налични алтернативни продукти

Мин наличност-минималната наличност за периода.

Средно месечно потребление-средно месечното количество изчислено за съответния период.

Очаквано количество-очаквано количество за осреднения бъдещ период.

Очаквано алт. количество- очаквано алтернативно количество за периода.

Чакащи одобрение-количества чакащи одобрение.

Доставчик-име на доставчика.

Срок на доставка-брой дни за доставка.

Последна цена-последна цена на продукта.


Основни положения при създаване на „Възел дефиниция“

 Top

Атрибути – всеки възел дефиниция се характеризира от определен набор атрибути. Използвайки атрибутите с вариращи стойности (тези които нямат зададена конкретна стойност или имат само стойност по подразбиране) се постига многообразието от крайни изделия които могат да възникнат след конфигурирането на възела дефиниция.

Избора на подходящ набор от атрибути е основна стъпка при изготвяне на производствената спецификация на изделието. Възела може да има неограничен брой различни атрибути като разработващия дефиницията има следния набор от опции свързани с тях:

· Избор на атрибут и допустимо множество от стойности за него
· Избор на стойност на атрибута
· Опция която да позволява или забранява редактирането на избраната стойност.
· Формула за стойност на атрибута – формула посредством която, на базата на останалите атрибути и конкретни параметри на изделието, се изчислява стойността на атрибута
· Опция за включване на стойността на атрибута в кода на крайното изделие и описанието на стойността на атрибута в описанието на крайното изделие
· Опция за позициониране на атрибута в кода и описанието на крайното изделие

Възела дефиниция може да включва в себе си:

· Детайли
· Групи
· Възли
· Пакети
· Възел дефиниции

Като разработващия може да контролира тяхното използване и съвместимост посредством следните свойства:

· Опция - показва че изделието не е задължително за включване в крайната сборка и може да се игнорира в процеса на конфигуриране
· Количество – броя изделия включени в крайната сборка от този възел в дървото
o Мин – минимално количество – използва се когато в процеса на конфигуриране броя изделия включени в сборката е избираем
o Макс – максимално количество - използва се когато в процеса на конфигуриране броя изделия включени в сборката е избираем
· Формула за количество – формула по която, в съответствие със стойностите на атрибутите и характеристиките на възел дефиницията, се изчислява крайния брой изделия от този възел в дървото които ще бъдат включени в сборката
· Формула за съвместимост – използва се когато „естествената” съвместимост по атрибути не дава желаните резултати
· Включи описанието в описанието на сборката – конкатенира описанието на текущия клон в дървото към описанието на сборката
· Включи количеството в описанието на сборката – добавя информация за броя крайни изделия които влизат в сборката от този клон на дървото
· Добави цената в цената на сборката – използва се при формиране на цените на крайните изделия

Връзка между атрибути – списък от атрибути и техните стойности които характеризират връзката между възела дефиниция и текущия клон в неговото дърво. Обикновено се използват когато в основния възел дефиниция бива вложен друг възел дефиниция и придават контекстни стойности на атрибути на вложеното изделие.


Видове изделия и дефиниции

 Top
· Група – дефиниция на множество от елементи. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на групата е да предостави механизъм за избор на точно един елемент от множеството което дефинира.
· Пакет – дефиниция на множество от елементи. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на пакета е да предостави механизъм за избор на всички елементи от множеството което дефинира.
· Възел дефиниция – дефиниция на изделие възел с променливи стойности на атрибутите. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на възела дефиниция е да предостави възможност за абстрактно представяне на множество от изделия от един тип но със различни стойности на атрибути (варианти на едно изделие). Процеса на конфигурация започва със конкретизиране на стойностите на атрибутите което в последваща фаза води до конфигуриране на крайно изделие с точно определени атрибути и код.
· Клас детайли - дефиниция на множество еднотипни детайли различаващи се само по стойностите на своите атрибути. Не съдържа в себе си други елементи. Целта на детайла дефиниция е да предостави възможност за генериране на голям брой еднотипни изделия (обикновено обединени под общ номер и чертеж ), с общ набор от атрибути, различаващи се само по стойностите на атрибутите.
· Детайл – крайно единично изделие. Точно определен набор от атрибути и конкретни стойности.
· Възел – крайно изделие – сборка. Възел от детайли и други възли с точно пределен набор от атрибути и конкретните им стойности.


Модул Управление на взаимоотношенията с конрагенти

 Top

Enter topic text here.


Модул Производство


Акт за брак

Форма – Акт за брак

Използва се за въвеждане, редактиране и отпечатване на актове за брак. В полетата на формата се въвеждат всички необходими данни за отчитане на актовете за брак. За общи указания за работа с форми виж.

Типове актове за брак.

Достъпни са три типа актове за брак, които се задават от полето Тип – „От производство”, ”Материали”, ”Машини и инструменти”. Различните типове определят полетата, които се съдържат в таблицата с детайли на акта за брак (бракуваните продукти).

Основни полета на формата.

Статус – определя статуса на потвърждаване на акта за брак. Може да приема следните стойности:

· Нов – попълва се при създаване на нов запис.
· Чакащ утвърждаване – избира се от служителя когато всички данни са попълнени и проверени. Когато е зададен този статус промени на останалите данни не са допустими с изключение на полетата за утвърждаване и полето статус, което може да бъде върнато на статус Нов.
· Одобрен – задава се автоматично от системата когато са попълнени полетата Дата на одобряване от Началник отдел и Началник ОТК.

Причина за допускане – попълва се от служителя зададен в Нач. на отдел с данни за причините за допускане на брака.

Заключение - попълва се от служителя зададен в Началник ОТКК.

Таблица с детайли за тип – „От производство”

Раб. у-к – номер на работния участък в който е възникнал брака.

Пр. Парт. # – идентификатор на производствена партида от която е брака

Партида No – номер на складова партида, ако брака е отчетен след приемане на продукта в склад.

Продукт # – идентификатор на бракуваното изделие. Задължително поле. За начините за избор на изделие виж....

Опер. # на възникване – идентификатор на производствена операция при която е възникнал брака.

ОТК опер. # - идентификатор на производствена операция от тип ОТК на която е отчетен брака.

Отчетени несъотв. – брой изделия от указаната производствена партида които са били отчетени като несъответстващи в процеса на отчитане на производствените операции в програмата Отчитане на операциите.

Нал. в склад – налично количество от изделието в склад, което се изчислява по следния начин подредено по приоритет на изчисляване:

· ако е зададен номер на складова партида – наличните бройки от партидата;
· ако е зададен идентификатор на производствена партида - наличните бройки от всички складови партиди съответстващи на дадената производствена партида.
· ако не е зададена складова или производствена партида – наличните количества във всички складове

Нал. в участък – налично количество от изделието в работния участък зададен в полето Раб. у-к, като ако не е зададен раб. участък се изчислява наличното количество във всички участъци.

К-во – количество за бракуване.

Раб. е-ца – идентификатор на работна единица на която е възникнал брака.

Причина # - идентификатор на причина за брак от списъка с дефинирани причини, като в полето Бележки се попълва описанието на причината.

Намали склад – указва количеството да бъде изписано от складовата партида с операция „Бракувано”. Виж т. Операции с данните при запис.

Намали участък – указва количеството да бъде изписано от наличните в участък с операция „Бракувано”. Виж т. Операции с данните при запис.

Забележка. Намаляване на количествата в склад или участък се налага ако съответните бройки към момента на запис на акта за брак се водят налични (добри) в участък или складова партида. Ако те са отчетени като несъответстващи в процеса на производството излизат в полето Отчетени несъотв. не се налага намаляване. Намаляване на склад не е възможно ако не е зададена складовата партида.

За преоценени – идентификатор на склад за преоценена продукция (F12 –попълва стойност по подразбиране)

Процедури с данните при запис

При запис на акта за брак се извършват следните операции с данни.

· Ако статусът е „Чакащ одобрение” се изпращат уведомителни съобщения до служителите указани в Нач. отдел и Началник ОТКК.
· Ако статусът е „Чакащ одобрение” и полетата Дата на одобряване от началник отдел и началник ОТКК не са попълнени, както и ако са избрани Намали склад, Намали участък и/или За преоценени се създават съответните продуктови операции в складовете и/или участъците (при недостатъчни количества се издава съобщение и се спира записа на данните).


Форма - Движение на продукти по участъци

Форма - Движение на продукти по участъци

Използва се за дефиниране на продуктови операции в отделите с контрол на движението на продукти (производствени участъци). За общи указания за работа с форми виж.

Основни полета на формата.

Операция # - идентификатор на операцията - задава се от системата.

Произв. участък - идентификатор на отдел.

Продукт # - идентификатор на продукт. Виж Избор на продукти.

Бележки - бележки към операцията.

Количество - количество на продукта за операцията в съответната мерна единица и количество със знак определен от вида на операцията.

Вид операция - вида на операцията определя дали съответното количество ще бъде взето със знак плюс или минус, съответно дали количеството от продукта в участъка ще бъде увеличено или намалено.

· Изравняване - използва се за изравняване на количествата при начална инициализация или корекция на грешки. Количеството може да бъде въведено със знак плюс или минус в зависимост в коя посока искаме да изравним.
· Преместено в склад (изходяща) - прехвърляне на продукт към склада указан в полето Към склад. При запис в съответния склад се създава складова партида с указаното количество.
· Получено от склад (входяща) - получено количество от склад с Искане за отпускане на материални ценности.
· Получено от участък (входяща) - прехвърляне на продукти от друг участък.
· Преместено в участък (изходяща) - прехвърляне на продукти от друг участък указан в полето Към участък.
· Произведено (входяща) - произведени изделия в участъка.
· Използвано за производство (изходяща) - използвани за производство продукти според технологиите. Не е достъпно за избор при ръчно създаване на операция.
· Отпадък от производство (входяща) - продукти отпадък при производството.
· Бракуване (изходяща) - изписване на продукти като брак.
· Продажба (изходяща) - изписване като продажба.
· Изравняване при производство (входяща/изходяща) - корекция на използвано за производство количество. Не е достъпно за избор при ръчно създаване на операция.
· Върнато за доработка (входяща) - получено количество от изделие за повторно изпълнение на производствена операция в участъка.
· Използвано за ремонт (изходяща) - използвани продукти за ремонт на оборудване и др.
· Издадено за бракуване (изходяща) - използва се за връщане към склада указан в полето Към склад, на амортизирани продукти с контролирано изписване с цел бракуването им.

Създадена от - идентификатор, име на служителя и дата на създаване.

Статус - статус на операцията (Чакащ или Изпълнен).

Произв. операция - идентификатор на производствена операция в следствие на която е генерирана продуктовата операция.

Статус променен от - идентификатор, име на служителя и дата на промяна на статуса.

Генерирана операция - указва дали операцията е автоматично генерирана от системата.

Източник - идентификатор на източника на операцията (в контекста на генерация)

Марш. лист # - идентификатор на маршрутен лист, в следствие на който е генерирана операцията виж.

Кл. поръчка # -идентификатор на клиентска поръчка, в следствие на която е генерирана операцията (при изписване на групови опаковки виж).

Складова партида - идентификатор и номер на складова партида, от която е продукта.

Произв. партида - идентификатор на производствена партида, от която е продукта.

Статус наличност (Отворена/Затворена) - валидно само за входящи операции, указва дали по операцията има налично количество достъпно за изходящи операции.

Взето от опер. - валидно само за изходящи операции, идентификатор на операция - източник, входяща операция от която е взето количеството и номер на складова партида.

Остатък - налично количество по операцията източник.

Процедури с данните при запис

При запис статусът на операцията-източник се променя на Затворен ако наличното количество (Остатъка) стане равно на 0.


Форма - Производствени партиди

Форма Производствени партиди

Производствената партида дефинира неделимо количество от изделия (например съдържащи се в един контейнер), които се произвеждат от основен материал или заготовка, преминавайки през последователни технологични операции. Изходното изделие на партидата може да бъде, както крайното изделие на производствената поръчка така и междинна заготовка, която подлежи на последваща обработка, дефинирана в производствена партида от следващ етап. За общи указания за работа с форми виж.

Основни полета на формата

Партида # - идентификатор на партидата. Формира се от идентификатора на производствената поръчка, двуцифрен номер на етап и трицифрен номер на партидата в етапа.

Етап - при ръчно създаване на производствена партида в полетата Поръчка #, Етап No и Етап # се въвеждат съответните идентификатор на производствена поръчка, номер и идентификатор на етап които служат за генериране на идентификатора на партидата.

Партида No - номер на партида в етапа.

Отпечатан - ако е селектирано указва, че паспорта на партидата е отпечатан на последната стъпка от генерацията на поръчката.

Стартова заготовка - идентификатор, код описание и количество на изделие - стартова заготовка за партидата. Полето е празно за партидите стартиращи от основен материал и такива за монтаж.

Текуща заготовка - идентификатор, код и описание на изделието, което се получава при производството на партидата.

К-во партида - необходимо количество изделия за партидата.

Статус - статус на производствената партида:

· В производство - партидата е в процес или чака започване на производството.
· Затворена - партидата е приключена.
· Затворена от служител - партидата е затворена служебно от служител.
· С откл. продължава - партидата е маркирана от ОТК служител, че е с по-малко от необходимите добри бройки, но производство и продължава.
· С откл. спира - партидата е маркирана от ОТК служител, че е с по-малко от необходимите добри бройки, и производство и спира.

Дата за изп. - дата за изпълнение на клиентската поръчка.

Мин. старт дата - дата, не по-рано от която да започне производството на производствената поръчка.

План старт дата, План. произв. дата, - планирани дата за стартиране и приключване на партидата.

Приоритет - приоритет на производствената поръчка (Нисък,Нормален,Висок,Спешен).

Изработени бр. - отчетени изработени изделия на последната операция от партидата.

Бележки – текстово поле за въвеждане на пояснителна информация относно текущата производствена партида.

Следв. партиди - списък на производствените партиди (една или повече), които се явяват продължение на обработката на текущата в следващия етап на производствената поръчка(и).

Кл. поръчки - списък с позиции от клиентски поръчки, към които е свързана партидата.

Таблица Производствени поръчки

В таблицата са показани връзките на партидата към производствени поръчки.

Произв. п-ка # - идентификатор на производствена поръчка.

No етап - номер на етап, към който е партидата.

К-во % от поръчка - процентно отношение на количеството на партидата към общото количество на производствената поръчка.

Изделие - код на изделието за производствената поръчка.

Таблица Операции

# - идентификационен номер на производствената операция. Поле за връзка водещо към формата за редакция на производствени операции

No – пореден номер на производствената операция в текущата партида.

Код – кода на технологичната операция.

Операция – наименование на технологичната операция.

К-во за изп. – броя изделия необходими за успешното завършване на производствената операция.

К-во за обр. – оценка за броя детайли подлежащи на обработка за покриване на количеството за изпълнение, включва в себе си предварително заложената оценка за брой брак и бройки за настройка.

Бр. добри - отчетени изработени добри бройки за операцията.

Статус – статус на производствената операция.

Променен от, Променен на - служител и дата на установяване на текущия статус.

Осн. кооперант – външен подизпълнител по подразбиране на текущата производствена операция.

Движение на партидата - информация за складовите партиди, получени в резултат на текущата производствена партида според технологичния маршрут за изделието.

Таблица Заделени продукти

Таблицата съдържа заделените материали по операциите на партидата, заделените стартови заготовки или компоненти за партидите от тип сборка.

Операция - идентификатор на производствена операция по която е заделен материал.

Продукт #,Тип - идентификатор и тип на заделения продукт (материал,изделие).

Описание - описание на продукта.

К-во - заделено количество в съответната мерна единица.

Качество - минимално качество изисквано за продукта.

Таблица Алтернативни изделия

В тази таблица, за партидите от тип сборка могат да бъдат задавани алтернативни изделия на компонентите, които ще се използват при монтажа на изделието вместо зададените по спецификация.

Основен # - идентификатор на изделието компонент по спецификация.

Алтернативен # - идентификатор на изделие, с което ще бъде заменен основния компонент.

Алт. к-во - ако полето е празно, при монтажа ще бъдат използвани толкова бройки от алтернативния компонент, колкото е броя на основния по спецификация. Ако има зададена стойност, за партидата ще бъдат използвани толкова бройки колкото са зададени в полето. Стойност (-1) означава, че основния компонент няма да бъде използван (независимо от идентификатора на алтернативния).

Таблица Допълнителни изделия

Някои технологични маршрути дефинират производствени партиди, които като резултат от производството имат две или повече различни изделия. В този случай едното изделие (условно наречено основно) е текущата заготовка на партидата, а останалите се описват в таблицата Допълнителни изделия.

Изделие #,Описание - идентификатор и описание на допълнително изделие.

Ст-т % - процентно отношение на изделието към общата стойност на използваните материали и заготовки за изработване на партидата. Използва се за изчисляване на себестойността на изделията.

Процедури с данните при запис

При запис в зависимост от статуса на партидата и операциите се преизчисляват заделените продукти, както и статуса на производствените поръчки свързани с партидата.

Програми извиквани от менюто Изпълни програма

Промяна на технологията

Тази функционалност позволява промяна на технологията на една или няколко партиди от етап, например при авария на машина и др.

Могат да бъдат избрани опциите:

Само текущата партида; всички партиди от етапа или избрани партиди с номера от до даден интервал.

Нова технология се избира от дървото с маршрути на прозореца Избор на технология. След избора на маршрут всички производствени операции на партидата се прегенерират.

Забележка. Промяна на технологията е допустима само за производствени партиди, за които производството не е стартирано.

Промяна на количеството

Количеството на партидата може да бъде увеличено или намалено като разликата (със знак плюс или минус) се въведе в полето Корекция.

Забележка. Промяна на количеството е допустимо само за производствени партиди, за които производството не е стартирано.

Добавяне на опционална операция

Опционални производствени операции, освен като част технологичен маршрут, могат да бъдат добавяни при необходимост в процеса на производството (например при нужда от допълнителна обработка на изделието) от диспечерите на производството.

Добави след - пореден номер, код и описание на производствената операция от текущата партида след която да бъде добавена нова опционална операция. Поредните номера на всички последващи операции ще бъдат увеличени с единица.

Бройки за обработка - брой изделия подлежащи на обработка за опционалната операция.

В готовност - ако е селектирано, операцията се създава със статус В готовност.

Техн. операция - идентификатор и описание на технологичната операция.

Разделяне на производствена партида

При необходимост (напр. само част от партидата да продължи от дадена операция нататък), една партида може да бъде разделена на две независими производствени партиди.

Партида # - идентификатор на текущата производствена партида.

К-во парт. - количество на текущата партида.

% - процентно отношение на новозададеното количество на текущата и новата партида спрямо общото.

Разделяне Парт. 1,2 - количества на двете партиди след разделянето съответстващо на зададения процент.

Опция Само текущата - разделя се само текущата партида.

Опция Всички следващи - освен текущата, ще бъдат разделени и партидите съответстващи на текущата във всички последващи производствени етапи.

Копиране на стартова заготовка и алтернативни изделия

С тази функционалност промяната на стартова заготовка или алтернативни изделия в таблицата Алтернативни изделия на текущата партида, може да бъде пренесена върху всички други или избрани партиди от етапа.

Забележка. Не се допуска промяна на стартова заготовка и алтернативни изделия за партиди, за които производството не е стартирано.

Справки

От меню Справки се извиква Паспорт на производствена партида


Форма - Производствени поръчки

Форма Производствени поръчки

Използва се за въвеждане, редактиране и разглеждане на производствени поръчки. Най-често производствените поръчки достъпни в тази форма са с произход програмата Генератор на производствени поръчки. За общи указания за работа с форми виж.

Типове производствени поръчки

Вътрешна – производствената поръчка и изделията които ще бъдат произведени от нея не са директно поръчани от клиент.

Клиентска – първичен инициатор на текущата производствена поръчка е клиентска поръчка.

Основни полета на формата

Пр. п-ка # - идентификационен номер на текущата производствена поръчка. Номера е автоматично заделен от системата и не може да бъде променян от потребителите.

Дата – датата на която е създадена текущата производствена поръчка.

Продукт # - идентификационен номер на изделието с което завършва текущата производствена поръчка. Заедно с този идентификационен номер, на формата присъстват и кода и описанието на това изделие, както и поле за връзка (Покажи) чрез което може да бъде отворена програма даваща детайлна информация за него.

К-во поръчка – количеството необходими за покриване на нуждите на вътрешната или клиентската поръчка.

К-во изпълнение – количеството необходимо за покриване на нуждите на вътрешната или клиентската поръчка, което включва в себе си и предвидените бройки за настройка както и очаквания брак.

Приоритет – приоритета с който трябва да бъде изпълнена текущата производствена поръчка. По подразбиране приоритета е Нормален. Другите възможни стойности са Нисък, Висок и Спешен.

Тип произв. – типа на произвежданото изделие

· Обработка – произвежданото изделие е детайл. Производствената поръчка започва с основен материал или детайл заготовка.
· Сборка – произвежданото изделие е възел който се състои от два или повече детайла/възела. Производствената поръчка започва с два или повече детайла/възела след асемблирането на които ще бъде произведено крайното изделие.

Статус:

· В производство - поръчката е в процес или чака започване на производството.
· Затворена - поръчката е приключена всички партиди са затворени.
· Затворена от служител - поръчката е затворена служебно от служител.

Категоризация – минимално качество на детайлите/възлите които могат да бъдат използвани при реализацията на текущата производствена поръчка. При не упоменато качество могат да бъдат използвани детайли от всяка категория. Водещо при определяне минималната категория качество на използваните детайли при производствени поръчки за клиент е стойността на полето за избор Категоризация от формата Доставчици и Клиенти от модул Управление на взаимоотношенията с контрагенти.

Бележки – текстово поле за въвеждане на пояснителна информация относно текущата производствена поръчка

Таблица Клиентски поръчки

Съдържа информация относно клиентските поръчки които са първоизточник на текущата производствена поръчка

# - идентификационния номер на клиентската поръчка.

Количество – броя детайли с които са заделени към тази клиентска поръчка

Таблици Свързани производствени поръчки

Сборки – списък с производствени поръчки от тип Сборка към които е свързана текущата производствена поръчка. Изделията произведени от текущата производствена поръчка ще бъдат използвани за асемблирането на изделията към производствени поръчки в този списък

Субкомпоненти – списък с производствени поръчки при текуща поръчка от тип Сборка. Изделията произведени към всяка от производствените поръчки в този списък ще бъдат използвани при асемблирането на текущото изделие(възел)

Текущи поръчки - използва се за – списък от производствени поръчки, които използват крайни изделия от текущата производствена поръчка като заготовки.

Текущи поръчки - използва от – списък от вътрешни производствени поръчки, от които текущата производствена поръчка ще използва заготовки.

Таблица Производствени партиди

Всяка производствена поръчка се състои от една или повече производствени партиди. Разделянето на производствени партиди се извършва от автоматично от програмата за генериране на производствени поръчки на база стойностите на полетата Максимално количество в партида и Минимално количество в партида от Производствената Спецификация на крайното изделие на текущата производствена поръчка. Тази таблица представлява списък от всички производствени партиди в текущата поръчка.

Парт. # - Идентификационен номер на производствената партида. Поле за връзка водещо към формата за редакция на производствени партиди.

No на етап – текущия етап на изработка на крайното изделие от поръчката. Реализацията на едно изделие се разделя условно на етапи на база маршрутите от технологичната му спецификация, които от своя страна отразяват различните частично завършени детайли през които преминава една изделие по време на производствения му цикъл.

No на партида – пореден номер на партидата в етап.

К-во за изпълнение – брой детайли/възли за изпълнение в текущата производствена партида.

Статус – статус на изпълнение на производствената партида.

Заготовка – код на изделието на партидата.

Таблица Операции

# - идентификационен номер на производствената операция. Поле за връзка водещо към формата за редакция на производствени операции

No – пореден номер на производствената операция в текущата партида.

Код – кода на технологичната операция.

Операция – наименование на технологичната операция

К-во за изп. – броя изделия необходими за успешното завършване на производствената операция.

К-во за обр. – оценка за броя детайли подлежащи на обработка за покриване на количеството за изпълнение, включва в себе си предварително заложената оценка за брой брак и бройки за настройка.

Статус – статус на производствената операция.

Осн. кооперант – външен подизпълнител по подразбиране на текущата производствена операция.

Процедури с данните при запис

При запис ако статусът на производствената поръчка е зададен Затворена от служител, със същия статус се маркират свързаните с нея незатворени производствени партиди и съответни операции.

Програми извиквани от менюто Изпълни програма

Клониране на производствената поръчка - създава точно копие на текущата, но без да бъдат генерирани производствени партиди и операциии. Използва се в случаите, когато искаме да създадем поръчка с ръчно въведени партиди и операции по нестандартен технологичен маршрут.

Изтриване на производствената поръчка - функционалност за изтриване на погрешно генерирана поръчка, като се изтриват и всички производствени партиди и операции, както и подчинените поръчки (за компоненти) съответно с техните партиди и операции.


Форма - Операции

Форма - Производствени операции

Използва се за въвеждане, редактиране и разглеждане на производствени операции. Най-често операциите които са достъпни в тази форма са част от производствена поръчка с произход програмата Генератор на производствени поръчки. За общи указания за работа с форми виж.

Основни полета на формата

Операция # - идентификатор на производствената операция. Състои се от идентификатора на производствената партида и двуцифрен пореден номер на операцията.

No - пореден номер на операцията в партидата.

Статус – текущото състояние на операцията:
· Празен - операцията е в процес на изчакване на изпълнение на предхождащите я операции
· Активна – операцията е активна и може да бъде приведена в готовност от диспечер на производството.
· В готовност – операцията е в готовност и работата по нея може да бъде започната от оператор.
· Стартирана – по тази операция се извършва текуща работа.
· Затворена – работата по тази операция е приключена и операцията е затворена автоматично от системата.
· Затворена от служител – работата по тази операция е приключила и операцията е била затворена от оператор.
· С отклонение продължава – има констатирани нередности с изработените детайли/възли но техния производствен цикъл няма да бъде прекъснат.
· С отклонение спира – има констатирани нередности с изработените детайли/възли което налага прекъсване на производствения им цикъл.

Тип - тип на технологичния маршрут, от който е част операцията - Обработка или Сборка.

Генерирана - указва дали операцията е генерирана от Генератора на производствени поръчки.

Опционална - ако е селектирано указва, че операцията е опционална. Опционалните операции могат да бъдат приведени в готовност само ръчно от диспечер на производството, както и не се изисква тяхното приключване за приключването (затваряне) на производствената партида.

Партида # - идентификатор на производствената партида.

Стартова заготовка - идентификатор, код, описание и брой на стартовата заготовка за партидата.

Текуща заготовка - идентификатор, код и описание на крайната заготовка за партидата.

Приоритет - приоритет на производствената поръчка.

Бележки - забележки в свободен текст към операцията.

Техн. операция - идентификатор, код и описание на съответстващата технологична операция. Полето за връзка Покажи отваря прозорец с подробна информация за технологичната операция.

Работен у-к – идентификатор и описание на работния участък (производствен отдел), в който ще бъде извършена текущата операция по технология.

Група раб. ед-ци – идентификатор и описание на групата работни единици за изпълнение на текущата производствена операция по технология.

Разделяне на заг. - коефициент указващ, че при текущата операция обработваното изделие се разделя на две или повече еднакви части, които подлежат на обработка в следващите операции и съответно се мултиплицират обработваните бройки.

Кооп. - ако е селектирано, означава че операцията се извършва от външен контрагент-подизпълнител (кооперирана операция).

Доставка (р. дни) - максимален срок за доставка (изпълнение на операцията) в работни дни, за контрагента по подразбиране на кооперирана операция.

Квал. за опер. - квалификационна група на служител в съответния работен участък за изпълнение на операцията - според технологичната операция.

Квал. за настр. - квалификационна група на служител в съответния работен участък за извършване настройка на машините за операцията - според технологичната операция.

Планирано - група от полета показващи планираните параметри на текущата операция:

Начало, Край - дата и час на планираните начало и край на работата по операцията според работния план.

Раб. единица - планирана работна единица, на която да се изпълни операцията според работния план.

Обработка - брой изделия подлежащи на обработка. Включени са бройките за настройка и технологичния брак.

Изпълнение - брой добри изделия които се очаква да бъдат резултат от операцията.

Настройка - предвидени бройки за настройка.

Контрол - минимален брой изделия, които трябва да бъдат проверени.

Брак - предвидени бройки брак.

Произв. (ч) - предвидено време за производство в часове.

ОВ сек/бр. - оперативно време (за обработка на една бройка) в секунди.

Настр. (мин) - време за настройка на машините в минути.

Контрол - предвидено време за проверка на качеството на изработените изделия в часове.

НВ сек/бр. - нормо-време в секунди на бройка. Време за изчисляване на заработката на оператора според технологичната операция.

Отчетено - група от полета показващи реалните данни, отчетени при изпълнението на текущата производствена операция:

Начало, Край - отчетени дата и час на започване и приключване на работата по операцията.

Изпълнение - изработени добри бройки.

Настройка - изразходвани бройки за настройка.

Контрол - брой проверени изделия.

Несъотв. - отчетени бройки несъответстващи на технологичните параметри на изделието

Производство (ч) - чисто време за производство в часове.

Настройка (мин) - отчетено време за настройка в минути.

Контрол (ч) - отчетено време за проверка в часове.

Таблица Извършена работа по операцията

Съдържа индивидуалните отчети на служителите (работни карти) за извършената работа по операцията, въведени чрез програмата Отчитане на операциите.

# - идентификатор на отчитането.

Начало – начален час и дата на работата.

Край – краен час и дата работата.

Служител #, Име – идентификатор и име на служителя.

Добри бр. – брой успешно произведени детайли/възли по тази работна карта.

Настр. бр. - изразходвани бройки за настройка.

Брак бр. - бройки несъответстващи на технологичните параметри на изделието.

Доработка бр. - бройки, които се нуждаят от повторна обработка.

ОТК бр. - брой проверени изделия.

Настройка - поле за отметка индикиращо, че работата е за настройка на машината.

Качество - качество на изработените изделия.

Раб. единица - работна единица на, която е извършена работата.

Причина за брак – идентификатор на причината, поради която детайлите от поле Брак бр. са отчетени като несъответстващи.

Бележи - забележки в свободен текст към работната карта.

Таблица Допълнителни служители

Ако за изпълнението операцията е предвидено едновременното участие на повече от един служител, те се отчитат към съответната работна карта и се показват в таблицата.

Таблица Материали

Списък от основни и спомагателни материали необходими при изпълнението на текущата операция.

#, Материал - идентификационен номер и наименование на материала

Разходна норма – количеството необходимо за изпълнение на операцията за единица бройка.

План. разход - общо количество от материала необходимо за операцията в съотв. мерна единица.

Основен – поле за отметка индикиращо дали текущия материал е основен или спомагателен.

Алтернативен за - ако е попълнено, означава че материала е дефиниран като алтернативен на друг материал от таблицата, чийто код е зададен в полето.

Таблица Инструменти

Списък с необходимите инструменти за извършване на текущата операция.

#, Инструмент - идентификатор и описание на инструмент

Амортизация - амортизационна норма за инструмента за единица бройка изделие, според технологичната операция

Таблица Мерители

Списък от измервателни инструменти необходими за извършване на текущата операция

Процедури с данните при запис

1. Производствената операция е със статус Празен или Активна:

· Планираните разходни количества за материали се добавят като заделени.
· Ако операцията е първа за партида, и маршрута е от тип:
· Обработка - заделят се стартовите заготовки за партидата ако има такива.
· Сборка - заделят се компонентите за монтаж според ПСИ.

2. Производствената операция е със статус В готовност:

· Заделените количества материали се освобождават. Създават се продуктови операции от тип Използвано за производство за съответните количества материали според технологията, в участъка определен от групата работни единици за операцията. Ако в съответния участък няма достатъчна наличност от основен материал се издава съобщение и записа се прекъсва. Ако операцията е към маршрут от тип Обработка, се създават и съответните продуктови операции за стартовата заготовка и се освобождават заделените.

3. Производствената операция е със статус Затворен,Затворен от служител:

· Следващата операция от производствената партида се установява със статус В готовност. Ако технологичният маршрут е зададен с произволен ред на изпълнение и операцията е първа за партидата то всички операции без последната се установяват със статус В готовност. Когато операцията е последна в партидата и има следващ етап, първата операцията на съответната партида от следващия етап се установява като Активна.
· Ако операцията е първа и маршрута е от тип Сборка, се създават продуктови операции от тип Използвано за производство за компонентите, според ПСИ за отчетените произведени бройки.
· Ако операцията е последна за производствената партида, се създава складова партида в зададения по технология склад или продуктова операция от тип Произведено ако е зададен участък.


Програма - Генератор на производствени поръчки

Генератор на производствени поръчки

Основният обект, който служи за планиране и отчитане на производствения процес е производствената поръчка. Тя представлява задание за изработване на определено количество от дадено изделие по дадена технология. Производствените поръчки са йерархично взаимосвързани - например поръчката за изработка на съставно изделие (възел) се явява родител и реферира поръчки за всеки от съставните му компоненти.

Всяка поръчка може условно да бъде разделена на един или повече етапи, при които се изработва междинно изделие (заготовка), което се явява стартова заготовка за следващия етап от поръчката. За всеки етап се дефинират една или повече производствени партиди - неделим "контейнер" с изделия, които минават заедно през всички етапи на производствения процес и имат съпроводителен документ (паспорт). Технологичния процес е описан в подробности, чрез последователни производствени операции дефинирани за всяка производствена партида.

Системата позволява генериране на производствените поръчки, партиди и операции на база на текущите клиентски поръчки или на вътрешно-фирмено задание (т.нар. вътрешни поръчки ), като се използва програма от тип съветник (wizard) с няколко последователни стъпки.

Стъпка 1 - избор на клиентски поръчки

В таблицата Клиентски поръчки се съдържат одобрените клиентски поръчки със статус различен от Затворен, а в таблицата Поръчани изделия - отделните позиции (релийси) от избраната поръчка със статус различен от Затворен. Изборът на поръчка за обработка става със селектиране на полето Вкл.

Таблица Клиентски поръчки

Поръчка # - идентификатор на клиентска поръчка.

Статус - производствен статус със следните стойности:

· празно - чака обработка (чака генериране на производствени поръчки);
· В производство - производствените поръчки са генерирани и са в процес на производство;
· Част. в производство - част от позициите на поръчката имат генерирани производствени поръчки и са в производство;
· Приключен - всички производствени поръчки към клиентската поръчка са затворени (производството по тях е завършило);
· От склад - изделията по всички позиции на поръчката са налични и ще бъдат реализирани от склад;
· Част. от склад - изделията по някои позиции на поръчката са налични и ще бъдат реализирани от склад, останалите позиции не са обработени.

Дата на утв. - дата на одобряване на поръчката.

Дата на изп. - дата за изпълнение на поръчката.

Клиент # - идентификатор на контрагента.

Клиент - наименование на контрагента.

Държава - държава на контрагента.

ОТК - категоризация за контрагента.

Таблица Поръчани изделия

Статус - аналогичен на полето от горната таблица, но за отделната позиция по поръчката.

Поръчка # - идентификатор на позиция (релийс) от клиентската поръчка.

Дата от клиент - дата за реализация от клиента за позицията.

Дата на изп. - дата за изпълнение на позицията.

К-т - идентификатор на комплект от изделия от поръчката.

К-во за п-во - количество за производство - разликата между количеството по поръчка и вече експедираните към клиента по фактури изделия и заделените за реализация от склад бройки.

Зад. от склад - брой изделия заделени за реализация от склад.

Идент. # - идентификатор на изделие. При щракване се отваря ПСИ на изделието.

Код - код на изделието.

Описание - описание на изделието.

Забележки - забележки от поръчката.

Налични в склад - налично количество във всички складове.

Налични в участъци - налично количество в производствените участъци.

Свободни - свободно количество (разликата между наличното и заделено по клиентски и производствени поръчки количество). При щракване на количеството се отваря прозорец с подробна информация за наличностите и заделените количества на изделието виж.

Контекстно меню на таблица Поръчани изделия

Маркирай от склад - сменя статуса на избраните позиции - От склад и заделя количествата по тях.

Лента с бутони

Използвай количеството в склада - ако е деселектирано указва наличните количества от дадено изделие да не се вземат под внимание при изчисляването на необходимите за производство изделия (дефицити).

Отвори за разглеждане [image] - отваря форма Потвърждение на поръчка за селектирания ред от таблицата с поръчки.

Стъпка 2 - изчисляване на дефицити

На тази стъпка се обединяват и сумират всички компоненти на селектираните по клиентски поръчки крайни изделия и се изчислява необходимото за производство количество - т.нар. дефицит, на база на разликата между необходимото и свободното количество от дадено изделие.

Таблица дефицити

Идент. #, Код, Описание - идентификатор, код и описание на изделието. При щракване на идентификатора се отваря ПСИ на изделието.

ПСИ количество - количество на изделието на изчислено на база на клиентските поръчки и ПСИ.

Необх. количество - изчислено на база на клиентските поръчки, като количеството на компонентите е редуцирано със свободното количество.

Налични общо - налично количество във всички складове и участъци. При щракване на количеството се отваря прозорец с подробна информация за наличностите и заделените количества на изделието виж. Ако към момента на генерация има складови партиди от изделието с входящи операции със статус Чакащ одобрение, фона на полето става червен.

Налични в склад - налично количество в складове.

Налични в участъци - налично количество в участъци.

Свободни - свободно количество (разликата между наличното и заделено по клиентски и производствени поръчки количество).

Дефицит - необходимо за производство количество. Ако е 0 не се генерира производствена поръчка. Полето може да се редактира от оператора, като промяната на стойността на дефицита на съставно изделие (възел) води до преизчисляване на дефицитите на компонентите му.

Реализация - указва дали изделието ще бъде произведено (Производство) или закупено (Покупно). Може да бъде редактирано от оператора. Ако бъде избрано Покупно производствена поръчка не се генерира, а съответното количество се заделя.

Макс. к-во в партида, Мин. к-во в партида - максимално и минимално количество за партида от съответното изделие според ПСИ.

К-т - описание на комплект от клиентската поръчка, ако изделието участва в комплект.

Таблица Алтернативни изделия

Ако според производствената спецификация на изделията има зададени алтернативни на изделията от таблицата Дефицити. Етикета Алтернативни изделия се оцветява в червено. При натискане на бутона Зареди те се зареждат в таблицата.

Идент. #, Код, Описание - идентификатор, код и описание на изделието. При щракване се отваря ПСИ на изделието.

Налични общо - налично количество в складове и участъци.

Свободни - свободно количество.

Алтернативен на - идентификатор на изделие от таблицата Дефицити на, което е алтернативно изделието от реда.

При натискане на бутона Използвай, изделието от избрания ред в таблица Дефицити се подменя с избраното от таблица Алтернативни изделия и данните се преизчисляват. Използването на алтернативно изделие се допуска само ако свободното му количество е по-голямо или равно на дефицита.

Таблица Текущи поръчки

В тази таблица се показват производствени поръчки от тип вътрешна, които са в процес на производство и са за изделия с ненулев дефицит от таблицата Дефицити. Системата позволява бройките от съответния компонент да бъдат резервирани от текущата вътрешна поръчка за поръчката за изделието, в което той се включва, като съответно при генерацията текущата вътрешна поръчка се включва към "подчинените" на поръчката за изделието сборка.

# - идентификатор на производствена поръчка. При щракване се отваря форма Производствени поръчки.

Налични общо - показва количеството по производствена поръчка, от което са извадени бройките резервирани за поръчки използващи компонента.

Използвани - брой резервирани изделия.

Идент. #, Код, Описание - идентификатор, код и описание на изделието. При щракване се отваря ПСИ на изделието.

Забележки - забележки към производствената поръчка

Дата - дата на производствената поръчка.

При натискане на бутона Използвай, количеството на изделието от избрания ред в таблица Дефицити се маркира за резервиране (при генерирането на производствените поръчки) от вътрешната поръчка селектирана в таблицата Текущи поръчки и колоните Налични общо и Използвани се преизчисляват.

Лента с бутони

Производствени стратегии

Количествата необходими за производство по производствените партиди, както и бройките за обработка и изпълнение по отделните производствени операции се определят в процеса на генерация, на база на поръчаните количества и предвидените за всяка операция бройки за настройка и брак, според избраната технология. Алгоритъма за изчисление може да бъде настройван чрез избор на производствена стратегия.

Производствена стратегия на партидите

· Приоритет на поръчката - при тази стратегия, количеството необходими заготовки (изделия които подлежат на преработка на следващ етап) се изчислява, като бройките за настройка и брак за партидите от следващият етап се определят за всяка партида поотделно. Този подход гарантира, че ако се наложат например допълнителни настройки на машините при производство на голяма серия от изделия винаги ще има необходимото количество от заготовки за настройката и съответно ще бъде произведено необходимото количество добри заготовки за стартиране на следващият етап. При тази стратегия се изразходват малко по-големи количества от суровите материали (необходими за конкретната поръчка), които обаче се натрупват като складови наличности от заготовки, използваеми при последващи поръчки.
· Приоритет на материала - в този случай количеството на заготовките се изчислява, като бройките за настройка и брак се определят за цялото количество на изделията от следващия етап. При този подход се изразходва суров материал, точно колкото е необходимо за поръчката, но при големи серии се създава известен риск от недостиг на детайли за монтаж, например при неколкократна пренастройка на машините и съответната "загуба" на заготовки.

Производствена стратегия на бройките за настройка

· Нормална - бройките за на настройка за всяка операция се изчисляват на според технологията.
· Оптимистична - бройките по технология се разделят на две.
· Рискова - задава се не повече от една бройка за настройка.
· Нулева - не се задават бройки за настройка.

По подразбиране са зададени стратегии - Приоритет на поръчката и Нормална. Текущите стратегии се изписват в статус полето на главния прозорец на програмата.

Бутон Печат - отпечатва се справка Дефицити.

Стъпка 3 - Избор на технология

На тази стъпка се избира технология (ако е достъпна повече от една) за производството на всяко изделие с ненулев дефицит от таблицата Дефицити.

Таблица Дефицити

Полетата са аналогични на съответните в таблицата Дефицити от стъпка 2.

Таблица Маршрутни карти

В таблицата се показват достъпните технологии (маршрутни карти) за изработване на избраното изделие от таблица Дефицити.

Вкл. - избира маршрутната карта(и) за производство.

Заготовка - идентификатор на стартовата заготовка за маршрутната карта. Ако маршрута започва от материал се изписва Материал. За монтажните маршрути се изписва Монтаж. При щракване се отваря прозорец с подробна информация за продукта.

К-во - необходимо количество от заготовката/материала.

Налични общо - налично количество от продукта.

Свободни - свободно количество, от което са извадени текущо селектираните.

Бр. - количество изделия за производство. Ако са селектирани повече от една маршрутни карти бройките се разпределят поравно. Бройката за дадена маршрутна карта може да бъде променяна в таблицата от оператора, като общият брой по всички избрани маршрутни карти трябва да съответства на дефицита.

Натовареност - сумарна натовареност за всички работни единици за операциите от маршрутната карта в часове. Изчислява се на база на създадените производствени поръчки плюс текущо селектираните маршрутни карти. Ако някоя от работните единици е временно спряна полето се оцветява в оранжев цвят, а ако всички работни единици от дадена група са временно спрени се оцветява в червен цвят.

Ранг - код на ранга на маршрутната карта, който се формира от ранговете на технологичния маршрут и операции, и дължината на маршрута като брой на етапите.

Мерна единица - мерна единица за основния материал (ако избраната маршрутна карта стартира от материал).

Забележка: По подразбиране селектирана е най-кратката и с най-висок ранг маршрутна карта, за която има наличност от стартовата заготовка (ако маршрута стартира от междинна заготовка).

Таблица Операции

Показва технологичните операции за избраната маршрутна карта.

Натовареност - натовареност на групата работни единици за операцията. Изчислява се на база на създадените производствени поръчки плюс текущо селектираните маршрутни карти.

# - пореден номер на операцията

Код - код на технологичната операция. При щракване се отваря програмата технологични операции.

Операция - наименование на технологичната операция.

Бройки за операцията - бройки за обработка.

Маршрут - наименование на технологичния маршрут.

Опер. # - идентификатор на технологичната операция.

Таблици Текущи операции за заготовки и Използвани поръчки

По аналогия със Стъпка 2, в таблицата Текущи операции за заготовки се показват текущите вътрешни поръчки за стартовите заготовки на маршрутните карти. Съответстващите на селектираната маршрутна карта текущи поръчки се маркират и след това резервират с натискане на бутона Използвай, след което се показват в таблицата Използвани поръчки. Резревирането може да бъде отказано като съответния ред в таблицата Използвани поръчки се селектира и се натисне бутона Премахни.

Бутон Справки

От бутона Справки могат да бъдат извикани следните справки:

Необходими материали

Опциите Подробна справка и Съкратена справка извикват репорти за необходимите за изработката на поръчките материали и покупни изделия.

Опция Искане за закупуване отваря прозореца Създаване на искане за закупуване, който служи за генериране на Искане за закупуване на необходимите материали.

Таблица Материали

Код, Описание - идентификатор и описание на материала.

Ед-ца - мерна единица.

К-во - необходимо количество.

Налични общо - налично количество във всички складове и участъци.

Свободни - свободно количество.

Минимална наличност - минимална наличност (неснижаем остатък) от материала по спецификация.

Алтернативен на - идентификатор на кой материал се явява алтернативен текущия. Алтернативните материали се изписват в курсив.

За заявка - необходимо за доставка количество (може да се коригира от оператора).

Таблица Покупни изделия е аналогична.

При натискане на бутона Генерирай за селектираните в колоните Използвай, материали и изделия с ненулево количество за заявка се генерира Искане за закупуване.

Стъпка 4 - Запис на генерираните производствени поръчки

При тази стъпка се визуализира помощна информация за производствените поръчки, които ще бъдат генерирани, както и за връзките между тях и съответните редове от клиентските поръчки. При натискане на бутона Запис се стартира процедура, която генерира и записва производствените поръчки и съответните им производствени партиди и производствени операции.

Забележка. Последната фаза при която информационния прозорец показва "Запис на производствените поръчки/партиди/операции" се извършва в режим на транзакция за базата данни. Което означава че други операции по запис в свързаните таблици на базата данни не могат да бъдат извършвани до края на процеса.

Стъпка 5 - финален прозорец

На тази стъпка процеса на генерация и запис е приключен.

Бутон Печат паспорти - позволява отпечатване на паспортите на производствените партиди.

Бутон Добави към плана - стартира процедура по добавяне на новогенерираните производствени поръчки към производствения план и преизчисляването му. В зависимост от големината на плана това може да бъде продължителна операция.

Бутон Рестартирам - рестартира генератора и започва от Стъпка 1.


Програма - Отчитане на операциите

Отчитане на операциите

Тази програма е основното средство, което се използва за своевременно отчитане на извършената работа по производствените операции, на място в работните участъци, от служителите, който я извършват.

Идентификация на служителя

Служителят, от чието име се отчита операцията се идентифицира в прозореца Вход с личния си идентификационен номер. Ако по технология е предвидено операцията да се извършва и отчита от няколко служители, то номерата им се въвеждат разделени със запетая.

Прозореца за идентификация се отваря при стартиране на програмата, след запис или изход, или от менюто Вход (F5), Вход като...

Отчитане на извършената работа

Извършването на работа по дадена производствена операция се отчита чрез два последователни записа в таблицата за отчитане (по-долната таблица в прозореца). С първия запис се указва, че е стартирало изработване на изделия или настройка за операцията като данните се появяват в таблицата Текущи операции (горната таблица) и се фиксира началния момент на работата. С втория отчет се очтитат изработени бройки или бройки за настройка и се фиксира момента на край на работата.

Таблица за отчитане на операциите

Операция # - идентификатор на производствена операция, от списъка на операциите със статус В готовност за текущия работен участък, избран в полето Участък.

Раб. единица - идентификатор на работна единица от групата работни единици за операцията, на която се извършва работата. Клавиша F12 попълва работна единица по подразбиране.

Настр. - ако е селектирано указва, че отчета е за работа по настройка на машините.

Бр. добри - изработени добри бройки. При позиционирането в това поле в статус полето на формата се показват бройките Остатък по операцията. Това е разликата между отчетените добри бройки по предхождащата операция (ако текущата операция е първа за поръчката се взимат бройките за изпълнение) и вече отчетените.

Бр. с откл. - изработени бройки с отклонение от технологичните параметри (брак).

Бр. за настр. - използвани бройки за настройка.

Кач. - качество на изработените изделия.

Наименование - наименование на технологичната операция.

Заготовка - текуща заготовка на производствената партида.

Начало, Край - моменти на начало и край на работата за текущия отчет.

Причина за брак - идентификатор на причина за несъответствие.

Когато отчета се извършва от ОТК служител в таблицата са достъпни допълнителни полета:

Бр. за дораб. - бройки за доработка - изделия които трябва повторно да преминат през производствения цикъл и през допълнителна операция.

Бр. ОТК - бройки преминали през качествен контрол.

Несъвм. статус - статус за несъвместимост (В несъответствие спира или В несъответствие продължава), който ще бъде присвоен на производствената операция.

Бележки - забележка в свободен текст.

Запис на данните

Данните могат да бъдат записани с избиране на опцията Запис (F10) от менюто или записа да бъде отказан с опцията Изход (F8).

Погрешно въведен ред в таблицата може да бъде изтрит, преди да бъде записан, като се селектира с натискане на сивото поле в началото на реда и след това клавиша Del/Delete.

След записа на отчета, ако сумарното количество произведени добри бройки по производствената операция е по-голямо или равно на Остатъка, операцията се установява със статус Затворен. Ако е по-малко - със статус Стартирана. След което се извикват процедурите след запис на производствена операция.


Програма - Производствен браузър

Производствен браузър

Производствения браузър е програма, която служи за навигиране и разглеждане на клиентски поръчки, производствени поръчки, производствени партиди и производствени операции, детайли за тях и връзките помежду им.

Потребителския интерфейс на програмата е разделен на четири сходни части, представляващи набор от филтри, команди за навигиране и прилежаща таблица с списък от записи. Редовете и съответстващите им записи в прилежащите таблици могат да бъдат селектирани чрез двойно натискане, като селектирания ред се показва с удебелен шрифт.

Клиентски поръчки

Идентификатор на клиентска поръчка – поле за избор от таблица на клиентските поръчки. Избирането или въвеждането на клиентска поръчка и натискане на клавиша Enter, ще попълни всички позиции от клиентската поръчка в прилежащата таблица.

Клиент – поле за избор от таблицата с клиентите. При попълване или избиране на запис в това поле ще се попълнят всички записи от всички незатворени поръчки за избрания клиент.

Държава – поле за избор от таблицата с държави. При попълване или избиране на запис в това поле, в прилежащата таблица, ще се попълнят всички незатворени поръчки предназначени за тази държава.

Закъсняващи – активен етикет указващ броя на закъсняващите клиентски поръчки. Зарежда в прилежащата таблица всички закъсняващи поръчки.

Отпечатване на паспорти [image] - функционалност за отпечатване на всички паспорти на производствени партиди свързани с клиентската поръчка.

Отвори за разглеждане [image] – отваря формата Клиентски поръчки.

Зареди надолу [image] – попълва прилежащата таблица от секция Производствени поръчки с всички производствени поръчки свързани със селектирания ред от секция Клиентски поръчки.

Изчисти таблицата [image] - премахва всички записи от прилежащата таблица.

Производствени поръчки

Идентификатор на производствена поръчка – поле за избор от таблицата с производствени поръчки. При попълване или избиране на запис и натискане на клавиша Enter, в прилежащата таблица се зареждат детайли за избраната производствена поръчка, както и свързаните с нея поръчки за изработка на компоненти.

Отворени поръчки – зарежда в прилежащата таблица всички незатворени производствени поръчки.

Закъсняващи - активен етикет указващ броя на закъсняващите производствени поръчки. Зарежда в прилежащата таблица всички закъсняващи производствени поръчки

Себестойност [image] – стартира програмата Себестойност на изделията, изчисляването оперативната себестойност на изделието от текущо избраната производствена поръчка.

Отвори за разглеждане [image] – отваря формата производствени поръчки.

Зареди нагоре [image] – премахва всички записи от прилежащата таблица в секция клиентски поръчки и я зарежда с клиентските поръчки използвани за генериране на селектираната производствена поръчка.

Зареди надолу [image] - премахва всички записи от прилежащата таблица в секция производствени партиди и я зарежда с производствените партиди свързани със селектираната производствена поръчка.

Изчисти таблицата [image] – премахва всички записи от прилежащата таблица.

Производствени партиди

Идентификатор на производствена партида – поле за избор от таблицата с производствени партиди. При попълване или избиране на запис и натискане на клавиша Enter, се зареждат детайлите относно избраната производствена партида в прилежащата таблица

Отвори за разглеждане [image] – отваря формата Производствени партиди.

Зареди нагоре [image] – изчиства всички записи от прилежащата таблица в секцията с производствени поръчки и зарежда в нея производствената поръчка към която принадлежи избраната производствена партида.

Зареди надолу [image] – изчиства всички записи в прилежащата на секция Операции таблица и зарежда в нея всички операции част от избраната производствена партида

Изчисти таблицата [image] – премахва всички записи от прилежащата таблица.

Операции

Идентификатор на производствена операция – поле за избор от таблицата с производствени операции. При попълване или избиране на запис и натискане на клавиша Enter, се зареждат детайлите относно избраната производствена операция в прилежащата таблица

Отвори за разглеждане [image] – отваря формата Операции.

Зареди нагоре [image] – изчиства всички записи от прилежащата на секция Производствени партиди таблица и зарежда в нея производствената партида, от която е част текущата производствена операция.

Изчисти таблицата [image] – премахва всички записи от прилежащата таблица.

Предупреждения

1. Закъсняващи клиентски поръчки

Показва броя на позициите по клиентски поръчки в производство, на които остават от Датата за производство 2 или по-малко дни за основната производствена поръчка за позицията или 3 или по-малко дни за свързаните под-поръчки за компоненти. При натискане на етикета, се изчистват всички записи от таблицата с клиентски поръчки и се зареждат всички изоставащи клиентски поръчки.

2. Закъсняващи производствени поръчки

Показва броя на производствените поръчки, на които остават от Датата за производство 2 или по-малко дни за основната производствена поръчка за позицията или 3 или по-малко дни за свързаните под-поръчки за компоненти. При натискане на бутона в таблицата с производствени поръчки се зареждат всички изоставащи поръчки.

Подробности за всяко предупреждение и причините за него могат да бъдат разгледани чрез двойно щракване с мишката върху колоната с предупреждения към съответния запис.


Програма - Планиране на производството

Планиране на производството

Програмата за планиране на производството позволява да бъде създаден времеви график (производствен план) за изпълнението на създадените в системата производствени партиди и операции, които предстои да бъдат реализирани. Той дефинира точни моменти за стартиране и приключване на всяка една производствена операция, както и работната единица, на която тя да бъде изпълнена. За целта се използва евристичен оптимизационен алгоритъм, който отчита графиците за работа на работните единици (работен календар), наличностите и сроковете за доставка на материали, приоритетите на поръчките и др. и позволява оптималното разпределение на производствените ресурси.

Визуализация на плана

Производственият план се представя с двумерна графична схема.

По вертикалната ос са нанесени работните единици, представени с идентификаторите на участъка, групата и работната единица. При задържане на курсора се показва подсказка с описанието на работната единица.

По хоризонталата е нанесено времето.

Производствените операции са показани с разноцветни ивици. Те са позиционирани вертикално спрямо работната единица а хоризонтално към момента за стартиране на операцията спрямо времевата ос. Ширината на ивицата е пропорционална на продължителността на операцията във времето. При задържане на курсора се показва подсказка с подробна информация за операцията. Ивиците на операциите могат да бъдат селектирани, като избраната се показва с удебелена рамка.

Лента с бутони

Зареждане на плана [image] - зарежда записания производствения план от базата данни.

Запис на плана [image] - записва изчисления план в базата данни.

Увеличаване/смаляване [image] - увеличва или намалява мащаба на визуализация на времевата ос. Съответно ширината на ивиците представящи операциите.

Избор на операция - селектира избраната операция от списъка и я визуализира.

Предишна операция [image] - селектира и визуализира операцията предхождаща избраната, в технологичния ред на операциите.

Следваща операция [image] - селектира и визуализира операцията последваща избраната, в технологичния ред на операциите.

Информация [image] - показва прозорец с подробна информация за избраната операция.

Филтър по поръчки [image] - позволява задаване на филтър на операциите по избрани производствени поръчки.

Филтър по участъци [image] - задава филтър на операциите за избрани работни участъци.

Филтър по време - 2 седмици, 1 месец, 2 месеца или 3 месеца от началото на плана.

Преместване на операция [image] - позволява фиксирането на старта на избрана операция за точно определен момент или работна единица, като фиксираната операция не се премества при преизчисляване на плана.

Преизчисляване на плана [image] - извиква се процедурата за преизчисляване на текущия план. След преизчисляването плана се визуализира и може да бъде записан в базата данни, за да бъде достъпен за останалите функционалности на системата.

Забележка. В зависимост от големината на текущия план тази процедура може да отнеме значително време.

Проверка - проверка за съвместимост на текущия план.

Добавяне на производствени поръчки към плана

Всички незатворени производствени поръчки се визуализират в раздела Поръчки.

Пр. п-ка # - идентификатор на производствена поръчка. Поръчките за компоненти са представени дървовидно, като ако една дъщерна поръчка има повече от една родителска в иконата и има червена стрелка - [image] .

Кл. п-ка - позиции от клиентска поръчка, към които е производствената.

Изделие #, Код, Описание - идентификатор, код и описание на изделието.

К-во - количество от производствената поръчка.

Дата за изп. - дата за изпълнение от клиентската поръчка.

Приоритет - приоритет на поръчката.

Статус - вече планираните поръчки имат статус Планирана

План. старт - планиран старт на поръчката (старт на първата операция).

План. край - планиран край на поръчката (край на последната операция).

Лента с бутони

Добавяне на поръчка [image] - избраните поръчки се добавят към плана и се стартира преизчисляването му. Могат да бъдат селектирани едновременно една или няколко поръчки, като дъщерните поръчки на избраната се добавят автоматично.

Изваждане на поръчка [image] - избраните поръчки се премахват от плана и той се преизчислява.

Опресняване - таблицата с поръчки се зарежда наново от базата данни.


Програма - Генериране на работен календар

Генериране на работен календар

За работата на функционалностите за планиране на производството е необходимо предварително да бъде генериран работен календар. Той представлява подробен график на работните смени на всяка една работна единица включена в производство, за определен период от време (например: календарна година).

Посредством програмата, работен календар може да бъде създаден или прегенериран за година или произволен период, за всички работни единици от отдел, група или за конкретна работна единица.

За всеки отдел и група работни единици могат да бъдат дефинирани параметри на работното време (работни смени, почивки и др.) по подразбиране, които могат да бъдат коригирани при стартиране на генерацията.

В процеса на генерация тези данни се взимат йерархично - ако генерираме календар за отдел и има дефинирано работно време за групата - използва се работното време за групата. Ако няма, се използват данните за отдела (видими в прозореца на програмата).

Забележка. След прегенериране на работния календар, за да бъдат отразени промените в работния план той трябва да бъде преизчислен чрез функционалностите за планиране.


Програма - Браузър на производствен участък

Програма - Браузър на производствен участък

Използва се за контрол и управление на наличностите и движението на продукти (материали, изделия и др.) в отделите, в които това е необходимо да се отчита (маркирано е полето Складова отчетност във формата Отдели), както и за контрол и управление на производството чрез производствените операции в производствените отдели (производствени участъци).

Наличности и движение на продуктите

Производствени операции

Инструментална екипировка


Модул Машини и инструменти

 Top

Enter topic text here.


Наличности и движение на продуктите

Движение на продуктите

Наличностите и движението на продуктите в производствените участъци се описват чрез хронологични и взаимосвързани продуктови операции. Всяка операция има идентификатор на продукт, количество в съответната мерна единица и тип, като количеството се интерпретира със знак плюс или минус в зависимост от типа на операцията. Условно можем да разделим операциите на:

· входящи - указват че съответното количество е постъпило в отдела (например Получено от склад, Произведено)
· изходящи - указват че количеството от продукта е излязло от участъка или е било изразходвано (например Прехвърлено в друг участък, Използвано з производство и т.н.). Когато се въвежда изходяща операция, задължително трябва да се укаже входящата операция, по която продукта е постъпил в отдела, като съответно остатъчното количество по тази операция се намалява.

Наличността от даден продукт следователно се формира от сумата на остатъчните количества по всички входящи операции (поле Количество в таблицата Наличност).

Съществува и особен тип операции - Изравняване, които се интерпретират като входящи или изходящи в зависимост от знака на въведеното количеството.

Пълният набор от данни за продуктовите операции се задава във формата Движение на продукти по участъци.

Можем да разглеждаме и редактираме продуктовите операции като изберем раздел Наличности в браузъра.

Достъпни са два различни изгледа в зависимост от избрания бутон в лентата с бутони.

1. По папки - бутон Папки

В този изглед можем да избираме с отделни раздели различните типове продукти - Изделия, Инструменти, Мерители и Материали, и съответните им папки като информацията за операциите за продукти от избраната папка се показва в таблиците Наличност и Движение.

Таблица Наличност

В тази таблица се показват продуктите, които са били обект на движение в съответния участък, групирани по идентификатора на продукта и качеството.

# - идентификатор на продукт

Код - код на продукта (в случаите когато продукта не е изделие съвпада с идентификатора)

Описание - описание на продукта

Количество - налично количество в съответната мерна единица (виж по-горе)

Качество - качество на продукта (ако е зададено)

Таблица Движение

Показва продуктовите операции за продукта (със съответното качество) от селектирания ред в Таблица Наличност

# - идентификатор на операцията

Дата - дата на създаване на операцията

Код на операцията - код (наименование на типа) на операцията

Количество - количество със знак

Качество - ако е зададено

Статус - статус на операцията, чакащ или утвърден

Партида - номер на складова партида от която е взет продукта (за входящите операции)

Произв. парт. # - идентификатор на производствена партида (ако продукта е произведен)

Затв. - ако е селектирано указва че входящата операция е затворена т.е. остатъка е =0

Остатък - налично количество от входяща операция

Произв. опер. # - идентификатор на производствена операция за която е изразходвано количеството (за изходящи операции от тип Използвано за производство или Изравняване при производство)

2. За всички продукти - бутон Преглед

В този изглед са достъпни четири филтъра за показваните операции

· По продукти - показани са таблиците Наличност и Движение за всички продукти.
· Чакащи утвърждаване - показана е таблицата Движение със всички операции със статус - "чакащ утвърждаване"
· Последни 100 - таблицата съдържа последните 100 операции за участъка
· Всички - таблица с всички продуктови операции за участъка. При избора на тази опция, показването на данните може да отнеме значително време, в зависимост от големината на натрупаната база данни с продуктови операции.

Контекстно меню на таблица Движение

Независимо от режима (Папки или Преглед) е достъпно контекстно меню на таблицата Движение със следните опции:

Нова операция - отваря се форма Движение на продукти по участъци в режим на нов запис, като е попълнен избрания участък и продукта от избрания ред в таблицата.

Нова изходяща операция - отваря се форма Движение на продукти по участъци в режим на нов запис, като е попълнен избрания участък, продукта от избрания ред в таблицата и идентификатора на избраната операция - като операция източник на количеството. Опцията е валидна е само за входящи операции с ненулев остатък.

Преместване в склад - отваря се форма Движение на продукти по участъци в режим на нов запис, като е попълнен избрания участък, кода на операцията - Преместено в склад, продукта от избрания ред в таблицата и идентификатора на избраната операция - като операция източник на количеството. Опцията е валидна е само за входящи операции с ненулев остатък.

Преместване в участък - аналогично на Преместване в склад, като кода на операцията е Преместване в участък.

Отваряне операция - отваря се формата Движение на продукти по участъци за избраната операция.

Утвърждаване - установява се статуса на избраната операция(и) на Утвърден.

Изписване на продукти - тази опция се използва за автоматизирано създаване на изходящи операции за продукта от избрания ред на таблицата Наличност. Типа на изходящите операции, количеството и качеството на продукта, който се изписва се избира прозореца Изписване на продукти

Забележка: Операции от тип Използвано за производство могат да се създават само за продукти, които не са маркирани, че подлежат на контролирано изписване.

Лента с бутони

От лентата с бутони могат да бъдат извиквани следните функционалности:

Бутон Отваряне операция [image] виж.

Бутон Нова операция [image] виж.

Бутон Изписване по маршрутен лист (МЛ) [image] предлага две опции:

1. Изписване по маршрутен лист (МЛ). Тази функционалност позволява автоматизираното генериране на операции по изписване на продукти от участъка въз основа на Маршрутен лист. Използва се прозореца Изписване по маршрутен лист.

В полето Маршрутен лист # се въвежда (избира) идентификатор на одобрен Маршрутен Лист.

Бутонът Зареди попълва в таблицата всички продукти дефинирани, че трябва да бъдат изразходвани в съответният участък според маршрутния лист.

Опер. # - номер на технологична операция по маршрутния лист.

Продукт #,Описание - идентификатор и описание на продукта

К-во по МЛ - необходимо количество според маршрутния лист.

Остатък - разликата между необходимото и вече отчетеното като изразходвано по този маршрутен лист количество.

Кач. - качество

К-во - количество което ще бъде отчетено. Не може да е по-голямо от необходимото. По подразбиране се зарежда със стойността на остатъка.

Налични - налично количество от продукта в участъка.

Бутонът Нулиране се използва за корекция на вече изпълнено изписване. След натискането му и потвърждаване се изтриват всички продуктови операции за избрания маршрутен лист.

2. Изписване на групови опаковки. Използва се за изписване на груповите опаковки на изделията от монтажните участъци.

Кл. поръчка # - избира се номер на одобрена клиентска поръчка.

Бутонът Зареди попълва в таблицата всички групови опаковки дефинирани, че трябва да бъдат изразходвани за съответната поръчка. Ако липсват такива, могат да бъдат избрани от оператора в полето Продукт #.

Останалите полета са аналогични на съответните в прозореца Изписване по маршрутен лист.

Бутон Справки [image] - достъпни са следните справки в раздел Наличности, филтрирани по избраната папка от дървото:

· Наличности в участък - наличности на продуктите към дадена дата.
· Движение по продукти - вход-изход на продукти в участъка за избран период.
· Движение на продукти по операции - показва началните и крайни салда за период, както и движението на продуктите групирано по различните видове продуктови операции.

Бутон Опресняване [image] - презареждане на данните, показани на екрана от БД.


Производствени операции

Разглеждането и действията с незавършените производствени операции в участъка става като се изберат разделите Произв. операции или Кооперирани операции. Пълния набор от данни за производствените операции се задава във формата Операции.

Раздел Производствени операции

Таблица Чакащи операции

В таблицата са показани всички производствени операции за участъка със статус Празен, Активна и В готовност.

ТГ (текущ график) - указва дали операцията да бъде включена в справката Текущ график (операции за неотложно изпълнение) в участъка.

# - идентификатор на производствената операция.

Партида # - идентификатор на производствена партида. При щракване се отваря формата Производствени партиди.

Кл. поръчка - списък на позициите по клиентски поръчки, към които е операцията.

Дата за изд. - Дата за издаване на позицията от клиентската поръчка.

Код - код на технологичната операция. При щракване се отваря прозореца за разглеждане на технологична операция.

Операция - описание на технологичната операция.

Статус - статус на производствената операция.

Текуща заготовка - код на изделието - текуща заготовка на производствената партида. При щракване се отваря ПСИ на изделието.

Брой за изп. - бройки за изпълнение.

Брой за обр. - бройки за обработка.

План старт - планирано начало на операцията.

План край - планирано завършване на операцията.

План р. ед. - идентификатор на работна единица, на която е планирано да се извърши операцията.

Приоритет - приоритет на производствената поръчка.

Група раб. ед. - идентификатор и наименование на групата работни единици, на които ще се извърши операцията.

Печат - маркира дали паспорта на производствената партида е отпечатан.

Забележки - забележки към производствената операция.

Таблица Текущи операции

В таблицата са показани производствените операции в участъка със статус Стартирана, т.е. операции за които е отчетено че са започнали но все още не са приключили.

Полетата - #, Партида #, Кл. поръчка, Код, Операция, Текуща заготовка, Дата за изд., Забележки са аналогични на тези от таблицата Чакащи операции.

Бр. добри - отчетени произведени добри бройки за операцията.

Остатък - разликата между отчетените добри бройки от предходната операция (ако е първа - бройките за изпълнение) и отчетените до момента добри бройки.

Бр. настр. - отчетени бройки брак при настройка на машината.

Брак - отчетени бройки брак (несъответстващи на нормите за изделието) при производството.

Старт - отчетено начало на операцията.

Раб. единица - идентификатор на работната единица, на която се извършва операцията.

Контекстно меню на таблица Чакащи операции

Маркиране "в готовност" - установява статус В готовност на избраните операции със статус Активна.

Маркиране "затворена от служител" - установява статус Затворена от служител на избраните операции.

Добави към текущия график - маркира избраните операции като част от текущия график.

Премахни от текущия график - изключва избраните операции от текущия график.

Добави партиди към текущия график - маркира всички операции за избраните производствени партиди, като част от текущия график.

Печат паспорти - отпечатва паспортите на производствените партиди за избраните операции.

Раздел Кооперирани операции

В този раздел са включени производствените операции, които се извършват от външен изпълнител (кооперант).

Таблица Чакащи операции

Таблицата е аналогична на тази в раздела Производствени операции с изключение на полето План. кооперант, показващо името на контрагента по-подразбиране, който реализира операцията.

Таблица Текущи операции

Таблицата е аналогична на тази в раздела Производствени операции с изключение на полетата Изпратени и Получени показващи съответно бройките от изделието за обработка изпратени на кооперанта с експедиционни бележки и получените бройки.

Лента с бутони

От лентата с бутони могат да бъдат извиквани следните функционалности:

Бутон Отваряне операция [image] отваря формата Операции за избраната операция.

Бутон Материали и компоненти [image]. Отваря функционалност, която показва необходимите за производствените операции материали и компоненти. Достъпни са опции изчисленията да се направят за всички операции или само за избраните.

Прозорец Необходими материали, стартови заготовки и компоненти

Таблица Материали

# - Идентификатор на материал.

Описание - Описание на материала

К-во - Необходимо количество в съответната мерна единица

Налични - налично количество във всички складове и участъци

Налични в участъка - налично количество само в избрания участък

Свободни - свободно количество (разликата между наличното и заделено по производствени поръчки количество).

За получаване - разлика между необходимото и наличното в участъка количество.

Склад - идентификатор на склад, в който има налично количество от материала.

Таблица Алтернативни материали

Съдържа алтернативните според технологиите материали на изброените в таблица Материали.

Полетата са аналогични на горе посочените, като в полето Алтернативен за е даден идентификатора на кой материал от горната таблица се явява алтернативен материала от таблицата.

За да използваме в процеса на производство алтернативния материал, трябва да го изберем като селектираме полето Използвай и потвърдим с бутона Запис.

Таблицата в раздел Заготовки и компоненти е аналогична на тази за материалите, като съдържа необходимите за монтаж компоненти или стартови заготовки за обработка.

Прозорец Създаване на искане за отпускане на материални ценности

Прозореца се извиква от бутона Искане и позволява автоматизирано създаване на Искане за отпускане на материални ценности за избрани материали или компоненти (в зависимост от избрания раздел).

Поле Получател - попълва се идентификатор на служителя получател за искането.

За отдел - идентификатор на отдела получател.

Склад - идентификатор на склад от който ще бъдат отпуснати продуктите.

В таблицата са показани следните полета:

Продукт # - идентификатор на продукта.

Описание - описание на продукта.

К-во - необходимо количество.

Налични - налично количество във всички складове и участъци

Налични в участъка - налично количество само в избрания участък

Свободни - свободно количество (разликата между наличното и заделено по производствени поръчки количество).

За получаване - разлика между необходимото и наличното в участъка количество. Това поле може да бъде редактирано от оператора.

Избери - указва дали избрания ред да бъде включен в искането. Всички редове могат да се селектират/деселектират от полето Избери всички.

При натискане на бутона Запис се създава ново искане за отпускане на материални ценности към указания склад, с избраните продукти с ненулеви количества за получаване от таблицата.

Бутон Експорт в excel [image] - експортира данните от таблицата като таблица в MS Excell.

Бутон Комплектовъчен лист [image] - отпечатва справка Комплектовъчен лист за избраните продукти.

Бутон Справки [image] - достъпни са следните справки в раздели Производствени/Кооперирани операции:

· Текущ график - отпечатва операциите селектирани в текущия график за участъка по групи работни единици.
· Текущи операции - всички операции със статус В готовност или Стартирана за участъка, по изделия.
· Извършена работа в участък за деня - извършената работа за даден ден по производствени операции.
· Извършена работа в участък - извършената работа в участък за период по групи работни единици и технологични операции.
· Извършена работа в участък по изделия - извършената работа в участък за период по групи работни единици, технологични операции и изделия.
· ОТК операции в готовност - ОТК операциите със статус В готовност, по участъци.


Инструментална екипировка

Движението на инструменталната екипировка, групирано по инструменти и за избран период, може да бъде разгледано в раздела Инструментална екипировка.

Времевият период може да бъде зададен чрез избор на датите и натискане на бутона Покажи.

Таблицата съдържа следните полета:

Код - идентификатор на инструмент

Описание - описание на инструмента

Начално к-во - изчислено налично количество от инструмента в участъка към началната дата на периода.

Изравняване - сума на операциите от тип Изравняване

Получено от склад - сума на операциите от тип Получено от склад

Получено от участък - сума на операциите от тип Получено от участък

Предадено в склад/участък - сума на операциите от тип Прехвърлено в склад/участък

Бракувано - сума на операциите от тип Бракувано

Предадено за бракуване - сума на операциите от тип Предадено за бракуване (за инструменти с контролирано изписване).

Използвано за ремонт - сума на операциите от тип Използвано за ремонт

Амортизирани за периода - брой амортизирани инструменти за периода, изчислени на база на амортизационната норма за производствените операции зададена в технологията.

Крайно к-во - изчислено налично количество от инструмента в участъка към крайната дата на периода.


Модул ПСИ


Програма ПСИ

Програма ПСИ. Основни термини

Програмата ПСИ служи за въвеждане в системата на пълното многообразие от произвеждани изделия с тяхната производствена спецификация. За тази цел се използват два основни типа обекти – конкретни, напълно определени спецификации на изделия и абстрактни дефиниции на множества от изделия. Конкретните спецификации определят напълно конкретизирани изделия (детайли или сборки) с пълният им набор от свойства – например секретен щифт с дължина 2, изработен от месинг с покритие никел-сатен и т.н. или ротор брониран от даден вид с дължина 31, покритие никел сатен, профил S1, който се състои от детайл ротор с горните характеристики и 3 брониращи щифта с дадена дължина, изработени от стомана.

Абстрактните дефиниции определят цели многообразия от изделия от даден вид – например - Ключалка NW4 с всичките и разновидности по размер, покритие и т.н. и от друга страна позволяват чрез задаване на конкретни характеристики (конфигуриране или генериране) да бъдат получени всички допустими разновидности на многовариантните изделия – например Ключалка NW4 с размер 31/36, покритие никел-сатен, 3бр ключове и т.н. с пълното и описание от конкретизирани детайли и под-сборки.

Видове дефиниции

· Група – дефиниция на множество от елементи. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на групата е да предостави механизъм за избор на точно един елемент от множеството което дефинира.
· Пакет – дефиниция на множество от елементи. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на пакета е да предостави механизъм за избор на всички елементи от множеството което дефинира.
· Възел дефиниция – дефиниция на изделие възел с променливи стойности на атрибутите. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на възела дефиниция е да предостави възможност за абстрактно представяне на множество от изделия от един тип но със различни стойности на атрибути (варианти на едно изделие). Процеса на конфигурация започва със конкретизиране на стойностите на атрибутите което в последваща фаза води до конфигуриране на крайно изделие с точно определени атрибути и код.
· Клас детайли - дефиниция на множество еднотипни детайли различаващи се само по стойностите на своите атрибути. Не съдържа в себе си други елементи. Целта на детайла дефиниция е да предостави възможност за „генериране“ на голям брой еднотипни изделия (обикновено обединени под общ номер и чертеж ), с общ набор от атрибути, различаващи се само по стойностите на атрибутите.

Видове изделия

· Детайл – крайно единично изделие. Точно определен набор от атрибути и конкретни стойности.
· Възел – крайно изделие – сборка. Възел от детайли и други възли с точно пределен набор от атрибути и конкретните им стойности.

Групиране в папки

Изделията и дефинициите в дървото от папки в програмата ПСИ са разделени в две отделни категории

· Дефиниции – основа папка съдържаща дефинициите на изделия. Състои се от набор от под папки съдържащи дефиниции за основните типове от произвежданите продукти (Катинари, сейфове, брави, секретни ключалки и др.) както и папка съдържаща групи и пакети използване при дефинирането на изделията. Потребителя има възможност да преименува, изтрива размества и да създава нови папки.
· Детайли – основна папка съдържаща крайни изделия. Състои се от набор от под папки съдържащи детайли и сборки от основните произвеждани и използвани в производството изделия. Потребителя има възможност да преименува, изтрива размества и да създава нови папки.
· Клас детайли – основна папка за клас от детайли получени след генериране на „детайл дефиниция“. Съдържа папки наречени „Папка Детайли”
· Папка детайли – производна папка от генериране на „детайл дефиниция”. Всяко следващо ниво папки добавя атрибут характеризиращ крайните изделия (детайли) към набора от атрибути на предходната папка. Последното ниво от папки съдържа само детайли.


Форма за създаване на изделие

Формата за създаване на ново изделие се стартира от бутона Ново изделие [image] в лентата с инструменти на програмата „ПСИ на изделията”. Бутона предоставя възможност за избор на желания тип на изделието (Детайл, Възел, Група, Пакет, Възел дефиниция, Детайл дефиниция ).

Формата предоставя възможност за въвеждане на:

Идентификационен № - уникален номер на изделието в системата. Предоставя се възможност и за автоматично генериране на пореден номер

Префикс на Код – префикс на кода на изделието съобразен с фирмения стандарт за кодове на изделия. За образуването на крайния код на изделието ще бъде използван този префикс в допълнение с код генериран на база атрибутите на изделието и техните стойности

Тип – попълва се ако типа на създаваното изделие не е предварително избран

Статус – статус на изделието

· В производство
· В разработка
· Архивен

Префикс на Описание – префикса на описанието на изделието. За образуване на крайното описание на изделието ще бъде използван този префикс в допълнение с описание генерирано на база атрибутите на изделието и техните описания на стойностите

Префикс на Описание на Английски език – префикса на описанието на Английски език на изделието. За образуването на крайното описание на изделието ще бъде използван този префикс в допълнение с описание генерирано на база атрибутите на изделието и техните описания на стойностите

Папка – папка в която ще бъде разположено изделието. По подразбиране е избрана текущата папка ако тя може да съдържа изделия от този тип

Папка за конфигуриране – използва се за „Възел дефиниция” и "Клас детайли"

След записване на новосъздаденото изделие то се отваря за редакция във формата за редакция на изделия която предоставя по-голям набор от свойства


Клониране на изделия

За клониране на изделие се използва формата за създаване на ново изделия. Клонирането може да се стартира от бутона Клонирай изделие [image] в лентата с инструменти на програмата „ПСИ на изделията”. При клониране е задължително на се промени идентификационния номер на изделието, като всички останали негови характеристики могат да останат непроменени.


Редактиране на изделия

Формата за редакция на изделията може да се стартира от бутона Отвори изделие [image] в лентата с инструменти или от контекстно меню Отвори в списъка с изделия.

Формата за редакция на изделия предоставя удобен интерфейс за навигация между изделията:

· Текстово поле указващо текущото изделие както и списък с последно редактираните изделие
· Бутони назад и напред да смяна на текущото изделие
· Бутон за смяна на редактираното изделие с избрано изделие подчаст от структурата на текущото

В допълнение на свойствата на изделието предоставени за редакция от формата за създаване на изделие, формата за редакция на изделие предоставя още:

· ОТК Контрол – показва дали изделието подлежи на ОТК контрол, ако се закупува от доставчик
· Атрибути – списък с атрибути и техните стойности или формули за стойности. Предоставя се възможност за редактиране, добавяне или премахване на атрибут на изделие като и опции за включването и реда на подреждане на атрибутите в кода и описанието на изделията
· Алтернативни изделия - списък с алтернативни на текущото изделия
· Документи - списък с документи свързани с текущото изделие
· Доставчици – списък с доставчиците на това изделие


Изтриване на изделие

Формата за изтриване на изделие може да бъде стартирана от бутона Изтриване на изделие [image] или от контекстно меню Изтрий в списъка с изделията. Формата предоставя списък с изделия в които текущото изделие участва както и две основни опции за изтриването:

· Изтрий само това изделие – ако включва в себе си други изделия то те няма да бъдат изтрити
· Изтрий цялото дърво на това изделие – ако изделието включва в себе си други изделия то цялата му структура и всички изделия участващи в нея ще бъдат изтрити


Видове изделия и дефиниции

· Група – дефиниция на множество от елементи. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на групата е да предостави механизъм за избор на точно един елемент от множеството което дефинира.
· Пакет – дефиниция на множество от елементи. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на пакета е да предостави механизъм за избор на всички елементи от множеството което дефинира.
· Възел дефиниция – дефиниция на изделие възел с променливи стойности на атрибутите. Може да съдържа както дефиниции на изделия така и конкретни спецификации. Целта на възела дефиниция е да предостави възможност за абстрактно представяне на множество от изделия от един тип но със различни стойности на атрибути (варианти на едно изделие). Процеса на конфигурация започва със конкретизиране на стойностите на атрибутите което в последваща фаза води до конфигуриране на крайно изделие с точно определени атрибути и код.
· Клас детайли - дефиниция на множество еднотипни детайли различаващи се само по стойностите на своите атрибути. Не съдържа в себе си други елементи. Целта на детайла дефиниция е да предостави възможност за генериране на голям брой еднотипни изделия (обикновено обединени под общ номер и чертеж ), с общ набор от атрибути, различаващи се само по стойностите на атрибутите.
· Детайл – крайно единично изделие. Точно определен набор от атрибути и конкретни стойности.
· Възел – крайно изделие – сборка. Възел от детайли и други възли с точно пределен набор от атрибути и конкретните им стойности.


Основни положения при създаване на „Възел дефиниция“

Атрибути – всеки възел дефиниция се характеризира от определен набор атрибути. Използвайки атрибутите с вариращи стойности (тези които нямат зададена конкретна стойност или имат само стойност по подразбиране) се постига многообразието от крайни изделия които могат да възникнат след конфигурирането на възела дефиниция.

Избора на подходящ набор от атрибути е основна стъпка при изготвяне на производствената спецификация на изделието. Възела може да има неограничен брой различни атрибути като разработващия дефиницията има следния набор от опции свързани с тях:

· Избор на атрибут и допустимо множество от стойности за него
· Избор на стойност на атрибута
· Опция която да позволява или забранява редактирането на избраната стойност.
· Формула за стойност на атрибута – формула посредством която, на базата на останалите атрибути и конкретни параметри на изделието, се изчислява стойността на атрибута
· Опция за включване на стойността на атрибута в кода на крайното изделие и описанието на стойността на атрибута в описанието на крайното изделие
· Опция за позициониране на атрибута в кода и описанието на крайното изделие

Възела дефиниция може да включва в себе си:

· Детайли
· Групи
· Възли
· Пакети
· Възел дефиниции

Като разработващия може да контролира тяхното използване и съвместимост посредством следните свойства:

· Опция - показва че изделието не е задължително за включване в крайната сборка и може да се игнорира в процеса на конфигуриране
· Количество – броя изделия включени в крайната сборка от този възел в дървото
o Мин – минимално количество – използва се когато в процеса на конфигуриране броя изделия включени в сборката е избираем
o Макс – максимално количество - използва се когато в процеса на конфигуриране броя изделия включени в сборката е избираем
· Формула за количество – формула по която, в съответствие със стойностите на атрибутите и характеристиките на възел дефиницията, се изчислява крайния брой изделия от този възел в дървото които ще бъдат включени в сборката
· Формула за съвместимост – използва се когато „естествената” съвместимост по атрибути не дава желаните резултати
· Включи описанието в описанието на сборката – конкатенира описанието на текущия клон в дървото към описанието на сборката
· Включи количеството в описанието на сборката – добавя информация за броя крайни изделия които влизат в сборката от този клон на дървото
· Добави цената в цената на сборката – използва се при формиране на цените на крайните изделия

Връзка между атрибути – списък от атрибути и техните стойности които характеризират връзката между възела дефиниция и текущия клон в неговото дърво. Обикновено се използват когато в основния възел дефиниция бива вложен друг възел дефиниция и придават контекстни стойности на атрибути на вложеното изделие.


Конфигуриране на изделия

Конфигурирането на изделия при които изхождайки от даден възел дефиниция и задавайки необходимите стойности на атрибути и други характеристики на възела се достига до реално крайно изделие.

Програмата за конфигуриране на изделие може да бъде стартирана от бутона Конфигурация на изделие [image] в лентата с инструменти на програмата „ПСИ на изделията“. При стартиране на процеса на конфигуриране, потребителя трябва да се увери че всички атрибути са конкретизирани че избор на стойност или формула за стойност на атрибута, това е задължително условие и процеса не може да продължи без пълния набор от стойности на атрибути на възела дефиниция.

За преминаване в следваща стъпка [image], потребителя трябва да се увери че следните условия са изпълнени:

· От под дървото на всяка група в дефиницията е избрано точно едно изделие
· За всяко опционално изделие е избрано дали да бъде включено в сборката
· Въведени са необходимите количества за всяко изделие където това е позволено

Преди записване на вече конфигурираното изделие потребителя има възможност да провери резултата и при несъответствие да се върне неограничен брой стъпки назад [image] до началото на процеса на конфигуриране. Конфигурираното изделие се записва от бутона Запис , като му се създава уникален идентификатор. Ако вече е било създадено изделие с идентична конфигурация то не се записва.


Генериране на многообразия от детайли

За генерирането на многообразие от еднотипни детайли се използва помощния тип изделие Детайл дефиниция. Детайла дефиниция има всички свойства на Детайл като атрибутите му нямат зададени конкретни стойности и могат да имат само формула за стойност.

Формата за генериране на детайли може да бъде стартирана от бутон Генериране на детайли от клас [image] в лентата с инструменти на програмата „ПСИ на изделията“. Формата предоставя следните основни опции:

· Маска # - шаблон за създаване на идентификационния номер на генерираните детайли
· Атрибути на класа – списък на атрибутите на детайла дефиниция от който изхожда генерирането на детайли
o Възможност за включване в групирането по папки на избраните атрибути
o Възможност за избор на реда в който ще се извърши групирането по папки
· Стойности на атрибута – възможност за избор на някой или всички [image] стойности на избрания атрибут които ще участват в генерираните детайли
· Формула за несъвместимост – формула по която да се изчислят и отхвърля несъвместимите детайли
· Дървовидна структура от папки и детайли показваща резултатите от генерирането на детайли
· Списък с атрибутите на избрания детайл
· Списък с всички генерирани детайли както и инструменти за търсене и филтриране

Резултатната структура от папки и детайли от генерирането ще бъде записана в Папката за конфигурации на детайла дефиниция


Промяна на версията на изделие

Промяна на атрибути на изделие. Смяна на версията

Всяка промяна в набора от атрибути за изделия в редовно производство трябва да се съпроводена от едновременна смяна на версията на съответното изделие.

1. Промяна на текущата версия на изделие
a. Функциите за контрол на версията могат да бъдат достигнати чрез формата за редакция на изделие в раздел „Други“
b. Таблицата с историята на предходните версии показва датата на въвеждане на съответната версия, както и кратка забележка описваща съответната промяна
c. Добавянето на нова версия се осъществява от бутона
d. В диалоговия прозорец се попълва кратко описание на извършените промени
2. След промяна на текущата версия на изделието се налага коригиране на някой от складовите партиди от съответното изделие с предходна версия
a. За откриване на съответните складови партиди се използва „Браузър на склад“ (Склад – Програми – Браузър на склад)
b. Преминава се в режим на търсене, избира се подходящ склад и се въвежда кода на търсеното изделие. След натискане на бутона „Търси“ се визуализират всички отворени партиди от търсеното изделие
c. На промяна подлежат следните партиди:
i. без клиентска поръчка
ii. вътрешна поръчка
iii. „затворена“ или „затворена от служител“ клиентска поръчка
d. За да редактираме конкретна клиентска поръчка е необходимо да я изберем от таблицата и след това да натиснем бутона
e. Преминаваме в режим на редакция във формата за преглед на партиди
f. Реконфигурираме изделието като от полето за избор на продукт
g. Следваме стъпките на „съветника“ за реконфигуриране на изделия без да променяме атрибутите
h. След приключване на „реконфигурацията“ записваме промените в партидата и затваряме формата за редакция и преглед на партиди
i. Повтарят се стъпки d-h за всички партиди
3. Описаните промени на партиди е необходимо да се приложат и върху изделия в които участва текущото изделие
a. За откриване на свързаните изделия се използва програмата „ПСИ на изделията“
b. За да визуализираме списък със свързаните изделия използваме бутона [image] „Разглеждане на свързаните изделия“


Атрибути на изделия

Всяко изделие или дефиниция (детайл, възел, детайл дефиниция, възел дефиниция, група, пакет, клас детайли и папка детайли ) се характеризират с определен набор от атрибути и стойности на атрибути. Атрибутите могат да бъдат част от изделието или дефиницията в резултат на „Генериране”, „Конфигуриране” или ръчното им добавяне към него. Основната разлика между изделие и дефиниция на изделие е че при дефиницията се допуска съществуването на атрибут без конкретна стойност докато при изделието всички атрибути трябва да имат съответстваща стойност. Всеки атрибут описва някоя основна характеристика на изделието (размер, цвят, покритие, конструкция, функция, тегло, площ и др.) като стойностите на атрибутите дават и конкретните параметри на тази характеристика.

Основните свойства на атрибутите са:

Код – кратък код на атрибута, за изписването му обикновено се използват главните букви от латинската азбука. Пример за употребата на този код са всички формули в системата касаещи атрибутите на изделията.

Име – име или кратко описание на атрибута

Тип – типа на стойностите на атрибута

· Str – текстови стойности
· Int – целочислени стойности
· Dbl – дробни числа

Папка – разположение на атрибута в дървото с папките от атрибути

Системен – показва дали текущия атрибут е основен за системата

Дефиниции на допустими стойности – всеки атрибут има една или повече дефиниции от допустими стойности които определят множества от еднотипни стойности предназначение за различни изделия които притежават съответния атрибут.

· Име – наименование на дефиницията от допустими стойности
· Изброим – показва дали стойностите в множеството са изброими или са в рамките на допустим интервал
· От – начало на допустимия интервал от стойности за неизброимите множества
· До- край на допустимия интервал от стойности за неизброимите множества

Стойности – всяко изброимо множество от допустими стойности дефинира поне една стойност

· Стойност – конкретна стойност на атрибута
· Описание – описание на стойността
· Описание Англ. – описание на стойността на Английски език

Вкл. в търговското описание - указва дали стойността на атрибута (описанието на стойността ако е изброим) се включва в съкратеното описание на конфигурируемите изделия (описание при фактуриране).


Модул Склад

 Top

Enter topic text here.


Дефиниране на атрибути. Програма „Атрибути”

Програмата атрибути е достъпна през главната програма „Инженеринг и технологии” > „ПСИ“ > „Програми” > „Атрибути” или през програмата „ПСИ на изделията” от бутона Атрибути на изделия [image]. Атрибутите са разпределени в папки, като структурата им може да бъде променяна и е препоръчително да се групират по типа на изделията в които се използват. Потребителя може да редактира, добавя изтрива и размества папки в дървото с папките на атрибутите. При избиране на папка програмата показва списък с атрибутите в нея. За преместването на атрибути от папка в папка се използват бутоните Копирай атрибут [image] и Постави атрибут [image] и функционалността предоставена от тях. Бутона Добави нов атрибут [image] създава атрибут в текущата папка.

За добавянето на нов и редактирането на съществуващ атрибут се използва програмата за редактиране на атрибути. Чрез нея могат да се променят основните свойства на атрибута (Код, Име, Тип, Папка и Системен), да се добавят нови дефиниции на допустими стойности и нови стойности в тези множества. Чрез програмата за редактиране на атрибути не могат да се променят стойностите на атрибутите и техните описания, за целта следва да се използва програмата за редактиране на стойности на атрибути [image]. Промяната на стойност на атрибут води след себе си няколко важни промени:

· Променя се текущата стойност на избрания атрибут
· Променя се текущата стойност на избрания атрибут във всяко едно изделие в което участва
· Преизчислява се кода на всяко едно изделие в което участва избрания атрибут
· Формулите в които се използва избрания атрибут няма да работят коректно


Програма Браузър Документи

 Top
· Съдържа систематизирана информация за документи и допълнителни функционалности за добавяне, преглед и редакция.

Лента с инструменти

1. Добавя папка.
2. Преименува папка.
3. Изтрива папка.
4. Създаване на нов документ.
5. Добавя версия на документа.
6. Редактиране на документа.
7. Копира избрания документ.
8. Поставя избрания документ в папка.
9. Разгледаждане на избрания файл.
10. Вземи файла локално.
11. Прикачи файл в архива.
12. Премахни файл от архива.
13. Вземи файла за редакция.
14. Върни файла в архива.
15. Откажи редакция.
16. Промяна на предишните версии на документа.
17. Последни версии.

Таблица документи

#- номер на документа

Означение- означение на документа.

Вер. - версия на документа.

Заглавие- заглавие на документа.

Файл-име на файла.

Изделие- индентификатор на изделието.

Статус на приемане в ТА- статус на приемане в техническия архив.

Заповед за ТА- номер на заповед за приемане в техническия архив.

Тип-тип на документа.

Език-език на документа

Създаден от -потребител създал документа

Създаден на-дата на създаване

Променен от-последна промяна от потребител

Променен на-дата на промяна

Взет от-взет за редакция от потребител


Програма Права върху документи

 Top

Права върху документи

· Служи за задаване на права на потребители от системата върху папки с документи чрез отметките Четене и Писане. Съдържа допълнителна функционалност Копиране на права , чрез която се копират всички права от избрана папка.


Меню Справки

 Top

Плащания по патенти,дизайни,марки

Справка за плащания по патенти,дизайни,марки за период

Достъп до архив

Справката за достъпа на служители до документи от архива за определен период

Прикачени документи към изделия

Обща справка за прикачени документи към изделия и изделия без прикачени документи в избрана папка

Прикачени файлове към изделия

Справка за прикачени документи към изделия в избрана папка


Модул Технологии

Модул технологии

Модулът Технологии служи за дефиниране на процеса на обработка на произвежданите изделия или техния монтаж. Във него се съдържа информация за:

· Етапите в производството необходими за изработването на завършен продукт.
· Реда на действителната обработка на материалите и сглобяването на субкомпоненти. Техните количества и разходни норми.
· Видовете операции за обработка на компонентите.
· Работните единици- групи , където се извършва съответната операция, прилежащите им машини и инструментална екипировка. Времето за подготовка и обработка.
· Всички формули и константи използвани в другите модули на системата.
· Допълнителни програми за технологична разработка и планиране.


Форма - Маршрутен лист

Форма Маршрутен лист

Използва се за стартиране на производство, дообработка или ремонт на продукти- нестандартни,извън редовно производство, тестови, мостри инструменти и др. Въвежда се пълна информация за необходимите материали, операции и документи за производство на продукта, както и данни за осчетоводяване на разходи. Създава се на базата на основание(заповед, известие, клиентска поръчка, тестова проба, мостра и т.н.) и предоставя възможност свързаност с съответен ред от клиентска поръчка или друг маршрутен лист.

No-идентификатор на маршрутния лист

Дата-дата на създаване

Статус-

· Нов
· Одобрен
· Затворен

Одобрил- потребител одобрил маршрутния.

Дата- дата на одобрение.

Базово изделие-

Отметка Търг. изделие-

Изделие описание- описание на продукта

Основание- основание на базата на което е създаден маршрутния лист.

Към маршрутен лист- връзка с основния маршрутен лист.

Брой за изработка-брой продукти за изработка.

Брой за настройка- необходим брой за настройка.

Изработени добри-количество изработени продукти.

Клиентска поръчка ред- ред от клиентска поръчка свързан с маршрутния лист.

Брак-количество бракувани продукти.

Получени-количество получени продукти за дообработка.

От-

Бележки- бележки относно получените продукти

Таблици

Необходими продукти

Таблица за избор на продукти със съответните количества и разходни норми.

Операции

Таблица с операции необходими за изпълнение на маршрутния лист ,извършвани в съответен отдел.

Документи

Техническа документация относно продукта.

Групираща рамка Осчетоводяване

Отметка Осчетоводяване-

С-ка разходи-

С- ка разпр-

С- ка продукция-

Изработени-

Сч. статус-

Dt лв-

Меню-Филтър

- затворени или неизписани маршрутни листи.

-създадени маршрутни листи за период

Меню-Изпълни-

-Изпълни програма > Клонирай маршрутен лист-функционалност за клониране на маршрутен лист.

-Изпълни справка- преглед и печат на маршрутен лист.

За общи указания за работа с форми виж.


Програма - Операции

Операции

Програмата Операции служи за въвеждане и редакция на технологични операции. Съдържа всички технологични операции свързани с обработката на материали и компоненти и изисквания за извършване и регулация на производствения процес.

Лента с инструменти

1. Добавяне нова папка в селектираната папка.

2. Преименуване на папка.

3. Изтриване на папка.

4. Създаване на нова операция в селектираната папка.

5. Клониране на избраната операция.

6. Позволява редактиране на операцията в зависимост от зададените права за редакция.

7. Изтриване операция в зависимост от зададените права за редакция и участието й в маршрути.

8. Копиране избраните операции.

9. Поставяне копираните операции в папка.

10.Принтиране избрана операция.

11.Режим на търсене- позволява разширено търсене по основните характеристики на дадена операция, както и по всички материали,машини и инструменти свързани с извършването й.

12. Търсене по папки.

Основни функционалности

Добавяне и редактиране на операция.

Бутони

Задай права за редакция-

Разделител Операция

Код на операцията - кратък код за обозначение на операцията (задължително поле).

Име на операцията - наименование (задължително поле).

Квалификационна група за операцията/настройка и брой оператори - квалификационна група на операторите за изпълнение и настройка, както и техния брой.

Описание на операцията - подробно описание на технологичния процес.

Отметка ОТК операция - маркира се при контролна операция.

Разделител Норми

Въвеждат се стойности и формули необходими за изчисления на времеви, количествени и разходни норми.

Отметка Използвай оперативното време за нормиране-

Групиращи рамки:

ЕОД (бр.)-

Разделяне на заготовки (бр.)-

Оперативно време(сек./бр.)-

Ефективност-

Нормовреме(сек./бр.)-

Технологичен брак(%)-

Време за настройка(мин.)-

Бройки за настройка(бр.)-

Тегло след операцията(кг./бр.)-

Допуск на технологичен брак(%)-

Допуск на бройки за настройка(бр.)-

Норми за ОТК:

· Брой-
· Брой(%)-
· Мин.брой-
· Време за ОТК(сек./бр.)-

Разделител Машини и инструменти

Избор на машини, инструменти и мерители използвани за изпълнение операцията.

Разделител Материали

Избор на основни и спомагателни материали , тяхната разходна норма и себестойност.

Разделител Кооперация

Кооперирани операции и подробна информация за тях.

Разделител Документи- документална информация свързана с текущата операция

Разделител Подоперации

Разделител Маршрути- производствените маршрути, в които участва операцията.


Програма - Маршрути

Маршрути

Програма за въвеждане и редакция на маршрути. Съвкупността от операции необходими за производството на дадено изделие. Реда на изпълнение на съответните операции и входно-изходните компоненти за всеки етап. Комбинацията от възможни маршрути и информация за тях.

Лента с инструменти.

1. Добавяне нова папка в избраната папка.
2. Преименуване на папка.
3. Изтриване на папка.
4. Добавяне на нов маршрут в избраната папка.
5. Клониране на избрания маршрут
6. Позволява редактиране на маршрута в зависимост от зададените права за редакция.
7. Изтриване маршрут в зависимост от зададените права за редакция.
8. Копиране на избраните маршрути.
9. Поставяне на копираните маршрути в папка.
10. Тестване на маршрут- предоставя пълна информация за всички дефиниции на маршрути необходими за производството на крайното изделие.
11. Позволява разширено търсене по име,операция и изделие на даден маршрут.
12. Търсене по папки.

Основни функционалности

Добавяне и редактиране на маршрут.

Име-въвежда се името на маршрута.

Папка - избор на папка.

Тип - тип на маршрута.

Ранг-

Ред-

Отметка произволен ред на изпълнение.

Лента с инструменти.

1. Избор на операция и добавяне след селектирания ред.
2. Добавяне на фиктивна операция.
3. Движение нагоре в таблицата с операции.
4. Движение надолу в таблицата с операции.
5. Премахване на избрана операция от таблицата.
6. Разглеждане на операция.
7. Тестване на маршрут.

Маршрутна карта- дава възможност за определяне реда на изпълнение и комбиниране на операциите.

Предишни операции- съдържа операцията предхождаща селектираната от таблицата с операции

Следващи операции- съдържа следващата операция след селектираната от таблицата с операции

Изделия-определяне на входно/изходните изделия за текущата операция.

Несъвместими маршрути - задаване на несъвместими маршрути.

Тестване на маршрут

Маршрути - всички съществуващи маршрути за избраното крайно изделие

Входни изделия- таблица с входните изделия необходими за производство

Изходни изделия- таблица с изходните изделия

Маршрутна карта- съдържа операциите в избрания маршрут и нормовремена и изчислени разходни норми.

Разделители - при избор на разделител предоставя пълна информация в съответния контекст във вид на таблица


Програма - Формули

Формули

Програмата Формули служи за създаване и редакция на формули за изчисления и ограничения необходими в различните модули на системата.

Лента с инструменти

1. Добавяне на папка.

2. Преименуване на папка.

3. Изтриване на папка.

4. Създаване на нова формула в селектираната папка.

5. Клониране на формула.

6. Редактиране на формула.

7. Изтриване на формула.

8. Копиране на формула.

9. Поставяне формула в папка.

10.Използване на формула.

11.Режим на търсене- позволява разширено търсене по име, описание и формула.

12. Търсене по папки.

Създаване на нова формула

Основни полета

Име на формулата- въвежда се име на формулата.

Описание- кратко описание на формулата.

Папка- избор на папка за запис.

Оператори

Аритметически:

· Сума(х+у)-сумата на аргументите х и у.
· Разлика(х-у)- разликата на аргументите х и у.
· Умножение(х*у)- произведението на аргументите х и у.
· Деление(х/у)- частното на аргументите х и у.
· Степен(х^у)- степенуване на аргумента х на степен у.
· Целочислено деление(х\y)-деление на аргумента х на аргумента у с резултат цяло число.
· Остатък при деление(х%у)- остатъка при делението на аргумента х на аргумента у.
· Скоби((х))- поставяне на аргумента х във скоби.

Логически:

Логическите оператори връщат резултат True(вярно) или False(невярно).

· И(х&y)-логическото "И" връща резултат True(вярно), само тогава, когато и двете условия са True(вярно).
· ИЛИ(х|у)-логическото "ИЛИ" връща резултат True(вярно), когато поне едно от условията е True(вярно).
· Отрицание(~х)-операторът за логическо отрицание сменя стойността на аргумента.

За сравнение:

· Равно(х=у)
· Различно(х<>у)
· По-малко(х<у)
· По-голямо(х>у)
· По-малко или равно(х<=у)
· По-голямо или равно(х>=у)

Функции

Математически:

· Закръгляне(round(x,y))- закръгляне на аргумента х до у позиции след десетичната запетая.
· Закръгляне(floor(x))- закръгля аргумента х към по-малкото цяло число
· Корен квадратен(sqrt(x))- корен квадратен от аргумента х.
· Максимум(max(x,y))- връща аргумента с по-голяма стойност.
· Минимум(min(x,y))-връща аргумента с по-малка стойност.
· Абсолютна стойност(abs(x))-абсолютната стойност на аргумента х.
· Логаритъм десетичен(log(x))-десетичен логаритъм от аргумента х.
· Логаритъм натурален(ln(x))-натурален логаритъм от аргумента х.
· sin(x)-синус на аргумента х.
· cos(x)-косинус на аргумента х.
· tan(x)-тангенс на аргумента х.
· arccos(x)-аркускосинус на аргумента х.
· arctan(x)-аркустангенс на аргумента х.

Текстови:

Символен низ-последователност от краен брой елементи от символен тип.

· Конкатенация concat(х,у,...)-събиране на два или повече символни низа. Пример:Ако х="те" и у="кст" резултата е "текст"
· Заместване(replace(x,y,z))-заместване на поредни символи от символен низ. Пример:Ако х="текст1a", у="1a" ,z="2б"резултата е "текст2б".
· Част от текст(mid(x,y,[z]))-
· Част от текст,лява(left(x,y))-избор на символи от лявата част на символен низ. Пример:Ако х="текст1a", у="5" резултата е "текст".
· Част от текст,дясна(right(x,y))-избор на символи от дясната част на символен низ. Пример:Ако х="1aтекст", у="5" резултата е "текст".
· Повторение на символи(strdup(x,y))-повтаря символ х на брой пъти. Пример:Ако х="5", у="т" резултата е "ттттт".
· Допълване от ляво(padleft(x,y,z))-
· Допълване от дясно(padright(x,y,z))-
· Дължина(leng(x))- брой на символите в символния низ. Пример:Ако х="текст" резултата е "5".
· Позиция на(indexof(x,y))- позиция на символ в символния низ. Пример:Ако х="текст" и у="е"резултата е "2".
· Съдържа(contains(x,y))-проверява дали символ се съдържа в символния низ. Пример:Ако х="текст" и у="е"резултата е "1"(вярно).
· Започва с(starts(x,y))-проверява дали символния низ започва с зададен символ. Пример:Ако х="текст" и у="е"резултата е "0"(невярно).
· Завършва с(ends(x,y))-проверява дали символния низ завършва с зададен символ. Пример:Ако х="текст" и у="т"резултата е "1"(вярно).
· Премахване на празните символи(trim(x))-премахва празните символи.
· Главни букви(ucase(x))-изписва текст с главни букви.
· Малки букви(lcase(x))-изписва текст с малки букви.
· Разделяне на текст(split(x,y,n))

Други:

· Стъпаловидна[=,=](step2E(x1,x2,c1,c2,v1,...,v))- функцията връща резултат v1, ако аргумента х1 е равен на стойността с1, аргумента х2 е равен на стойносттас2 и т.н.. Ако не са изпълнени условията връща резултат v.
· Стъпаловидна[=,=..=](stepNE(n,x1,x2..xn,c1,c2,..cn,v1...,v))- функцията връща резултат v1, ако всеки един елемент от множеството аргументи х1..xn e равен на съответстващата му стойност от множеството c1..cn, където n е броя на елементите..Ако не са изпълнени условията връща резултат v
· Стъпаловидна[=](stepE(x,c1,v1,c2,v2...,v))- функцията връща резултат v1, ако аргумента х е равен на стойността с1,v2 ако аргумента х е равен на стойността с2 и т.н.. Ако не са изпълнени условията функцията връща резултат v.
· Стъпаловидна[<=](stepLE(x,c1,v1...,v))- функцията връща резултат v1, ако аргумента х е по-малък или равен на стойността с1 и т.н.Ако не е изпълнено условието функцията връща резултат v
· Стъпаловидна[<](stepL(x,c1,v1,...,v))- функцията връща резултат v1, ако аргумента х е по-малък от стойността с1 и т.н.Ако не е изпълнено условието функцията връща резултат v
· Алтернативна(iif(x,v1,v2))- алтернативната функция връща резултат v1, ако зададеното условие x е TRUE(вярно), и резултат v2, ако това условие е FALSE(невярно).
· Елемент от множеството(in(x,c1,c2,...,cn))- функцията връща резултат TRUE(вярно),ако аргумента х е елемент от множеството на изброените стойности с1,с2...cn, и стойност FALSE(невярно),ако не е.

Константи:

Пи(pi)

E(e)

Специални функции

Стойности на атрибути- съдържа всички стойности на атрибути в системата.

Кодове на атрибути- съдържа всички кодове на атрибути в системата.

Кодове на константи- съдържа всички кодове на константи в системата.

Функции за атрибути:

· Стойност на атрибут по ID на стойност V()-
· Стойност на атрибут на изделие AttrValue()-
· Стойност на външен атрибут ParentAttrValue()-
· Наличие на атрибут AttrExists()-
· Наличие на външен атрибут ParentAttrExists() -
· Наличие на атрибут на основното изделие RootAttrExists() -
· Описание на атрибут AttrDescr() -
· Описание на атрибут Англ. AttrDescr2() -
· Стойност на атрибут на основното изделие RootAttrValue() -

Функции на изделия:

· Код на изделието CompCode()-
· Описание на изделието CompDescr() -
· Описание на изделието Англ. CompDescr2()
· Изделието е детайл IsDetail()-
· Изделието е възел IsNode() -
· Бройки изделия в партидата LotAmount() -

Функции на операции:

· Текуща операция CurrentOper() -
· Непосредствена предишна операция PreviousOper()-
· Предишна операция PassedOper()-

Функции за материали:

· Материала съответства MatchMaterial() -
· Размер на материала MaterialDim()-
· Относителна плътност Density()-
· Тегло за ед. материал MaterialUnitWeight-

Функции за ТРЗ:

· Основна заплата OsnovnaZaplata()-
· Работни дни в месеца RabotniDni()-
· Отработени дни OtraboteniDni() -
· Заработка Zarabotka() -
· Трудов стаж общ Staj() -
· Фирмен стаж StajFirmen() -
· Година на раждане Roden() -
· Брой работни дни за контекстния период/месец PeriodRabotniDni() -
· Сума за начисления SumPlus() -
· Сума на удръжки SumMinus() -

Стойност на константа ConstValue()-


Програма - Константи

Константи

Използва се за въвеждане и редакция на константи , участващи в формули.

Лента с инструменти

1. Добавяне на нова папка в селектираната папка.

2. Преименуване на папка.

3. Изтриване на папка.

4. Добави константа- създава нова константа в селектираната папка.

5. Клониране на константа-клонира избраната константа.

6. Редактиране на константа-позволява редактиране на константа.

7. Изтриване на константа-изтрива константа.

8. Копиране на избрана константа.

9. Поставяне на копираната константа в папка.

10.Търсене- разширено търсене по параметри.

11.Папки- търсене по папки.

Таблица Константи - съдържа всички константи в селектираната папка.

Таблица Формули- съдържа данни за формулите в които участва селектираната константа.

Създаване на нова константа

При създаване на нови константи е препоръчително името да бъде на латиница. При въвеждане на константа от числов тип не са разрешени отрицателни стойности

Основни полета:

Име- име на константата.

Описание- кратко описание на константата

Тип-избор на типа на константата

· Число
· Текст

Стойност-въвежда се стойност.

Таблица- съдържа данни за промените извършени от служител към дата.


Меню Справки

Маршрутна карта

Произвеждани изделия в участък-

Справка за обработваните изделия в работен участък.

Маршрутни листи

Справка за затворени маршрутни листи към дата.

· Неосчетоводени
· Осчетоводени


Модул Технологии

 Top

Модул технологии

Модулът Технологии служи за дефиниране на процеса на обработка на произвежданите изделия или техния монтаж.Във него се съдържа информация за:

· Етапите в производството необходими за изработването на завършен продукт .
· Реда на действителната обработка на материалите и сглобяването на субкомпоненти.Техните количества и разходни норми.
· Видовете операции за обработка на компонентите.
· Работните единици- групи , където се извършва съответната операция, прилежащите им машини и инструментална екипировка. Времето за подготовка и обработка .
· Всички формули и константи използвани в другите модули на системата.
· Допълнителни програми за технологична разработка и планиране.


Модул Управление на проекти


Програма - Менажер Проекти

Менажер Проекти

Програмата служи за създаване и планиране на проекти в отдели и дирекции с цел предварително координиране на работните процеси и повишаване на ефективността на производството и разработката на нови продукти. В годишен план се дефинират на дейностите, които трябва да бъдат извършени, за да се постигнат желаните резултати. Определя се на тяхната последователност във времето, периоди за изпълнение и тяхната прогнозна себестойност, като по този начин във всеки един етап на може да се даде оценка за изпълнението на проекта .

Лента с инструменти

1. Избор на отдел/дирекция.
2. Избор на година.
3. Добавяне на папка.
4. Редактиране на папка.
5. Изтриване на папка.
6. Създаване на нов план.
7. Клониране на план.
8. Копиране на план.
9. Одобрен/Неодобрен.
10. Принтиране на план.
11. Добавяне на проект.
12. Отваряне на проект.
13. Изтриване на проект.
14. Клониране на проект.
15. Копиране на проекти.
16. Поставяне в папка.
17. Премахване от папка.
18. Преглед на всички документи.
19. Създаване на задача.
20. Отваряне на задача.
21. Изтриване на задача
22. Дефиниране на типове планирано време.
23. Отработено време.
24. Търсене
25. План
26. Опресняване на данните

Търсене

Функционалност за разширено търсене на проекти по различни характеристики, периоди и статус на изпълнение .


Програма - Задачи

Задачи

Програмата служи за разширено търсене и преглед на задачи към проекти. Позволява филтриране по основните характеристики на задачите, проекта и годишния план към които са зададени.


Програма - Съобщения

Програмата служи за преглед на съобщения.


Програма - Отработено време

Отработено време

Програмата служи за преглед на отработеното време по проекти.

Лента с инструменти

1. Търсене.
2. Опресняване.
3. Отваряне на задача.
4. Отваряне на проект.

Групираща рамка Търсене:

Дирекция- избор на дирекция.

Проекти от год.- избор на период на търсене.

Папка- избор на папка.

Проект- избор на проект.

Служител- избор на служител.

Таблица - съдържа данни за служители,проекти, задачи и отработени времена по тях.

Общо време- сумата от времената на всички от таблицата.


Управление на документацията

 Top

Enter topic text here.


Модул Машини и инструменти


Форма Машини - инстанции

Форма Машини - инстанции

Предназначение:

· Преглед и редакция на данни за машини, инструменти и мерители по инвентарен номер. Съдържа детайлна информация за връзката им със съответните работни единици(групи), планови ремонти и необходими прикачени документи.

За общи указания за работа с форми виж.


Форма - Работни единици

Форма Работни единици

Предназначение:

· Съдържа всички елементарни структурни единици на предприятието, където са разположени изпълнителите на работата и съответното технологично оборудване.
· Техния работен статус и капацитет.
· Групите от работни единици, в които участват.

Идент.# -генерира се от системата.

Статус-избор на работен статус.

Отметка Временно спряна-маркира се при временно спиране от работа.

Описание- описание на работната единица.

Отдел #- избор на отдел.

Оборудване в работната единица- избор от таблица на машини и инструменти включени в работната единица и техния статус.

Групи- избор на групи в които участва работната единица.

За общи указания за работа с форми виж.


Форма - Работни единици (групи)

Форма Работни единици (групи)

Предназначение:

· Обединява отделни работни единици в по-големи групи в зависимост от извършваната работата.
· Позволява определяне на работното време.
· Дава информация за приложимостта на групата в изпълнението на дадени операции.

Група #-генерира се от системата.

Име-кратко описание на групата.

Отметка Отпаднала- маркира се при отпаднала група.

Отдел #- избор на отдел.

Таблици за избор на съответните машини и работни единици.

Групираща рамка Работно време -организация на работното време на групата с отметки Работи в събота/неделя.

Таблица Приложимост- списък с операциите, в които се използва групата.

За общи указания за работа с форми виж.


Форма - Инструменти

Форма - Инструменти

Формата служи за въвеждане и редакция на данни за инструменти.

Основни полета на формата.

Тип- избор на тип на инструмента от дървото с папки.

Инструмент#-идентификатор на инструмента.

Отметки-

· Серия
· ОТК контрол

Наименование- име на инструмента

Изделиe-въвежда се ако инструмента има съответстващо изделие от системата

Описание- описание на изделието.

Таблица инстанции- въвежда се инвентарен и сериен номер, кратко описание

Сметки-

Групираща рамка Доставчици-

Съдържа поле за избор на главен доставчик и таблица за въвеждане на допълнителни доставчици

Таблица прикачени ни документи-

За общи указания за работа с форми виж.


Форма - Мерители

Форма - Мерители

Формата служи за въвеждане и редакция на данни за мерители.


Програма - Браузър продукти

Браузър продукти

Съдържание:

· Продуктовия каталог-заготовки, компоненти, крайни изделия и зависимости между тях.
· Инструменталната екипировка- мерители и инструменти.
· Материали-съвкупността от материални условия за производство.
· Извършвани услуги.
· Наличности.

Лента с инструменти:

1. Отваряне на избран ред от таблицата с продукти.
2. Отваряне на форма за добавяне (без изделия).
3. Копиране на избрания продукт.
4. Поставяне на избрания продукт в папка.
5. Търсене по папки.
6. Разширено търсене.
7. Разглеждане на зависимости.
8. Наличности от продукт.

Основни функционалности

Търсене

Позволява разширено търсене по следните характеристики:

Идент#- идентификатор на продукта.

Описание- точно описание или ключова дума.

В наличност- отметка филтрираща само продукти с наличности.

Свободни-отметка филтрираща само продукти с свободни наличности.

Тип- избор на тип продукт.

Разглеждане на зависимости

В зависимост от избрания вид продукт, дава информация за :

- изделия зависими от селектираното от таблицата с опция за избор на тип и отметка за директна свързаност.

- операции в които се използват инструменти, мерители или материали.

Наличности от продукт

Предоставя данни за наличности от избрания продукт в съответните участъци и количества, заделени или участващи в производството.


Меню Справки

Справки

Планови ремонти

Справка за планираните ремонти в определен участък за период. Ако не е въведен участък важи за всички участъци.

Извършени ремонти

Справка за извършените ремонти в определен участък за период. Ако не е въведен участък важи за всички участъци.

Извършени ремонти от служител

Справка за извършените ремонти от служител за период.

Използвани резервни части

Справка за използваните резервни части в определен участък за период. Ако не е въведен участък важи за всички участъци.

Спрени машини

Справка за спрени машини в определен участък. Ако не е въведен участък важи за всички участъци.

Неизпълнени планови ремонти

Справка за неизпълнени планови ремонти в определен участък за период. Ако не е въведен участък важи за всички участъци.

Престой на машини

Справка за престой на машини в определен участък за период.


Модул Управление на документацията


Форма - Известия

Форма Известия-[Отговори на известия]

Комбинирана форма с разделители - Изходящи известия и Отговори на известия за бърз достъп до информация свързана с известия .

Изходящи известия

Форма за въвеждане и редакция на известия с цел комуникация между различните отдели и дирекции. След запис на известието автоматично се генерират нови записи в формата Отговори на известия за всеки един получател, където входящия им номер е номера на Изходящото известие. Всяка промяна се отразява в изходящото известие.

Изходящ #- идентификатор на известието.

Отдел- избор на отдел.

Изготвил- потребител изготвил известието.

Одобрил- потребител одобрил известието.

Относно- кратка информация относно предмета на известието.

Съдържание- пълно съдържание на известието.

Дата- дата на създаване.

Краен срок - краен срок за отговор.

Дата на одобряване- дата на одобрение от служител на съответната дирекция.

Статуси-

· Нов- известието е в процес на дефиниране.
· Чакащ одобрение- известието не е одобрено
· Активен-известието е активно
· Приключен-известието е приключено

Таблица Получател

Задават се получатели на известието отдел или дирекция.

Таблица Прикачени документи

Таблица за избор на необходима документална информация свързана с текущото известие.

Меню -Филтри

Позволява филтриране на известията по техния статус.

За общи указания за работа с форми виж.


Форма Отговори на известия

Форма Отговори на известия

Формата съдържа отговори на известия от съответните дирекции -получатели.


Форма - Документи

Форма Документи

Кратка версия

Форма за добавяне и редакция на документи.

Документ#- идентификационен номер(генерира се от системата).

Заглавие- кратко описание на документа.

Описание- подробно описание на съдържанието на документа.

Папка- избор на папка.

Местонахождение- физическо местонахождение на документа (ако е във хартиен формат).

Тип, Формат, и Език на документа

Създаден от - потребител създал документа.

Създаден на - дата на създаване и последна промяна.

Получен на - дата на получаване.

Форма Документи(Пълна версия)

Съдържа разширена информация относно извършени промени и причините за тях, дати на получаване, публикуване и валидност, както и статус на въвеждане в техническия архив. Има следните допълнителни таблици:

Таблица Абонати

Абонати получатели на документи.

Таблица Документи за изпращане

Въвеждат се получатели на документа

Таблица Версии на документа

Предоставя данни за версиите на документа.

За общи указания за работа с форми виж.


Абонати

Форма - Абонати

Форма - Абонати

Форма за въвеждане и редакция на абонати, които могат да се избират като получатели в Форма - Документи.

Абонат #- генерира се пореден номер от системата.

Тип- избор на типа на абоната.

Идентификатор- избира се абонат от таблица

Описание- кратко описание.

За общи указания за работа с форми виж.


Форма - Документи чакащи изпращане

Форма - Документи чакащи изпращане

Таблица с документи чакащи изпращане към съответния абонат.


Форма - Заповеди за изменение

Съдържа заповеди за изменение на документи с полета за съгласуваност с различните дирекции към дата


Форма - Патенти,Дизайни,Марки

Форма за въвеждане и редакция на Патенти, Дизайни и Марки. Съдържа таблица за въвеждане на плащания към тях и прикачени документи.

За общи указания за работа с форми виж.


Форма - Зап. за въвеждане в техн.архив

Заповеди за въвеждане в технически архив

Форма за въвеждане в техническия архив на документи след съответната проверка, контрол и одобрение към дата. Съдържа таблици за добавяне на прикачени документи - основни и допълнителни , за които се отнася заповедта.

Таблица Прикачени документи

Добави документи -добавяне на нов документ.

Групираща рамка Въведено в архив - име и идентификатор на служител въвел документа в архива, дата на въвеждане.

Таблица Допълнителни прикачени документи

Добави документи -добавяне на допълнителен документ.

Таблицата съдържа техническа документация свързана с заповедта и функционалности за директно Разглеждане на файл и Разглеждане на метаданни

За общи указания за работа с форми виж.


Форма - Зап. за внедряване/спиране от редовно произв.

Форма - Зап. за внедряване/спиране от редовно произв.

Служи за създаване и редакция на заповеди за внедряване, спиране,връщане в разработка и връщане в редовно производство на изделия. Съдържа полета за съгласуваност с дирекции, таблица за добавяне на изделия свързани с избраното и прикачени документи.

Заповед №- идентификационен номер

Тип:

· Заповед за внедряване в редовно производство-
· Заповед за спиране от редовно производство-
· Заповед за връщане в редовно производство-
· Заповед за връщане в разработка-

Дата- дата на заповедта

Статус-

· Нов-
· Чакащ одобрение-
· Одобрен-
· Отхвърлен-

Свързана заповед /от дата-

Изделие- идентификатор на изделието.

Разгледай- разглеждане на изделието в ПСИ.

Маршрут-разглеждане на маршрута на изделието.

Блок Съгласуване с дирекции

Съдържа полета за избор и въвеждане, на служители от отделните дирекции, които трябва да бъдат информирани за текущата заповед. Предоставя избор на два типа обратна връзка- съгласуване или уведомяване.

Таблица подизделия - изделия зависещи от основното , които също трябва да кореспондират на съответната заповед. Директно разглеждане на изделията и техния маршрут.

Добави изделия-добавяне на изделия в таблицата

Таблица прикачени документи

Добави документи- добавяне на документи

Таблицата съдържа техническа документация свързана с заповедта и функционалности за Разглеждане на файл и Разглеждане на метаданни

За общи указания за работа с форми виж.


Програма - Браузър Документи

Съдържа систематизирана информация за всички документи в системата. Допълнителни функционалности за добавяне, преглед и редакция.

Лента с инструменти

1. Добавяне на папка.
2. Преименуване на папка.
3. Изтриване на папка.
4. Създаване на нов документ.
5. Добавяне на нова версия на документа.
6. Редактиране на документа.
7. Копиране на избрания документ.
8. Поставяне избрания документ в папка.
9. Разглеждане на избрания файл.
10. Вземане файла локално.
11. Прикачване на файл в архива.
12. Премахване на файл от архива.
13. Вземане на файла за редакция.
14. Връщане на файла в архива.
15. Отказ от редакция.
16. Промяна на на предишни версии на документа.
17. Последни версии- преглед на последните версии на избрания документ

Таблица документи

#- номер на документа

Означение- означение на документа.

Вер. - версия на документа.

Заглавие- заглавие на документа.

Файл-име на файла.

Изделие- идентификатор на изделието.

Статус на приемане в ТА- статус на приемане в техническия архив.

Заповед за ТА- номер на заповед за приемане в техническия архив.

Тип-тип на документа.

Език-език на документа.

Създаден от -потребител създал документа.

Създаден на-дата на създаване.

Променен от-последна промяна от потребител.

Променен на-дата на промяна.

Взет от-взет за редакция от потребител.


Програма - Права върху документи

Права върху документи

Служи за задаване на права на потребители върху папки с документи, чрез отметките Четене и Писане в таблицата . Съдържа допълнителна функционалност Копиране на права , чрез която се копират всички права на потребители от избрана папка с възможност за избор чрез отметките Четене и Писане. Правата за достъп се задават от служител, отговарящ за тази дейност.


Меню Справки

Плащания по патенти,дизайни,марки

Справка за плащания по патенти,дизайни,марки за период

Достъп до архив

Справката за достъпа на служители до документи от архива за определен период

Прикачени документи към изделия

Обща справка за прикачени документи към изделия и изделия без прикачени документи в избрана папка

Прикачени файлове към изделия

Справка за прикачени документи към изделия в избрана папка


Модул Управление на взаимоотношенията с конрагенти


Форма - Доставчици и клиенти

Форма Доставчици и клиенти

Форма за въвеждане и редакция на данни за контрагенти.

Основни полета на формата

Контрагент#- генерира се от системата.

Тип- избор на типа на контрагента.

Име на кирилица-въвежда се име на контрагент.

Оригинално име-въвежда се оригиналното име на контрагента( български или английски).

ЕИК- въвежда се единния идентификационен код.

ЕИК по ДДС-въвежда се, ако контрагента е регистриран по ДДС.

МОЛ- въвежда се материално отговорно лице.

Адрес на ТД на НАП.

Валута- избор на валута.

Статус

· Активен
· Неактивен

Бележки.

Таблица Банкови сметки -таблица за въвеждане на данни за сметки на контрагента с отметка за главен и активен.

Групираща рамка Адрес по регистрация

Съдържа полета за адреси и връзки с избор на главен адрес за доставка.

Групираща рамка Оценка на доставчика

· Съдържа полета за оценка и допълнителни данни за контрагента(обичайни срокове за плащане,избор на група за отстъпки и категоризация).

· Таблица Контакти- избор на лица за контакти с отметка за главен контакт.

Групираща рамка Сметки

Съдържа полета за въвеждане на сметки в зависимост от типа на контрагента и вида на фактурирането.

· Информация за създател на записа и последна редакция.

Меню- Филтри

Позволява филтриране по типа на контрагента-доствчици,клиенти или само одобрени доставчици.

За общи указания за работа с форми виж.


Форма - Адреси за доставка

Форма Адреси за доставка

Използва се за въвеждане и редакция на адреси за доставка.

Основни полета на формата.

Контрагент#-избор на контрагент.

Адрес на доставка#- генерира се пореден номер за адрес за доставка с префикс идентификатора на избрания контрагент.

Тип- тип на контрагента.

Статус- статус на контрагента.

Групираща рамка Адрес- полета за въвеждане на пълния адрес за доставка и връзки за контакт.

Описание- бележки относно адреса за доставка.

За общи указания за работа с форми виж.


Форма - Контакти

Форма Контакти

Използва се за въвеждане и редакция на лице за контакт към контрагент.

Основни полета на формата:

Контакт#- генерира се пореден номер от системата.

Име на лице- въвежда се името на лицето за контакт.

Име на фирма -въвежда се име на фирма.

Групираща рамка Адрес- въвеждат се пълен адрес и връзки с контакта. Поле за комисионна.

Описание-бележки относно контакта.

Таблица Контакт за следните контрагенти- избор на контрагенти ,за които лицето е включено като контакт.

За общи указания за работа с форми виж.


ТРЗ


Форма - Личен състав

Форма - Личен състав

Форма за въвеждане и редакция на данни за служители. За общи указания за работа с форми виж.

Служител #- идентификатор на служителя.

Съответстващ потребител от системата- потребителско име използвано от служителя за вход в системата.

Групиращи рамки:

Лични данни- въвеждат се личните данни на служителя.

Текуща длъжностна характеристика- въвежда се информация длъжността на служителя.

Квалификация- данни за квалификацията

Таблици:

Проведени обучения- съдържа данни за проведени обучения.

Предишни длъжности във фирмата- съдържа данни за предишни длъжности заемани от служителя.

Стаж при други работодатели- съдържа данни за стаж при други работодатели.

За общи указания за работа с форми виж.


Форма - Служители

Формата съдържа всички данни от Личен състав , както и следната допълнителна информация:

Групираща рамка Параметри на работната заплата

Основна заплата-

Фирмен стаж-

Прослужено време-

Трудов стаж-

Друг стаж-

Таблици:

Начисления-

Удръжки-

За общи указания за работа с форми виж.


Форма - Отдели

Форма - Отдели

Форма за въвеждане и редакция на отдели, подразделения и съответните материално отговорни лица към тях. За общи указания за работа с форми виж.

Отдел#- идентификатор на отдел.

Име на отдел- пълно име на отдела.

Ръководител- избор на ръководител.

Секретар-избор на секретар.

Отметки:

· Складова отчетност-
· Производствен-

С-ка разх. прикл.-

Таблици:

Длъжности в отдела- таблица за въвеждане и редакцияна на длъжности в отдел.

Подразделения-подразделения към отдела.

Материално отговорни лица- таблица за въвеждане на материално отговорни лица към отдела.


Форма - Отсъствия


Форма - Квалификации

Форма за въвеждане на основни типове квалификации на служители, които съответстват на различни ставки използвани при формиране на заплащането. Въвежда се идентификатор и име на квалификацията. За общи указания за работа с форми виж.


Форма - Ставки


Форма - Работни карти

Форма - Работни карти

Форма за съдържа месечните заработки на служители на сделно заплащане. Съдържа текущата длъжностна характеристика на служителя и таблица за индивидуално формиране заплащането възоснова на извършени операции и изработени количества. За общи указания за работа с форми виж.


Счетоводство


Форма - Банкови сметки

Форма за въвеждане и редакция на банкови сметки .

Банкова сметка#- идентификатор на банкова сметка.

Фирма#- Идентификатор на фирма.

IBAN-международен номер на банковата сметка

BIC- идентификационен код на банката.

Счет. с-ка- номер на счетоводната сметка.

Групираща рамка Данни за банката-име и адрес на банката.

Групираща рамка Данни за банката(английски)-име и адрес на банката на английски.


Форма - Митнически декларации

Митнически декларации

Форма - Митнически декларации

Формата служи за въвеждане и редакция на митнически декларации.

ID- идентификатор на митническата декларация

Тип-внос или износ.

Статус-счетоводен статус.

Изготвил- идентификатор на служител изготвил декларацията.

Контрагент-идентификатор на контрагент(доставчик/ получател).

У-я на доставка-идентификатор на условията на доставка.

ЕИК по ДДС-единен идентификационен код по ДДС(Булстат)

ЕИК-единен идентификационен код.

МОЛ-материално отговорно лице.

Транс. док#- идентификатор на транспортен документ.

Tранс. док . No- номер на транспортен документ.

Транс. док. дата- дата на транспортния документ.

Тр. разх. лв.-транспортни разходи в лева.

Таблица Продукти-

Ред#-

Док#- идентификатор на документа в системата

Док. No-номер на документа

Док. Дата- дата на документа.

Продукт#-идентификатор на продукта

Описание- описание на продукта

К-во-количество и мерна единица

Цена на стоката-

Уточнена сума (лв)-

Мито(лв)-

ДДС(лв)-

Нето тегло-

Тр. разходи-транспортни разходи.

С-ка материали-сметка за материали.

Вал. курс-

ДДС%

По ф-ра

Мито-

ДДС

МОС

Групираща рамка Осчетоводяване

ДК

Дан. осн. с ДК

Дост. на път-

Ct лв.

Доставчик- сметка на доставчика.

Ct вал/лв

Референция-


Форма - Протоколи

Форма Протоколи

Формата служи за въвеждане и редакция на протоколи.

Основни полета на формата

Протокол # - идентификатор на протокола.

Протокол No- номер на протокола.

Дата- дата на протокола.

Тип:

· ВОП-вътрешнообщностни придобивания
· ДДС на мостри
· Корекции

Статус-

· осчетоводен
· неосчетоводен

Контрагент#- избор на контрагент

Фактура#- номер на фактура от системата.

Дата на данъчното събитие-

Отметки:

-Дневник покупки

-Дневник продажби

Тип продукти

Таблица Продукти-въвеждат се продукти от съответен ред на фактурата , тяхното количество,единична цена и стойност без ДДС, ДДС и кореспондираща сметка за материали.

У-я за ДДС-избор на условие за ДДС

Сумарни полета

Данъчна основа- сума без ДДС

ДДС%- данък добавена стойност в проценти

ДДС-данък добавена стойност

Общо-обща сума

Групираща рамка осчетоводяване-


Форма - Разходни центрове( направления)

Форма за въвеждане и редакция на разходни центрове.


Форма - Валути

 Top Previous

Форма - Валути

Фома за въвеждане и редакция на котировки на валути . В системата се използва обменния курс към последната дата.


Лента с бутони

 Top

Лента с бутони в команден режим

Навигация

Разглеждането на записи във формата става посредством бутоните за навигация.

Първи запис [image] - позиционира формата на първия запис при текущото сортиране.

Предходен запис [image] - позиционира формата на предходния запис при текущото сортиране.

Следващ запис [image] - позиционира формата на следващия запис при текущото сортиране.

Последен запис [image] - позиционира формата на последния запис при текущото сортиране.

При движение по записите в най-дясното поле на статус ленатата се изписва позицията на текущия запис спрямо текущото сортиране и броя на всички записи спрямо текущото филтриране [image] .

Търсене

Възможно е позиционирането върху определен запис по следния начин:

· в полето за търсене се въвежда валиден текст базиран на текущото сортиране.
· натиска се клавиша Enter или бутона Намери запис [image] .

Ако няма съвпадение на записа в полето за търсене и стойност от колоната на текущото сортиране, формата се позиционира върху запис, чиято стойност на сортираното поле започва със записа в полето.

Промяна на ключа за сортиране

Полето от базата данни по което се извършва сортиране (ключ) може да се промени чрез бутона Промяна на ключа за сортиране [image] или F7. Визуализира се прозорец с предварително зададени ключови полета. Може да се избере някое от тях или да се избира между всички полета от базата данни като се селектира Покажи всички. След като изборът е направен бутонът ОК променя ключа за сортиране, като затваря отворения прозорец. Текущият ключ за сортиране се показва в средното поле на статус лентата [image] .

Превключването между първичния и вторичния ключ за сортиране (зададени по подразбиране за формата) се извършва чрез бутона F11.

Временен филтър

Бутонът Временен филтър [image] се използва, за да се намалят временно броя записи, които се разглеждат. Той е тясно свързан с текущия ключ за сортиране - филтрира записите, оставяйки само тези, които имат стойност на полето-ключ, равна на стойността на ключа на текущия запис. Промяната се отразява в статус лентата – броят на записите намалява и в иконата на бутона –появява се червена стрелка [image] . Изключването на филтъра става с повторно натискане на бутона.

Пример: Ако разглеждаме фактури, сортирали сме записите по град и сме се позиционирали на запис,за който стойността на полето град е София. След като натиснем бутона Временен филтър, достъпни за разглеждане ще останат само записите, за които стойността на полето град е София. Ако обаче сме сортирали записите по номер на фактура и сме позиционирани на запис с номер на фактурата 123456, след натискане на бутона Временен филтър, то навигацията ще бъде възможна само за един запис, тъй като не би трябвало да съществува друга фактура със същия номер.

Режим на преглед

Режим на преглед се установява чрез натискане на бутона Режим на преглед [image] . Появява се нов прозорец, който предоставя функционалност за избор на полета от базата данни, които да са видими. Някои полета са маркирани по подразбиране, но може да се променят и да се добавят нови.

Изборът на полета е аналогичен на избора на множество файлове в Windows Explorer. Избор на допълнителни полета се осъществява като се задръжа Ctrl и се изберат полетата с мишката. Ако се избира последователност от полета, се избира първото с мишката и при задържан Shift се селектира последното от тях (отново с ляв бутон на мишката). Задържането и на Ctrl при избора на първо поле дава възможност за селектиране на няколко последователности от полета.

След като желаните полета са селектирани се натиска OK. Визуализира се таблица с цялата налична информация. Тя може да бъде сортирана по дадена колона посредством кликване с ляв бутон върху заглавното и поле. При повторен клик върху заглавното поле на колоната таблицата се пресортира в намаляващ ред.

Ако таблицата е сортирана по дадена колона е възможно търсене на определен запис в нея чрез полето за търсене долу в ляво.

Пример: Ако сме сортирали по град и напишем “София” в полето за търсене ще се визуализират първите данни, за които стойността на полето град е “София”.

Таблица може да бъде филтрирана по произволно поле като се използват стандартни функционалности за таблици с филтър.

Изборът на редове от таблицата е аналогичен на избора на полета за визуализация - отново посредством комбинациите на ляв бутон на мишката и Ctrl и/или Shift.

Данните от таблицата могат да бъдат експортирани към друга програма. Това става с натискане на бутона Копирай, след избор на редовете за експорт и Paste в документ на съответната програма.

Пример: Ако искаме да експортираме селектираните редове в таблица на Microsoft Excel, натискаме Копирай, след което отваряме съответния .xls файл и избираме Paste или Paste Special от меню Edit.

Натискането на OK в режим на преглед, след като е избран ред от таблицата ще затвори прозореца и ще покаже отново формата, като тя ще бъде позиционирана на записа, съответстващ на селектирания ред.

Клавишни комбинации (shortcuts) в команден режим

F1 - Помощна информация за формата.

F5 – Визуализация на предходен запис.

F6 – Визуализация на следващ запис.

F7 – Дава възможност за избор на ключ за сортиране.

F8 – Изпълни програма (само където е приложимо).

F9 – Изпълни (покажи) справка (само където е приложимо).

F11 – Превключване между първичен и вторичен ключ.


Главно меню

 Top

Филтри

Възможно е за дадена форма предварително да бъдат зададени определено множество от филтри (различни от временните филтри). Те са достъпни през менюто Филтри на формата. За да се приложи някой от тях е необходимо да се избере от менюто. Резултатът от прилагането на временен филтър след това включва само записи, отговарящи на временния филтър и зададения от менюто филтър. За да се преустанови действието на филтъра, от менюто се избира Без филтър.

Изпълни програма

От това меню могат да бъдат извиквани различни програми обработващи данните свързвани с формата. Ако има зададена програма по подразбиране тя може да се извика с F8.

Изпълни справка

Меню за извикване на справки свързани с формата. Ако е дефинирана само една справка - по подразбиране, може да се отвори с F9.

Опресняване

Презарежда данните във формата от базата данни.

Разширено търсене

В някои форми освен обикновените единични полета за въвеждане на данни има и таблици за въвеждане на данни. Търсенето в тях не е възможно през полето за търсене, а колоните им не са в списъка с полета в режим на преглед. Това е така, защото обикновено за един запис заглавна информация има повече от един запис детайлна информация (напр. в една фактура се изброяват няколко изделия). Тази детайлна информация се визуализира във формите чрез тези таблици. За търсене, базирано на детайлната информация, се използва менюто Разширено търсене. При избиране на това меню се появява прозорец Разширено търсене.

В него има две списъчни полета – за избор на таблица (възможно е във една форма да има повече от една таблица) и на поле от избраната таблица. В полето Търси се въвежда стойност, която се търси в посоченото вече поле. След като се въведе критерий за търсене можете да се избере посоката на търсене спрямо текущия запис – Назад или Напред. Търсенето става с натискане на бутона Следващ.

Ако не е намерен запис в избраната посока се извежда съобщение, а ако бъде намерен формата се позиционира на него. Формата може да бъде разглеждана докато е активен прозореца за разширено търсене . С бутона Филтър се поставя временен филтър на формата, който показва само тези записи, които отговарят на критерия за търсене. Този филтър можете да бъде изключен чрез повторно натискане на бутона Филтър.


Филтриране на таблица

 Top

Таблици с филтър

Част от таблиците в системата например таблицата в прозореца Режим на преглед, както и в повечето програми тип браузър имат вградена функционалност за филтриране на записите, които се показват.

Забележка: Поради спецификата на формите таблиците в самите форми нямат филтриране.

Филтър може да бъде зададен за произволно поле (колона) от такава таблица, като се щракне с десен бутон на мишката върху заглавието на колоната.

Релации за филтриране

Филтърът се установява на база текста в текстовото поле (по подразбиране се попълва стойността на избрания ред от таблицата) и релация която се избира от падащото меню.

= - стойността на полето за филтриране (колоната от таблицата) е равна на текста;

<> - стойността е различна от текста;

> - стойността е по-голяма от текста спрямо стандартната подредба;

>= - стойността е по-голяма или равна от текста спрямо стандартната подредба;

< - стойността е по-малка от текста спрямо стандартната подредба;

<= - стойността е по-малка или равна от текста спрямо стандартната подредба;

Съдържа - текста се съдържа на произволно място в стойността на полето;

Не съдържа - текста не се съдържа в стойността на полето;

Започва с - Стойността на полето започва с текста;

Не започва с - Стойността на полето не започва с текста;

Завършва на - Стойността на полето завършва с текста;

Не завършва на - Стойността на полето не завършва с текста;

Е празно - Полето е празно;

Не е празно - Полето не е празно (има зададена стойност).

След натискане на бутона ОК филтъра се установява и заглавието на колоната се изписва с удебелен шрифт.

Филтърът може да бъде премахнат с натисканена бутона Премахни филтъра.

Допуска се задаване на филтър за повече от една колона от таблицата.


Типове полета за въвеждане

 Top

Във формите полета за въвеждане са от различен тип.

Текстово поле

Поле за избор от таблица

Поле за избор на дата

Поле за избор от списък


Таблици за въвеждане на детайлна информация

 Top

Таблицата за въвеждане на данни е един от често срещаните начини за въвеждане на детайлна информация. Таблицата се състои от различни колони – някои са текстови, други за избор от таблица, избор на дата, избор от списък. Някои от колоните са сиви – в тези колони не може да се въвеждат данни.

Навигация в таблица

Въвеждане на данни

Изтриване на ред


Акт за брак

 Top

Форма – Акт за брак

Използва се за въвеждане, редактиране и отпечатване на актове за брак. В полетата на формата се въвеждат всички необходими данни за отчитане на актовете за брак. За общи указания за работа с форми виж.

Типове актове за брак.

Достъпни са три типа актове за брак, които се задават от полето Тип – „От производство”, ”Материали”, ”Машини и инструменти”. Различните типове определят полетата, които се съдържат в таблицата с детайли на акта за брак (бракуваните продукти).

Основни полета на формата .

Статус – определя статуса на потвърждаване на акта за брак. Може да приема следните стойности:

· Нов – попълва се при създаване на нов запис.
· Чакащ утвърждаване – избира се от служителя когато всички данни са попълнени и проверени. Когато е зададен този статус промени на останалите данни не са допустими с изключение на полетата за утвърждаване и полето статус, което може да бъде върнато на статус Нов.
· Одобрен – задава се автоматично от системата когато са попълнени полетата Дата на одобряване от Началник отдел и Началник ОТКК.

Причина за допускане – попълва се от служителя зададен в Нач. на отдел с данни за причините за допускане на брака.

Заключение - попълва се от служителя зададен в Началник ОТКК.

Таблица с детайли за тип – „От производство”

Раб. у-к – номер на работния участък в който е възникнал брака.

Пр. Парт. # – идентификатор на производствена партида от която е брака

Партида No – номер на складова партида, ако брака е отчетен след приемане на продукта в склад.

Продукт # – идентификатор на бракуваното изделие. Задължително поле. За начините за избор на изделие виж ....

Опер. # на възникване – идентификатор на производствена операция при която е възникнал брака.

ОТК опер. # - идентификатор на производствена операция от тип ОТК на която е отчетен брака.

Отчетени несъотв. – брой изделия от указаната производствена партида които са били очетени като несъответстващи в процеса на отчитане на производсвтените операции в програмата Отчитане на операциите.

Нал. в склад – налично количество от изделието в склад, което се изчислява по следния начин подредено по приоритет на изчисляване:

· ако е зададен номер на складова партида – наличните бройки от партидата;
· ако е зададен идентификатор на производствена партида - наличните бройки от всички складови партиди съоветстващи на дадената производствена партида.
· ако не е зададена складова или производствена партида – наличните количества във всички складове

Нал. в участък – налично количество от изделието в работния участък зададен в полето Раб. у-к, като ако не е зададен раб. участък се изчислява наличното количество във всички участъци.

К-во – количество за бракуване.

Раб. е-ца – идентификатор на работна единица на която е възникнал брака.

Причина # - идентификатор на причина за брак от списъка с дефинирани причини, като в полето Бележки се попълва описанието на причината.

Намали склад – указва количеството да бъде изписано от складовата партида с операция „Бракувано” . Виж т. Операции с данните при запис.

Намали участък – указва количеството да бъде изписано от наличните в участък с операция „Бракувано”. Виж т. Операции с данните при запис.

Забележка. Намаляване на количествата в склад или участък се налага ако съответнте бройки към момента на запис на акта за брак се водят налични (добри) в участък или складова партида. Ако те са отчетени като несъответстващи в процеса на производството излизат в полето Отчетени несъотв. не се налага намаляване. Намаляване на склад не е възможно ако не е зададена складовата партида.

За преоценени – идентификатор на склад за преоценена продукция (F12 –попълва стойност по подразбиране)

Процедури с данните при запис

При запис на акта за брак се извършват следните операции с данни.

· Ако статусът е „Чакащ одобрение” се изпращат уведомителни съобщения до служителите указани в Нач. отдел и Началник ОТКК.
· Ако статусът е „Чакащ одобрение” и полетата Дата на одобряване от началник отдел и началник ОТКК не са попълнени, както и ако са избрани Намали склад, Намали участък и/или За преоценени се създават съответните продуктови операции в складовете и/или участъците (при недостатъчни количества се издава съобщение и се спира записа на данните).


Програма - Браузър на производствен участък

 Top

Програма - Браузър на производствен участък

Използва се за контрол и управление на наличностите и движението на продукти (материали, изделия и др.) в отделите, в които това е необходимо да се отчита (маркирано е полето Складова отчетност във формата Отдели), както и за контрол и управление на производството чрез производствените операции в производствените отдели (производствени участъци).

Наличности и движение на продуктите

Производствени операции

Инструментална екипировка


Форма - Движение на продукти по участъци

 Top

Форма - Движение на продукти по участъци

Използва се за дефиниране на продуктови операции в отделите с контрол на движението на продукти (производствени участъци). За общи указания за работа с форми виж.

Основни полета на формата .

Операция # - идентификатор на операцията - задава се от системата.

Произв. участък - идентификатор на отдел.

Продукт # - идентификатор на продукт. Виж Избор на продукти.

Бележки - бележки към операцията.

Количество - количество на продукта за операцията в съответната мерна единица и количество със знак определн от вида на операцията.

Вид операция - вида на операцията определя дали съответното количество ще бъде взето със знак плюс или минус, съответно дали количеството от продукта в участъка ще бъде увеличено или намалено.

· Изравняване - използва се за изравняване на количествата при начална инициализация или корекция на грешки. Количеството може да бъде въведено със знак плюс или минус в зависимост в коя посока искаме да изравним.
· Преместено в склад (изходяща) - прехвърляне на продукт към склада указан в полето Към склад. При запис в съответния склад се създава складова партида с указаното количество.
· Получено от склад (входяща) - получено количество от склад с Искане за отпускане на материални ценности.
· Получено от участък (входяща) - прехвърляне на продукти от друг участък.
· Преместено в участък (изходяща) - прехвърляне на продукти от друг участък указан в полето Към участък.
· Произведено (входяща) - произведени изделия в участъка.
· Използвано за производство (изходяща) - използвани за производство продукти според технологиите. Не е достъпно за избор при ръчно създаване на операция.
· Отпадък от производство (входяща) - продукти отпадък при производството.
· Бракуване (изходяща) - изписване на продукти като брак.
· Продажба (изходяща) - изписване като продажба.
· Изравняване при производство (входяща/изходяща) - корекция на използвано за производство количество. Не е достъпно за избор при ръчно създаване на операция.
· Върнато за доработка (входяща) - получено количество от изделие за повторно изпълнение на производствена операция в участъка.
· Използвано за ремонт (изходяща) - използвани продукти за ремонт на оборудване и др.
· Издадено за бракуване (изходяща) - използва се за връщане към склада указан в полето Към склад, на амортизирани продукти с контролирано изписване с цел бракуването им.

Създадена от - идентификатор, име на служителя и дата на създаване.

Статус - статус на оперцията (Чакащ или Изпълнен).

Произв. операция - идентификатор на производствена операция в следствие на която е генерирана продуктовата операция.

Статус променен от - идентификатор, име на служителя и дата на промяна на статуса.

Генерирана операция - указва дали операцията е автоматично генерирана от системата.

Източник - идентификатор на източника на операцията (в контекста на генерация)

Марш. лист # - идентификатор на маршрутен лист, в следствие на който е генерирана операцията виж.

Кл. поръчка # -идентификатор на клиентска поръчка, в следствие на която е генерирана операцията (при изписване на групови опаковки виж).

Складова партида - идентификатор и номер на складова партида, от която е продукта.

Произв. партида - идентификатор на производствена партида, от която е продукта.

Статус наличност (Отворена/Затворена) - валидно само за входящи операции, указва дали по операцията има налично количество достъпно за изходящи операции.

Взето от опер. - валидно само за изходящи операции, идентификатор на операция - източник, входяща операция от която е взето количеството и номер на складова партида.

Остатък - налично количество по операцията източник.

Процедури с данните при запис

При запис статусът на операцията-източник се променя на Затворен ако наличното количество (Остатъка) стане равно на 0.


Форма - Производствени поръчки

 Top

Форма Производствени поръчки

Използва се за въвеждане, редактиране и разглеждане на производствени поръчки. Най-често производствените поръчки достъпни в тази форма са с произход програмата Генератор на производствени поръчки. За общи указания за работа с форми виж.

Типове производствени поръчки

Вътрешна – производствената поръчка и изделията които ще бъдат произведени от нея не са директно поръчани от клиент.

Клиентска – първичен инициатор на текущата производствена поръчка е клиентска поръчка.

Основни полета на формата

Пр. п-ка # - идентификационен номер на текущата производствена поръчка. Номера е автоматично заделен от системата и не може да бъде променян от потребителите.

Дата – датата на която е създадена текущата производствена поръчка.

Продукт # - идентификационен номер на изделието с което завършва текущата производствена поръчка. Заедно с този идентификационен номер, на формата присъстват и кода и описанието на това изделие, както и поле за връзка (Покажи) чрез което може да бъде отворена програма даваща детайлна информация за него.

К-во поръчка – количеството необходими за покриване на нуждите на вътрешната или клиентската поръчка.

К-во изпълнение – количеството необходимо за покриване на нуждите на вътрешната или клиентската поръчка, което включва в себе си и предвидените бройки за настройка както и очаквания брак.

Приоритет – приоритета с който трябва да бъде изпълнена текущата производствена поръчка. По подразбиране приоритета е Нормален. Другите възможни стойности са Нисък, Висок и Спешен.

Тип произв. – типа на произвежданото изделие

· Обработка – произвежданото изделие е детайл. Производствената поръчка започва с основен материал или детайл заготовка.
· Сборка – произвежданото изделие е възел който се състои от два или повече детайла/възела. Производствената поръчка започва с два или повече детайла/възела след асемблирането на които ще бъде произведено крайното изделие.

Статус:

· В производство - поъчката е в процес или чака започване на производството.
· Затворена - поръчката е приключена всички партиди са затворени.
· Затворена от служител - поръчката е затворена служебно от служител.

Категоризация – минимално качество на детайлите/възлите които могат да бъдат използвани при реализацията на текущата производствена поръчка. При не упоменато качество могат да бъдат използвани детайли от всяка категория. Водещо при определяне минималната категория качество на използваните детайли при производствени поръчки за клиент е стойността на полето за избор Категоризация от формата Доставчици и Клиенти от модул Управление на взаимоотношенията с контрагенти.

Бележки – текстово поле за въвеждане на пояснителна информация относно текущата производствена поръчка

Таблица Клиентски поръчки

Съдържа информация относно клиентските поръчки които са първоизточник на текущата производствена поръчка

# - идентификационния номер на клиентската поръчка.

Количество – броя детайли с които са заделени към тази клиентска поръчка

Таблици Свързани производствени поръчки

Сборки – списък с производствени поръчки от тип Сборка към които е свързана текущата производствена поръчка. Изделията произведени от текущата производствена поръчка ще бъдат използвани за асемблирането на изделията към производствени поръчки в този списък

Субкомпоненти – списък с производствени поръчки при текуща поръчка от тип Сборка. Изделията произведени към всяка от производствените поръчки в този списък ще бъдат използвани при асемблирането на текущото изделие(възел)

Текущи поръчки - използва се за – списък от производствени поръчки, които използват крайни изделия от текущата производствена поръчка като заготовки.

Текущи поръчки - използва от – списък от вътрешни производствени поръчки, от които текущата производствена поръчка ще използва заготовки.

Таблица Производствени партиди

Всяка производствена поръчка се състои от една или повече производствени партиди. Разделянето на производствени партиди се извършва от автоматично от програмата за генериране на производствени поръчки на база стойностите на полетата Максимално количество в партида и Минимално количество в партида от Производствената Спецификация на крайното изделие на текущата производствена поръчка. Тази таблица представлява списък от всички производствени партиди в текущата поръчка.

Парт. # - Идентификационен номер на производствената партида. Поле за връзка водещо към формата за редакция на производствени партиди.

No на етап – текущия етап на изработка на крайното изделие от поръчката. Реализацията на едно изделие се разделя условно на етапи на база маршрутите от технологичната му спецификация, които от своя страна отразяват различните частично завършени детайли през които преминава една изделие по време на производствения му цикъл.

No на партида – пореден номер на партидата в етап.

К-во за изпълнение – брой детайли/възли за изпълнение в текущата производствена партида.

Статус – статус на изпълнение на производствената партида.

Заготовка – код на изделието на партидата.

Таблица Операции

# - идентификационен номер на производствената операция. Поле за връзка водещо към формата за редакция на производствени операции

No – пореден номер на производствената операция в текущата партида.

Код – кода на технологичната операция.

Операция – наименование на технологичната операция

К-во за изп. – броя изделия необходими за успешното завършване на производствената операция.

К-во за обр. – оценка за броя детайли подлежащи на обработка за покриване на количеството за изпълнение, включва в себе си предварително заложената оценка за брой брак и бройки за настройка.

Статус – статус на производствената операция.

Осн. кооперант – външен подизпълнител по подразбиране на текущата производствена операция.

Процедури с данните при запис

При запис ако статусът на производствената поръчка е зададен Затворена от служител, със същия статус се маркират свързаните с нея незатворени производствени партиди и съответни операции.

Програми извиквани от менюто Изпълни програма

Клониране на производствената поръчка - създава точно копие на текущата, но без да бъдат генерирани производствени партиди и операциии. Използва се в случаите, когато искаме да създадем поръчка с ръчно въведени партиди и операции по нестандартен технологичен маршрут.

Изтриване на производствената поръчка - функционалност за изтриване на погрешно генерирана поръчка, като се изтриват и всички проиводствени партиди и операции, както и подчинените поръчки (за компоненти) съответно с техните партиди и операции.


Форма - Производствени партиди

 Top

Форма Производствени партиди

Производствената партида дефинира неделимо количество от изделия (например съдържащи се в един контейнер), които се произвеждат от основен материал или заготовка, преминавайки през последователни технологични операции. Изходното изделие на партидата може да бъде, както крайното изделие на производствената поръчка така и междинна заготовка, която подлежи на последваща обработка, дефинирана в производствена партида от следващ етап. За общи указания за работа с форми виж.

Основни полета на формата

Партида # - идентификатор на партидата. Формира се от идентификатора на производствената поръчка, двуцифрен номер на етап и трицифрен номер на партидата в етапа.

Етап - при ръчно създадване на производствена партида в полетата Поръчка #, Етап No и Етап # се въвеждат съответните идентификатор на производствена поръчка, номер и идентификатор на етап които служат за генериране на идентификатора на партидата.

Партида No - номер на партида в етапа.

Отпечатан - ако е селектирано указава, че паспорта на партидата е отпечатан на последната стъпка от генерацията на поръчката.

Стартова заготовка - идентификатор, код описание и количество на изделие - стартова заготовка за партидата. Полето е празно за партидидите стартиращи от основен материал и такива за монтаж.

Текуща заготовка - идентификатор, код и описание на изделието, което се получава при производството на партидата.

К-во партида - необходимо количество изделия за партидата.

Статус - статус на производствената партида:

· В производство - партидата е в процес или чака започване на производството.
· Затворена - партидата е приключена.
· Затворена от служител - партидата е затворена служебно от служител.
· С откл. продължава - партидата е маркирана от ОТК служител, че е с по-малко от необходимите добри бройки, но производство и продължава.
· С откл. спира - партидата е маркирана от ОТК служител, че е с по-малко от необходимите добри бройки, и производство и спира.

Дата за изп. - дата за изпълнение на клиентската поръчка.

Мин. старт дата - дата, не по-рано от която да започне производството на производствената поръчка.

План старт дата, План. произв. дата, - планирани дата за стартиране и приключване на партидата.

Приоритет - приоритет на производствената поръчка (Нисък,Нормален,Висок,Спешен).

Изработени бр. - отчетени изработени изделия на последната оперция от партидата.

Бележки – текстово поле за въвеждане на пояснителна информация относно текущата производствена партида.

Следв. партиди - списък на производствените партиди (една или повече), които се явяват продължение на обработката на текущата в следващия етап на производствената поръчка(и).

Кл. поръчки - списък с позиции от клиентски поръчки, към които е свързана партидата.

Таблица Производствени поръчки

В таблицата са показани връзките на партидата към производствени поръчки.

Произв. п-ка # - идентификатор на производствена поръчка.

No етап - номер на етап, към който е партидата.

К-во % от поръчка - процентно отношение на количеството на партидата към общото количество на производствената поръчка.

Изделие - код на изделието за производствената поръчка.

Таблица Операции

# - идентификационен номер на производствената операция. Поле за връзка водещо към формата за редакция на производствени операции

No – пореден номер на производствената операция в текущата партида.

Код – кода на технологичната операция.

Операция – наименование на технологичната операция.

К-во за изп. – броя изделия необходими за успешното завършване на производствената операция.

К-во за обр. – оценка за броя детайли подлежащи на обработка за покриване на количеството за изпълнение, включва в себе си предварително заложената оценка за брой брак и бройки за настройка.

Бр. добри - отчетени изработени добри бройки за операцията.

Статус – статус на производствената операция.

Променен от, Променен на - служител и дата на установяване на текущия статус.

Осн. кооперант – външен подизпълнител по подразбиране на текущата производствена операция.

Движение на партидата - информация за складовите партиди, получени в резултат на текущата производствена партида според технологичния маршрут за изделието.

Таблица Заделени продукти

Таблицата съдържа заделените материали по оперциите на партидата, заделените стартови заготовки или компоненти за партидите от тип сборка.

Операция - идентификатор на производствена операция по която е заделен материал.

Продукт #,Тип - идентификатор и тип на заделения продукт (материал,изделие).

Описание - описание на продукта.

К-во - заделено количество в съответната мерна единица.

Качество - минимално качество изисквано за продукта.

Таблица Алтернативни изделия

В тази таблица, за партидите от тип сборка могат да бъдат задавани алтернативни изделия на компонентите, които ще се използват при монатажа на изделието вместо зададените по спецификация.

Основен # - идентификатор на изделието компонент по спецификация.

Алтернативен # - идентификатор на изделие, с което ще бъде заменен основния компонент.

Алт. к-во - ако полето е празно, при монтажа ще бъдат използвани толкова бройки от алтернативния компонент, колкото е броя на основния по спецификация. Ако има зададена стойност, за партидата ще бъдат използвани толкова бройки колкото са зададени в полето. Стойност (-1) означава, че основния компонент няма да бъде използван (независимо от идентификатора на алтернативния).

Таблица Допълнителни изделия

Някои технологични маршрути дефинират производствени партиди, които като резултат от производството имат две или повече различни изделия. В този случай едното изделие (условно наречено основно) е текущата заготовка на партидата, а останалите се описват в таблицата Допълнителни изделия.

Изделие #,Описание - идентификатор и описание на допълнително изделие.

Ст-т % - процентно отношение на изделието към общата стойност на използваните материали и заготовки за изработване на партидата. Използва се за изчисляване на себестойността на изделията.

Процедури с данните при запис

При запис в зависимост от статуса на партидата и операциите се преизчисляват заделените продукти, както и статуса на производствените поръчки свързани с партидата.

Програми извиквани от менюто Изпълни програма

Промяна на технологията

Тази функционалност позволява промяна на технологията на една или няколко партиди от етап, например при авария на машина и др.

Могат да бъдат избрани опциите:

Само текущата партида; всички партиди от етапа или избрани партиди с номера от до даден интервал.

Нова технология се избира от дървото с маршрути на прозореца Избор на технология. След избора на маршрут всички производствени операции на партидата се прегенерират.

Забележка. Промяна на технологията е допустима само за производствени партиди, за които производството не е стартирано.

Промяна на количеството

Количеството на партидата може да бъде увеличено или намалено като разликата (със знак плюс или минус) се въведе в полето Корекция.

Забележка. Промяна на количеството е допустимо само за производствени партиди, за които производството не е стартирано.

Добавяне на опционална операция

Опционални производствени операции, освен като част технологичен маршрут, могат да бъдат добавяни при необходимост в процеса на производството (например при нужда от допълнителна обработка на изделието) от диспечерите на производството.

Добави след - пореден номер, код и описание на производствената операция от текущата партида след която да бъде добавена нова опционална операция. Поредните номера на всички полседващи операции ще бъдат увеличени с единица.

Бройки за обработка - брой изделия подлежащи на обработка за опционалната операция.

В готовност - ако е селктирано, оперцията се създава със статус В готовност.

Техн. операция - идентификатор и описание на технологичната операция.

Разделяне на производствена партида

При необходимост (напр. само част от партидата да продължи от дадена операция нататък), една партида може да бъде разделена на две независими производствени партиди.

Партида # - идентификатор на текущата производствена партида.

К-во парт. - количество на текущата партида.

% - процентно отношение на новозададеното количество на текущата и новата партида спрямо общото.

Разделяне Парт. 1,2 - количества на двете партиди след разделянето съответстващо на зададения процент.

Опция Само текущата - разделя се само текущата партида.

Опция Всички следващи - освен текущата, ще бъдат разделени и партидите съответстващи на текущата във всички последващи производствени етапи.

Копиране на стартова заготовка и алтернативни изделия

С тази функционалност промяната на стартова заготовка или алтернативни изделия в таблицата Алтернативни изделия на текущата партида, може да бъде пренесена върху всички други или избрани партиди от етапа.

Забележка. Не се допуска промяна на стартова заготовка и алтернативни изделия за партиди, за които производството не е стартирано.

Справки

От меню Справки се извиква Паспорт на производствена партида


Форма - Операции

 Top

Форма - Производствени операции

Използва се за въвеждане, редактиране и разглеждане на производствени операции. Най-често операциите които са достъпни в тази форма са част от производствена поръчка с произход програмата Генератор на производствени поръчки. За общи указания за работа с форми виж.

Основни полета на формата

Операция # - идентификатор на производствената операция. Състои се от идентификатора на производствената партида и двуцифрен пореден номер на операцията.

No - пореден номер на оперцията в партидата.

Статус – текущото състояние на операцията:
· Празен - операцията е в процес на изчакване на изпълнение на предхождащите я операции
· Активна – операцията е активна и може да бъде приведена в готовност от диспечер на производството.
· В готовност – операцията е в готовност и работата по нея може да бъде започната от оператор.
· Стартирана – по тази операция се извършва текуща работа.
· Затворена – работата по тази операция е приключена и операцията е затворена автоматично от системата.
· Затворена от служител – работата по тази операция е приключила и операцията е била затворена от оператор.
· С отклонение продължава – има констатирани нередности с изработените детайли/възли но техния производствен цикъл няма да бъде прекъснат.
· С отклонени спира – има констатирани нередности с изработените детайли/възли което налага прекъсване на производствения им цикъл.

Тип - тип на технологичния маршрут, от който е част операцията - Обработка или Сборка.

Генерирана - указва дали операцията е генерирана от Генератора на производствени поръчки.

Опционална - ако е селектирано указва, че операцията е опционална. Опционалните операции могат да бъдат приведени в готовност само ръчно от диспечер на производството, както и не се изисква тяхното приключване за приключването (затваряне) на производствената партида.

Партида # - идентификатор на производствената партида.

Стартова заготовка - идентификатор, код, описание и брой на стартовата заготовка за партидата.

Текуща заготовка - идентификатор, код и описание на крайната заготовка за партидата.

Приоритет - приоритет на производствената поръчка.

Бележки - забележки в свободен текст към операцията.

Техн. операция - идентификатор, код и описание на съответстващата технологична операция. Полето за връзка Покажи отваря прозорец с подробна информация за технологичната операция.

Работен у-к – идентификатор и описание на работния участък (производствен отдел), в който ще бъде извършена текущата операция по технология.

Група раб. ед-ци – идентификатор и описание на групата работни единици за изпълнение на текущата производствена операция по технология.

Разделяне на заг. - коефициент указващ, че при текущата операция обработваното изделие се разделя на две или повече еднакви части, които подлежат на обработка в следващите операции и съответно се мултиплицират обработваните бройки.

Кооп. - ако е селектирано, означава че операцията се извършва от външен контрагент-подизпълнител (кооперирана операция).

Доставка (р. дни) - максимален срок за доставка (изпълнение на операцията) в работни дни, за контрагента по подразбиране на кооперирана операция.

Квал. за опер. - квалификационна група на служител в съответния работен участък за изпълнение на операцията - според технологичната операция.

Квал. за настр. - квалификационна група на служител в съответния работен участък за извършване настройка на машините за операцията - според технологичната операция.

Планирано - група от полета показващи планираните параметри на текущата операция:

Начало, Край - дата и час на планираните начало и край на работата по операцията според работния план.

Раб. единица - планирана работна единица, на която да се изпълни операцията според работния план.

Обработка - брой изделия подлежащи на обработка. Включени са бройките за настройка и технологичния брак.

Изпълнение - брой добри изделия които се очаква да бъдат резултат от операцията.

Настройка - предвидени бройки за настройка.

Контрол - минимален брой изделия, които трябва да бъдат проверени.

Брак - предвидени бройки брак.

Произв. (ч) - предвидено време за производство в часове.

ОВ сек/бр. - оперативно време (за обработка на една бройка) в секунди.

Настр. (мин) - време за настройка на машините в минути.

Контрол - предвидено време за проверка на качеството на изработените изделия в часове.

НВ сек/бр. - нормо-време в секунди на бройка. Време за изчисляване на заработката на оператора според технологичната операция.

Отчетено - група от полета показващи реалните данни, отчетени при изпълнението на текущата производствена операция:

Начало, Край - отчетени дата и час на започване и приключване на работата по операцията.

Изпълнение - изработени добри бройки.

Настройка - изразходвани бройки за настройка.

Контрол - брой проверени изделия.

Несъотв. - отчетени бройки несъответстващи на технологичните параметри на изделието

Производство (ч) - чисто време за производство в часове.

Настройка (мин) - отчетено време за настройка в минути.

Контрол (ч) - отчетено време за проверка в часове.

Таблица Извършена работа по операцията

Съдържа индивидуалните отчети на служителите (работни карти) за извършената работа по операцията, въведени чрез програмата Отчитане на операциите.

# - идентификатор на отчитането.

Начало – начален час и дата на работата.

Край – краен час и дата работата.

Служител #, Име – идентификатор и име на служителя.

Добри бр. – брой успешно произведени детайли/възли по тази работна карта.

Настр. бр. - изразходвани бройки за настройка.

Брак бр. - бройки несъответстващи на технологичните параметри на изделието.

Доработка бр. - бройки, които се нуждаят от повторна обработка.

ОТК бр. - брой проверени изделия.

Настройка - поле за отметка индикиращо, че работата е за настройка на машината.

Качество - качество на изработените изделия.

Раб. единица - работна единица на, която е извършена работата.

Причина за брак – идентификатор на причината, поради която детайлите от поле Брак бр. са отчететни като несъответстващи.

Бележи - забележки в свободен текст към работната карта.

Таблица Допълнителни служители

Ако за изпълнението операцията е предвидено едновременното участие на повече от един служител, те се отчитат към съответната работна карта и се показват в таблицата.

Таблица Материали

Списък от основни и спомагателни материали необходими при изпълнението на текущата операция.

#, Материал - идентификационен номер и наименование на материала

Разходна норма – количеството необходимо за изпълнение на операцията за единица бройка.

План. разход - общо количество от материала необходимо за операцията в съотв. мерна единица.

Основен – поле за отметка индикиращо дали текущия материал е основен или спомагателен.

Алтернативен за - ако е попълнено, означава че материала е дефиниран като алтернативен на друг материал от таблицата, чийто код е зададен в полето.

Таблица Инструменти

Списък с необходимите инструменти за извършване на текущата операция.

#, Инструмент - идентификатор и описание на инструмент

Амортизация - амортизационна норма за инструмента за единица бройка изделие, според технологичната операция

Таблица Мерители

Списък от измервателни инструменти необходими за извършване на текущата операция

Процедури с данните при запис

1. Производствената операция е със статус Празен или Активна:

· Планираните разходни количества за материали се добавят като заделени.
· Ако операцията е първа за партида, и маршрута е от тип:
· Обработка - заделят се стартовите заготовки за партидата ако има такива.
· Сборка - заделят се компонентите за монтаж според ПСИ.

2. Производствената операция е със статус В готовност:

· Заделените количества материали се освобождават. Създават се продуктови операции от тип Използвано за производство за съответните количества материали според технологията, в участъка определн от групата работни едници за операцията. Ако в съответния участък няма достатъчна наличност от основен материал се издава съобщение и записа се прекъсва. Ако операцията е към маршрут от тип Обработка, се създават и съответните продуктови операции за стартовата заготовка и се освобождават заделените.

3. Производствената операция е със статус Затворен,Затворен от служител:

· Следващата операция от производствената партида се установява със статус В готовност. Ако технологичният маршрут е зададен с произволен ред на изпълнение и операцията е първа за партидата то всички операции без последната се установяват със статус В готовност. Когато операцията е последна в партидата и има следващ етап, първата операцията на съответната партида от следващия етап се установява като Активна.
· Ако операцията е първа и маршрута е от тип Сборка, се създават продуктови операции от тип Използвано за производство за компонентите, според ПСИ за отчетените произведени бройки.
· Ако операцията е последна за производствената партида, се създава складова партида в зададения по технология склад или продуктова операция от тип Произведено ако е зададен участък.


Програма - Генератор на производствени поръчки

 Top

Генератор на производствени поръчки

Основният обект, който служи за планиране и отчитане на производствения процес е производствената поръчка. Тя представлява задание за изработване на определено количество от дадено изделие по дадена технология. Производствените поръчки са йерархично взаимосвързани - например поръчката за изработка на съставно изделие (възел) се явява родител и реферира поръчки за всеки от съставните му компоненти.

Всяка поръчка може условно да бъде разделена на един или повече етапи, при които се изработва междинно изделие (заготовка), което се явява стартова заготовка за следващия етап от поръчката. За всеки етап се дефинират една или повече производствени партиди - неделим "контейнер" с изделия, които минават заедно през всички етапи на производствения процес и имат съпроводителен документ (паспорт). Технологичния процес е описан в подробности, чрез последователни производствени операции дефинирани за всяка производствена партида.

Системата позволява генериране на производствените поръчки, партиди и операции на база на текущите клиентски поръчки или на вътрешно-фирмено задание (т.нар. вътрешни поръчки ), като се използва програма от тип съветник (wizard) с няколко последователни стъпки.

Стъпка 1 - избор на клиентски поръчки

В таблицата Клиентски поръчки се съдържат одобрените клиентски поръчки със статус различен от Затворен, а в таблицата Поръчани изделия - отделните позиции (релийси) от избраната поръчка със статус различен от Затворен. Изборът на поръчка за обработка става със селектиране на полето Вкл.

Таблица Клиентски поръчки

Поръчка # - идентификатор на клиентска поръчка.

Статус - производствен статус със следните стойности:

· празно - чака обработка (чака генериране на производствени поръчки);
· В производство - производствените поръчки са генерирани и са в процес на производство;
· Част. в производство - част от позициите на поръчката имат генерирани производствени поръчки и са в производство;
· Приключен - всички производствени поръчки към клиентската поръчка са затворени (производството по тях е завършило);
· От склад - изделията по всички позиции на поръчката са налични и ще бъдат реализирани от склад;
· Част. от склад - изделията по някои позиции на поръчката са налични и ще бъдат реализирани от склад, останалите позиции не са обработени.

Дата на утв. - дата на одобряване на поръчката.

Дата на изп. - дата за изпълнение на поръчката.

Клиент # - идентификатор на контрагента.

Клиент - наименование на контрагента.

Държава - държава на контрагента.

ОТК - категоризация за контрагента.

Таблица Поръчани изделия

Статус - аналогичен на полето от горната таблица, но за отделната позиция по поръчката.

Поръчка # - идентификатор на позиция (релийс) от клиентската поръчка.

Дата от клиент - дата за реализация от клиента за позицията.

Дата на изп. - дата за изпълнение на позицията.

К-т - идентификатор на комплект от изделия от поръчката.

К-во за п-во - количество за производство - разликата между количеството по поръчка и вече експедираните към клиента по фактури изделия и заделените за реализация от склад бройки.

Зад. от склад - брой изделия заделени за реализация от склад.

Идент. # - идентификатор на изделие. При щракване се отваря ПСИ на изделието.

Код - код на изделието.

Описание - описание на изделието.

Забележки - забележки от поръчката.

Налични в склад - налично количество във всички складове.

Налични в участъци - налично количество в производствените участъци.

Свободни - свободно количество (разликата между наличното и заделено по клиентски и производствени поръчки количество). При щракване на количеството се отваря прозорец с подробна информация за наличностите и заделените количества на изделието виж.

Контекстно меню на таблица Поръчани изделия

Маркирай от склад - сменя статуса на избраните позиици - От склад и заделя количествата по тях.

Лента с бутони

Използвай количеството в склада - ако е деселектирано указва наличните количества от дадено изделие да не се вземат под внимание при изчисляването на необходимите за производство изделия (дефицити).

Отвори за разглеждане [image] - отваря форма Потвърждение на поръчка за селектирания ред от таблицата с поръчки.

Стъпка 2 - изчисляване на дефицити

На тази стъпка се обединяват и сумират всички компоненти на селектираните по клиентски поръчки крайни изделия и се изчислява необходимото за производство количество - т.нар. дефицит, на база на разликата между необходимото и свободното количество от дадено изделие.

Таблица дефицити

Идент. #, Код, Описание - идентификатор, код и описание на изделието. При щракване на идентификатора се отваря ПСИ на изделието.

ПСИ количество - количество на изделието на изчислено на база на клиентските поръчки и ПСИ.

Необх. количество - изчислено на база на клиентските поръчки, като количеството на компонентите е редуцирано със свободното количество.

Налични общо - налично количество във всички складове и участъци. При щракване на количеството се отваря прозорец с подробна информация за наличностите и заделените количества на изделието виж. Ако към момента на генерация има складови партиди от изделието с входящи операции със статус Чакащ одобрение, фона на полето става червен.

Налични в склад - налично количество в складове.

Налични в участъци - налично количество в участъци.

Свободни - свободно количество (раликата между наличното и заделено по клиентски и производствени поръчки количество).

Дефицит - необходимо за производство количество. Ако е 0 не се генерира производствена поръчка. Полето може да се редактира от оператора, като промяната на стойността на дефицита на съставно изделие (възел) води до преизчисляване на дефицитите на компонентите му.

Реализация - указва дали изделието ще бъде произведено (Производство) или закупено (Покупно). Може да бъде редактирано от оператора. Ако бъде избрано Покупно производствена поръчка не се генерира, а съответното количество се заделя.

Макс. к-во в партида, Мин. к-во в партида - максимално и минимално количество за партида от съответното изделие според ПСИ.

К-т - описание на комплект от клиентската поръчка, ако изделието участва в комплект.

Таблица Алтернативни изделия

Ако според производствената спецификация на изделията има зададени алтернативни на изделията от таблицата Дефицити. Етикета Алтернативни изделия се оцветява в червено. При натискане на бутона Зареди те се зареждат в таблицата.

Идент. #, Код, Описание - идентификатор, код и описание на изделието. При щракване се отваря ПСИ на изделието.

Налични общо - налично количество в складове и участъци.

Свободни - свободно количество.

Алтернативен на - идентификатор на изделие от таблицата Дефицити на, което е алтернативно изделието от реда.

При натискане на бутона Използвай, изделието от избрания ред в таблица Дефицити се подменя с избраното от таблица Алтернативни изделия и данните се преизчисляват. Използването на алтернативно изделие се допуска само ако свободното му количество е по-голямо или равно на дефицита.

Таблица Текущи поръчки

В тази таблица се показват производствени поръчки от тип вътрешна, които са в процес на производство и са за изделия с ненулев дефицит от таблицата Дефицити. Системата позволява бройките от съответния компонент да бъдат резервирани от текущата вътрешна поръчка за поръчката за изделието, в което той се включва, като съответно при генерацията текущата вътрешна поръчка се включва към "подчинените" на поръчката за изделието сборка.

# - идентификатор на производствена поръчка. При щракване се отваря форма Производствени поръчки.

Налични общо - показва количеството по производствена поръчка, от което са извадени бройките резервирани за поръчки използващи компонента.

Използвани - брой резервирани изделия.

Идент. #, Код, Описание - идентификатор, код и описание на изделието. При щракване се отваря ПСИ на изделието.

Забележки - забележки към производствената поръчка

Дата - дата на производствената поръчка.

При натискане на бутона Използвай, количеството на изделието от избрания ред в таблица Дефицити се маркира за резевиране (при генерирането на производствените поръчки) от вътрешната поръчка селектирана в таблицата Текущи поръчки и колоните Налични общо и Използвани се преизчисляват.

Лента с бутони

Производствени стратегии

Количествата необходими за производство по производствените партиди, както и бройките за обработка и изпълнение по отделните производствени операции се определят в процеса на генерация, на база на поръчаните количества и предвидените за всяка операция бройки за настройка и брак, според избраната технология. Алгоритъма за изчисление може да бъде настройван чрез избор на производствена стратегия.

Производствена стратегия на партидите

· Приоритет на поръчката - при тази стратегия, количеството необходими заготовки (изделия които подлежат на преработка на следващ етап) се изчислява, като бройките за настройка и брак за партидите от следващият етап се определят за всяка партида поотделно. Този подход гарантира, че ако се наложат например допълнителни настройки на машините при производство на голяма серия от изделия винаги ще има необходимото количество от заготовки за настройката и съответно ще бъде произведено необходимото количество добри заготовки за стратиране на следващият етап. При тази стратегия се изразходват малко по-големи количества от суровите материали (необходими за конкретната поръчка), които обаче се натрупват като складови наличности от заготовки, използваеми при последващи поръчки.
· Приоритет на материала - в този случай количеството на заготовките се изчислява, като бройките за настройка и брак се определят за цялото количество на изделията от следващия етап. При този подход се изразходва суров материал, точно колкото е необходмо за поръчката, но при големи серии се създава известен риск от недостиг на детайли за монтаж, например при неколкократна пренастройка на машините и съоветната "загуба" на заготовки.

Производствена стратегия на бройките за настройка

· Нормална - бройките за на настройка за всяка операция се изчисляват на според технологията.
· Оптимистична - бройките по технолгия се разделят на две.
· Рискова - задава се не повече от една бройка за настройка.
· Нулева - не се задават бройки за настройка.

По подразбиране са зададени стратегии - Приоритет на поръчката и Нормална. Текущите стратегии се изписват в статус полето на главния прозорец на програмата.

Бутон Печат - отпечатва се справка Дефицити.

Стъпка 3 - Избор на технология

На тази стъпка се избира технология (ако е достъпна повече от една) за производството на всяко изделие с ненулев дефицит от таблицата Дефицити.

Таблица Дефицити

Полетата са аналогични на съответните в таблицата Дефицити от стъпка 2.

Таблица Маршрутни карти

В таблицата се показват достъпните технологии (маршрутни карти) за изработване на избраното изделие от таблица Дефицити.

Вкл. - избира маршрутната карта(и) за производство.

Заготовка - идентификатор на стартовата заготовка за маршрутната карта. Ако маршрута започва от материал се изписва Материал. За монтажните маршрути се изписва Монтаж. При щракване се отваря прозорец с подробна информация за продукта.

К-во - необходимо количество от заготовката/материала.

Налични общо - налично количество от продукта.

Свободни - свободно количество, от което са извадени текущо селектираните.

Бр. - количество изделия за производство. Ако са селектирани повече от една маршрутни карти бройките се разпределят поравно. Бройката за дадена маршрутна карта може да бъде променяна в таблицата от оператора, като общият брой по всички избрани маршрутни карти трябва да съответства на дефицита.

Натовареност - сумарна натовареност за всички работни единици за операциите от маршрутната карта в часове. Изчислява се на база на създадените производствени поръчки плюс текущо селектираните маршрутни карти. Ако някоя от работните единици е временно спряна полето се оцветява в оранжев цвят, а ако всички работни единици от дадена група са временно спрени се оцветява в червен цвят.

Ранг - код на ранга на маршрутната карта, който се формира от ранговете на технологичния маршрут и операции, и дължината на маршрута като брой на етапите.

Мерна единица - мерна единица за основния материал (ако избраната маршрутна карта стартира от материал).

Забележка: По подразбиране селектирана е най-кратката и с най-висок ранг маршрутна карта, за която има наличност от стартовата заготовка (ако маршрута стартира от междинна заготовка).

Таблица Операции

Показва технологичните операции за избраната маршрутна карта.

Натовареност - натовареност на групата работни единици за операцията. Изчислява се на база на създадените производствени поръчки плюс текущо селектираните маршрутни карти.

# - пореден номер на операцията

Код - код на технологичната операция. При щракване се отваря програмата технологични операции.

Операция - наименование на технологичната операция.

Бройки за операцията - бройки за обработка.

Маршрут - наименование на технологичния маршрут.

Опер. # - идентификатор на технологичната операция.

Таблици Текущи операции за заготовки и Използвани поръчки

По аналогия със Стъпка 2, в таблицата Текущи операции за заготовки се показват текущите вътрешни поръчки за стартовите заготовки на маршрутните карти. Съответстващите на селектираната маршрутна карта текущи поръчки се маркират и след това резервират с натискане на бутона Използвай, след което се показват в таблицата Използвани поръчки. Резревирането може да бъде отказано като съответния ред в таблицата Използвани поръчки се селектира и се натисне бутона Премахни.

Бутон Справки

От бутона Справки могат да бъдат извикани следните справки:

Необходими материали

Опциите Подробна справка и Съкратена справка извикват репорти за необходимите за изработката на поръчките материали и покупни изделия.

Опция Искане за закупуване отваря прозореца Създаване на искане за закупуване, който служи за генериране на Искане за закупуване на необходимите материали.

Таблица Материали

Код, Описание - идентификатор и описание на материала.

Ед-ца - мерна единица.

К-во - необходимо количество.

Налични общо - налично количество във всички складове и участъци.

Свободни - свободно количество.

Минимална наличност - минимална наличност (неснижаем остатък) от материала по спецификация.

Алтернативен на - идентификатор на кой материал се явява алтернативен текущия. Алтернативните материали се изписват в курсив.

За заявка - необходмо за доставка количество (може да се коригира от оператора).

Таблица Покупни изделия е аналогична.

При натискане на бутона Генерирай за селектираните в колоните Използвай, материали и изделия с ненулево количество за заявка се генерира Искане за закупуване.

Стъпка 4 - Запис на генерираните производствени поръчки

При тази стъпка се визуализира помощна информация за производствените поръчки, които ще бъдат генерирани, както и за връзките между тях и съответните редове от клиентските поръчки. При натискане на бутона Запис се стартира процедура, която генерира и записва производствените поръчки и съответните им производствени партиди и производствени операции.

Забележка. Последната фаза при която информационния прозорец показва "Запис на производствените поръчки/партиди/операции" се извършва в режим на транзакция за базата данни. Което означава че други оперции по запис в свързаните таблици на базата данни не могат да бъдат извършвани до края на процеса.

Стъпка 5 - финален прозорец

На тази стъпка процеса на генерация и запис е приключен.

Бутон Печат паспорти - позволява отпечатване на паспортите на производствените партиди.

Бутон Добави към плана - стартира процедура по добавяне на новогенерираните проиводствени поръчки към производствения план и преизчисляването му. В зависимост от големината на плана това може да бъде продължителна операция.

Бутон Рестартирай - рестартира генератора и започва от Стъпка 1.


Програма - Отчитане на операциите

 Top

Отчитане на операциите

Тази програма е основното средство, което се използва за своевременно отчитане на извършената работа по производствените операции, на място в работните участъци, от служителите, който я извършват.

Идентификация на служителя

Служителят, от чието име се отчита операцията се идентифицира в прозореца Вход с личния си идентификационен номер. Ако по технология е предвидено операцията да се извършва и отчита от няколко служители, то номерата им се въвеждат разделени със запетая.

Прозореца за идентификация се отваря при стартиране на програмата, след запис или изход, или от менюто Вход (F5), Вход като...

Отчитане на извършената работа

Извършването на работа по дадена производствена операция се отчита чрез два последователни записа в таблицата за отчитане (по-долната таблица в прозореца). С първия запис се указва, че е стартирало изработване на изделия или настройка за операцията като данните се появяват в таблицата Текущи операции (горната таблица) и се фиксира началния момент на работата. С втория отчет се очтитат изработени бройки или бройки за настройка и се фиксира момента на край на работата.

Таблица за отчитане на операциите

Операция # - идентификатор на производствена операция, от списъка на операциите със статус В готовност за текущия работен участък, избран в полето Участък.

Раб. единица - идентификатор на работна единица от групата работни едници за операцията, на която се извършва работата. Клавиша F12 попълва работна единица по подразбиране.

Настр. - ако е селектирано указва, че отчета е за работа по настройка на машините.

Бр. добри - изработени добри бройки. При позиционирането в това поле в статус полето на формата се показват бройките Остатък по операцията. Това е разликата между отчетените добри бройки по предхождащата операция (ако текущата операция е първа за поръчката се взимат бройките за изпълнение) и вече отчетените.

Бр. с откл. - изработени бройки с отклонение от технологичните параметри (брак).

Бр. за настр. - използвани бройки за настройка.

Кач. - качество на изработените изделия.

Наименование - наименование на технологичната операция.

Заготовка - текуща заготовка на производствената партида.

Начало, Край - моменти на начало и край на работата за текущия отчет.

Причина за брак - идентификатор на причина за несъответствие.

Когато отчета се извършва от ОТК служител в таблицата са достъпни допълнителни полета:

Бр. за дораб. - бройки за доработка - изделия които трябва повторно да преминат през производствения цикъл и през допълнителна операция.

Бр. ОТК - бройки преминали през качествен контрол.

Несъвм. статус - статус за несъвместимост (В несъответствие спира или В несъответствие продължава), който ще бъде присвоен на производствената операция.

Бележки - забележка в свободен текст.

Запис на данните

Данните могат да бъдат записани с избиране на опцията Запис (F10) от менюто или записа да бъде отказан с опцията Изход (F8).

Погрешно въведен ред в таблицата може да бъде изтрит, преди да бъде записан, като се селектира с натискане на сивото поле в началото на реда и след това клавиша Del/Delete.

След записа на отчета, ако сумарното количество произведени добри бройки по производствената операция е по-голямо или равно на Остатъка, операцията се установява със статус Затворен. Ако е по-малко - със стаус Стартирана. След което се извикват процедурите след запис на производствена операция.


Програма - Производствен браузър

 Top

Производствен браузър

Производствения браузър е програма, която служи за навигиране и разглеждане на клиентски поръчки, производствени поръчки, производствени партиди и производствени операции, детайли за тях и връзките помежду им.

Потребителския интерфейс на програмата е разделен на четири сходни части, представляващи набор от филтри, команди за навигиране и прилежаща таблица с списък от записи. Редовете и съответстващите им записи в прилежащите таблици могат да бъдат селектирани чрез двойно натискане, като селектирания ред се показва с удебелен шрифт.

Клиентски поръчки

Идентификатор на клиентска поръчка – поле за избор от таблица на клиентските поръчки. Избирането или въвеждането на клиентска поръчка и натискане на клавиша Enter, ще попълни всички позиции от клиентската поръчка в прилежащата таблица.

Клиент – поле за избор от таблицата с клиентите. При попълване или избиране на запис в това поле ще се попълнят всички записи от всички незатворени поръчки за избрания клиент.

Държава – поле за избор от таблицата с държави. При попълване или избиране на запис в това поле, в прилежащата таблица, ще се попълнят всички незатворени поръчки предназначени за тази държава.

Закъсняващи – активен етикет указващ броя на закъсняващите клиентски поръчки. Зарежда в прилежащата таблица всички закъсняващи поръчки.

Отпечатване на паспорти [image] - функционалност за отпечатване на всички паспорти на производствени партиди свързани с клиентската поръчка.

Отвори за разглеждане [image] – отваря формата Клиентски поръчки.

Зареди надолу [image] – попълва прилежащата таблица от секция Производствени поръчки с всички производствени поръчки свързани със селектирания ред от секция Клиентски поръчки.

Изчисти таблицата [image] - премахва всички записи от прилежащата таблица.

Производствени поръчки

Идентификатор на производствена поръчка – поле за избор от таблицата с производствени поръчки. При попълване или избиране на запис и натискане на клавиша Enter, в прилежащата таблица се зареждат детайли за избраната производствена поръчка, както и свързаните с нея поръчки за изработка на компоненти .

Отворени поръчки – зарежда в прилежащата таблица всички незатворени производствени поръчки.

Закъсняващи - активен етикет указващ броя на закъсняващите производствени поръчки. Зарежда в прилежащата таблица всички закъсняващи производствени поръчки

Себестойност [image] – стартира програмата Себестойност на изделията, изчисляването оперативаната себестойност на изделието от текущо избраната производствена поръчка.

Отвори за разглеждане [image] – отваря формата производствени поръчки.

Зареди нагоре [image] – премахва всички записи от прилежащата таблица в секция клиентски поръчки и я зарежда с клиентските поръчки използвани за генериране на селектираната производствена поръчка.

Зареди надолу [image] - премахва всички записи от прилежащата таблица в секция производствени партиди и я зарежда с производствените партиди свързани със селектираната производствена поръчка.

Изчисти таблицата [image] – премахва всички записи от прилежащата таблица.

Производствени партиди

Идентификатор на производствена партида – поле за избор от таблицата с производствени партиди. При попълване или избиране на запис и натискане на клавиша Enter, се зареждат детайлите относно избраната производствена партида в прилежащата таблица

Отвори за разглеждане [image] – отваря формата Производствени партиди.

Зареди нагоре [image] – изчиства всички записи от прилежащата таблица в секцията с производствени поръчки и зарежда в нея производствената поръчка към която принадлежи избраната производствена партида.

Зареди надолу [image] – изчиства всички записи в прилежащата на секция Операции таблица и зарежда в нея всички операции част от избраната производствена партида

Изчисти таблицата [image] – премахва всички записи от прилежащата таблица.

Операции

Идентификатор на производствена операция – поле за избор от таблицата с производствени операции. При попълване или избиране на запис и натискане на клавиша Enter, се зареждат детайлите относно избраната производствена операция в прилежащата таблица

Отвори за разглеждане [image] – отваря формата Операции.

Зареди нагоре [image] – изчиства всички записи от прилежащата на секция Производствени партиди таблица и зарежда в нея производствената партида, от която е част текущата производствена операция.

Изчисти таблицата [image] – премахва всички записи от прилежащата таблица.

Предупреждения

1. Закъсняващи клиентски поръчки

Показва броя на позициите по клиентски поръчки в производство, на които остават от Датата за производство 2 или по-малко дни за основната производствена поръчка за позицията или 3 или по-малко дни за свързаните под-поръчки за компоненти. При натискане на етикета, се изчистват всички записи от таблицата с клиентски поръчки и се зареждат всички изоставащи клиентски поръчки.

2. Закъсняващи производствени поръчки

Показва броя на производствените поръчки, на които остават от Датата за производство 2 или по-малко дни за основната производствена поръчка за позицията или 3 или по-малко дни за свързаните под-поръчки за компоненти. При натискане на бутона в таблицата с производствени поръчки се зареждат всички изоставащи поръчки.

Подробности за всяко предупреждение и причините за него могат да бъдат разгледани чрез двойно щракване с мишката върху колоната с предупреждения към съответния запис.


Програма - Планиране на производството

 Top

Планиране на производството

Програмата за планиране на производството позволява да бъде създаден времеви график (производствен план) за изпълнението на създадените в системата производствени партиди и операции, които предстои да бъдат реализирани. Той дефинира точни моменти за стартиране и приключване на всяка една производствена операция, както и работната единица, на която тя да бъде изпълнена. За целта се използва евристичен оптимизационен алгоритъм, който отчита графиците за работа на работните единици (работен календар), наличностите и сроковете за доставка на материали, приоритетите на поръчките и др. и позволява оптималното разпределение на производствените ресурси.

Визуализация на плана

Производственият план се представя с двумерна графична схема.

По вертикалната ос са нанесени работните единици, представени с идентификаторите на участъка, групата и работната единица. При задържане на курсора се показва подсказка с описанието на работаната единица.

По хоризонталата е нанесено времето.

Производствените операции са показани с разноцветни ивици. Те са позиционирани вертикално спрямо работната единица а хоризонтално към момента за стартиране на операцията спрямо времевата ос. Ширината на ивицата е пропорционална на продължителността на операцията във времето. При задържане на курсора се показва подсказка с подробна информация за операцията. Ивиците на операциите могат да бъдат селектирани, като избраната се показва с удебелена рамка.

Лента с бутони

Зареждане на плана [image] - зарежда записания производствения план от базата данни.

Запис на плана [image] - записва изчисления план в базата данни.

Увеличаване/смаляване [image] - увеличва или намалява мащаба на визуализация на времевата ос. Съответно ширината на ивиците представящи операциите.

Избор на оперция - селектира избраната операция от списъка и я визуализира.

Предишна операция [image] - селектира и визуализира операцията предхождаща избраната, в технологичния ред на операциите.

Следваща операция [image] - селектира и визуализира операцията последваща избраната, в технологичния ред на операциите.

Информация [image] - показва прозорец с подробна информация за избраната операция.

Филтър по поръчки [image] - позволява задаване на филтър на операциите по избрани производствени поръчки.

Филтър по участъци [image] - задава филтър на операциите за избрани работни участъци.

Филтър по време - 2 седмици, 1 месец, 2 месеца или 3 месеца от началото на плана.

Преместване на операция [image] - позволява фиксирането на старта на избрана операция за точно определен момент или работна единица, като фиксираната операция не се премества при преизчисляване на плана.

Преизчисляване на плана [image] - извиква се процедурата за преизчисляване на текущия план. След преизчисляването плана се визуализра и може да бъде записан в базата данни, за да бъде достъпен за останалите функционалности на системата.

Забележка. В зависимост от големината на текущия план тази процедура може да отнеме значително време.

Проверка - проверка за съвместимост на текущия план.

Добавяне на производствени поръчки към плана

Всички незатворени производствени поръчки се визуализират в раздела Поръчки.

Пр. п-ка # - идентификатор на производствена поръчка. Поръчките за компоненти са представени дървовидно, като ако една дъщерна поръчка има повече от една родителска в иконата и има червена стрелка - [image] .

Кл. п-ка - позиции от клиентска поръчка, към които е производствената.

Изделие #, Код, Описание - идентифкато код и описание на изделието.

К-во - количество от производствената поръчка.

Дата за изп. - дата за изпълнение от клиентската поръчка.

Приоритет - приоритет на поръчката.

Статус - вече планираните поръчки имат статус Планирана

План. старт - планиран старт на поръчката (старт на първата операция).

План. край - планиран край на поръчката (край на последната операция).

Лента с бутони

Добавяне на поръчка [image] - избраните поръчки се добавят каъм плана и се стартира призчисляването му. Могат да бъдат селектирани едновременно една или няколко поръчки, като дъщерните поръчки на избраната се добавят автоматично.

Изваждане на поръчка [image] - избраните поръчки се премахват от плана и той се преизчислява.

Опресняване - таблицата с поръчки се зарежда наново от базата данни.


Програма - Генериране на работен календар

 Top

Генериране на работен календар

За работата на функционалностите за планиране на производството е необходимо предварително да бъде генериран работен календар. Той представлява подробен график на работните смени на всяка една работна единица включена в производство, за определен период от време (напр. календарна година).

Посредством програмата, работен календар може да бъде създаден или прегенериран за година или произволен период, за всички работни единици от отдел, група или за конкретна работна единица.

За всеки отдел и група работни единици могат да бъдат дефинирани параметри на работното време (работни смени, почивки и др.) по подразбиране, които могат да бъдат коригирани при стартиране на генерацията.

В процеса на генерация тези данни се взимат йерархично - ако генерираме календар за отдел и има дефинирано работно време за групата - използва се работното време за групата. Ако няма, се използват данните за отдела (видими в прозореца на програмата).

Забележка. След прегенериране на работния календар, за да бъдат отразени промените в работния план той трябва да бъде преизчислен чрез функционалностите за планиране.


Маршрутен лист

Форма Маршрутен лист

 Top

Маршрутен лист

· Използва се за стартиране на производство или доработка на изделия- нестандартни(извън редовно производство), тестови, мостри или нужни за производствения процес. Въвежда се пълна информация за необходимите продукти, операции и документи за производство на изделието, както и данни за осчетоводяване на разходи. Създава се на базата на основание(заповед ,известие, клиентска поръчка, тестова проба, мостра и т.н.) и предоставя възможност свързаност с съответен ред от клиентска поръчка или друг маршрутен лист.

Меню-Филтър-филтър само затворени и неизписани маршрутни листи.


Програма - Операции

 Top

Операции

· Основните технологични операции свързани с обработката на материали и компоненти.
· Технологични изисквания за извършване и регулация на призводствения процес.

Лента с инструменти

1. Добавяне нова папка в селектираната папка.

2. Преименуване на папка.

3. Изтриване на папка.

4. Създава нова операция в селектираната папка .

5. Клонира избраната операция.

6. Позволява редактиране на операцията в зависимост от зададените права за редакция.

7. Изтрива операция в зависимост от зададените права за редакция и участието й в маршрути .

8. Копира избраните операции.

9. Поставя копираните операции в папка.

10.Принтира избрана операция.

11.Режим на търсене- позволява разширено търсене по основните характеристики на дадена операция, както и по всички материали,машини и инструменти свързани с извършването й.

12. Търсене по папки.

Основни функционалности

Добавяне и редактиране на операция.

Разделител Операция

Код на операцията - кратък код за обозначение на операцията (задължително поле).

Име на операцията - наименование (задължително поле).

Квалификационна група за операцията/настройка и брой оператори - квалификационна група на операторите за изпълнение и настройка, както и техния брой.

Описание на операцията - подробно описание на технологичния процес.

Отметка ОТК операция - маркира се при контролна операция.

Разделител Норми

Въвеждат се стойности и формули необходими за изчисления на времеви и разходни норми.

Разделител Машини и инструменти

Избор на машини, инструменти и мерители използвани за изпълнение операцията.

Разделител Материали

Избор на основни и спомагателни материали , тяхната разходна норма и себестойност.

Разделител Кооперация

Кооперирани операции и подробна информация за тях.

Разделител Документи- документална информация свързана с текущата операция

Разделител Подоперации

Разделител Маршрути- производствените маршрути, в които участва операцията.


Програма - Маршрути

 Top

Маршрути

· Съвкупността от операции необходими за производството на дадено изделие.
· Реда на изпълнение на съответните операции и входно-изходните компоненти за всеки етап.
· Комбинацията от възможни маршрути и информация за тях.

Лента с инструменти.

1. Добавя нова папка в избраната папка.
2. Преименува папка.
3. Изтрива папка.
4. Добавя нов маршрут в избраната папка.
5. Клонира избрания маршрут
6. Позволява редактиране на маршрута в зависимост от зададените права за редакция.
7. Изтрива маршрут в зависимост от зададените права за редакция .
8. Копира избраните маршрути.
9. Поставя копираните маршрути в папка.
10. Тестване на маршрут- предоставя пълна информация за всички дефиниции на маршрути необходими за производството на крайното изделие .
11. Позволява разширено търсене по име,операция и изделие на даден маршрут.
12. Търсене по папки.

Основни функционалности

Добавяне и редактиране на маршрут.

Име-въвежда се името на маршрута.

Папка - избор на папка.

Тип - тип на маршрута.

Ранг-

Ред-

Отметка произволен ред на изпълнение.

Лента с инструменти.

1. 2. 3. 4. 5. 6.

1. Избор на операция и добавяне след селектирания ред.
2. Добавяне на фиктивна операция.
3. Движение нагоре в таблицата с операции.
4. Движение надолу в таблицата с операции.
5. Премахване на избрана операция от таблицата.
6. Разглеждане на операция.

Маршрутна карта- дава възможност за определяне реда на изпълнение и комбиниране на операциите.

Изделия-определяне на входно/изходните изделия.

Несъвместими маршрути - задаване на несъвместими маршрути.

Тестване на маршрут


Програма-Формули

 Top

Формули

· Програмата Формули служи за създаване и редакция на формули за изчисления и ограничения необходими в различните модули на системата.

Лента с инструменти

Създаване на нова формула

Основни полета

Име на формулата- въвежда се име на формулата.

Описание- кратко описание на формулата.

Папка- избор на папка за запис.

Оператори

Аритметически:

· Сума(х+у)-сумата на аргументите х и у.
· Разлика(х-у)- разликата на аргументите х и у.
· Умножение(х*у)- произведението на аргументите х и у.
· Деление(х/у)- частното на аргументите х и у.
· Степен(х^у)- степенуване на аргумента х на степен у.
· Целочислено деление(х\y)-деление на аргумента х на аргумента у с резултат цяло число.
· Остатък при деление(х%у)- остатъка при делението на аргумента х на аргумента у.
· Скоби((х))- поставяне на аргумента х във скоби.

Логически:

Логическите оператори връщат резултат True(вярно) или False(невярно).

· И(х&y)-логическото "И" връща резултат True(вярно), само тогава, когато и двете условия са True(вярно).
· ИЛИ(х|у)-логическото "ИЛИ" връща резултат True(вярно), когато поне едно от условията е True(вярно).
· Отрицание(~х)-операторът за логическо отрицание сменя стойността на аргумента.

За сравнение:

· Равно(х=у)
· Различно(х<>у)
· По-малко(х<у)
· По-голямо(х>у)
· По-малко или равно(х<=у)
· По-голямо или равно(х>=у)

Функции

Математически:

· Закръгляне(round(x,y))- закръгляне на аргумента х до у позиции след десетичната запетая.
· Закръгляне(floor(x))- закръгля аргумента х към по-малкото цяло число
· Корен квадратен(sqrt(x))- корен квадратен от аргумента х.
· Максимум(max(x,y))- връща аргумента с по-голяма стойност.
· Минимум(min(x,y))-връща аргумента с по-малка стойност.
· Абсолютна стойност(abs(x))-абсолютната стойност на аргумента х.
· Логаритъм десетичен(log(x))-десетичен логаритъм от аргумента х.
· Логаритъм натурален(ln(x))-натурален логаритъм от аргумента х.
· sin(x)-синус на аргумента х.
· cos(x)-косинус на аргумента х.
· tan(x)-тангенс на аргумента х.
· arccos(x)-аркускосинус на аргумента х.
· arctan(x)-аркустангенс на аргумента х.

Текстови:

Символен низ-последователност от краен брой елементи от символен тип.

· Конкатенация concat(х,у,...)-събиране на два или повече символни низа.Пример:Ако х="те" и у="кст" резултата е "текст"
· Заместване(replace(x,y,z))-заместване на поредни символи от символен низ.Пример:Ако х="текст1a", у="1a" ,z="2б"резултата е "текст2б".
· Част от текст(mid(x,y,[z]))-
· Част от текст,лява(left(x,y))-избор на символи от лявата част на символен низ.Пример:Ако х="текст1a", у="5" резултата е "текст".
· Част от текст,дясна(right(x,y))-избор на символи от дясната част на символен низ.Пример:Ако х="1aтекст", у="5" резултата е "текст".
· Повторение на символи(strdup(x,y))-повтаря символ х на брой пъти.Пример-Пример:Ако х="5", у="т" резултата е "ттттт".
· Допълване от ляво(padleft(x,y,z))-
· Допълване от дясно(padright(x,y,z))-
· Дължина(leng(x))- брой на символите в символния низ.Пример:Ако х="текст" резултата е "5".
· Позиция на(indexof(x,y))- позиция на символ в символния низ .Пример:Ако х="текст" и у="е"резултата е "2".
· Съдържа(contains(x,y))-проверява дали символ се съдържа в символния низ.Пример:Ако х="текст" и у="е"резултата е "1"(вярно).
· Започва с(starts(x,y))-проверява дали символния низ започва с зададен символ.Пример:Ако х="текст" и у="е"резултата е "0"(невярно).
· Завършва с(ends(x,y))-проверява дали символния низ завършва с зададен символ.Пример:Ако х="текст" и у="т"резултата е "1"(вярно).
· Премахване на празните символи(trim(x))-премахва празните символи.
· Главни букви(ucase(x))-изписва текст с главни букви.
· Малки букви(lcase(x))-изписва текст с малки букви.
· Разделяне на текст(split(x,y,n))

Други:

· Стъпаловидна[=,=](step2E(x1,x2,c1,c2,v1,...,v))- функцията връща резултат v1, ako аргумента х1 е равен на стойноста с1, аргумента х2 е равен на стойностас2 и т.н..Ако не са изпълнени условията връща резултат v.
· Стъпаловидна[=,=..=](stepNE(n,x1,x2..xn,c1,c2,..cn,v1...,v))- функцията връща резултат v1, ako всеки един елемент от множеството аргументи х1..xn e равен на съответстващата му стойност от множеството c1..cn, където n е броя на елементите..Ако не са изпълнени условията връща резултат v
· Стъпаловидна[=](stepE(x,c1,v1,c2,v2...,v))- функцията връща резултат v1, ако аргумента х е равен на стойноста с1,v2 ако аргумента х е равен на стойноста с2 и т.н.Ако не са изпълнени условията функцията връща резултат v.
· Стъпаловидна[<=](stepLE(x,c1,v1...,v))- функцията връща резултат v1, ако аргумента х е по-малък или равен на стойноста с1 и т.н.Ако не е изпълнено условието функцията връща резултат v
· Стъпаловидна[<](stepL(x,c1,v1,...,v))- функцията връща резултат v1, ако аргумента х е по-малък от стойноста с1 и т.н.Ако не е изпълнено условието функцията връща резултат v
· Алтернативна(iif(x,v1,v2))- алтернативната функция връща резултат v1, ако зададеното условие x е TRUE(вярно), и резултат v2, ако това условие е FALSE(невярно).
· Елемент от множеството(in(x,c1,c2,...,cn))- функцията връща резултат TRUE(вярно),ако аргумента х е елемент от множеството на изброените стойности с1,с2...cn, и стойност FALSE(невярно),ако не е.

Константи:

Пи(pi)

E(e)

Специални функции

Стойности на атрибути- съдържа всички стойности на атрибути в системата .

Кодове на атрибути- съдържа всички кодове на атрибути в системата.

Кодове на константи- съдържа всички кодове на константи в системата.

Функции за атрибути:

· Стойност на атрибут по ID на стойност V()-
· Стойност на атрибут на изделие AttrValue()-
· Стойност на външен атрибут ParentAttrValue()-
· Наличие на атрибут AttrExists()-
· Наличие на външен атрибут ParentAttrExists() -
· Наличие на атрибут на основното изделие RootAttrExists() -
· Описание на атрибут AttrDescr() -
· Описание на атрибут Англ. AttrDescr2() -
· Стойност на атрибут на основното изделие RootAttrValue() -

Функции на изделия:

· Код на изделието CompCode()-
· Описание на изделието CompDescr() -
· Описание на изделието Англ. CompDescr2()
· Изделието е детайл IsDetail()-
· Изделието е възел IsNode() -
· Бройки изделия в партидата LotAmount() -

Функции на операции:

· Текуща операция CurrentOper() -
· Непосредствена предишна операция PreviousOper()-
· Предишна операция PassedOper()-

Функции за материали:

· Материала съответства MatchMaterial() -
· Размер на материала MaterialDim()-
· Относителна плътност Density()-
· Тегло за ед. материал MaterialUnitWeight-

Функции за ТРЗ:

· Основна заплата OsnovnaZaplata()-
· Работни дни в месеца RabotniDni()-
· Отработени дни OtraboteniDni() -
· Заработка Zarabotka() -
· Трудов стаж общ Staj() -
· Фирмен стаж StajFirmen() -
· Година на раждане Roden() -
· Брой работни дни за контекстния период/месец PeriodRabotniDni() -
· Сума за начисления SumPlus() -
· Сума на удръжки SumMinus() -

Стойност на константа ConstValue()-


Програма-Константи

 Top

Константи

· Използва се за въвеждане и редакция на константи ,участващи в формули виж.

Лента с инструменти

1. Добавяне на нова папка в селектираната папка.

2. Преименуване на папка.

3. Изтриване на папка.

4. Добави константа- създава нова константа в селектираната папка .

5. Клониране на константа-клонира избраната константа.

6. Редактирай константа-позволява редактиране на константа.

7. Изтрий константа-изтрива константа.

8. Копира избраните константи.

9. Поставя копираните константи в папка.

10.Търсене- разширено търсене по параметри.

11.Папки- търсене по папки.

Създаване на нова константа

Основни полета:

Име- име на константата.

Описание-кратко описание на константата

Тип-избор на типа на константата

Стойност-въвежда се стойност.


Меню Справки

 Top

Маршрутна карта

Произвеждани изделия в участък-

Справка за обработваните изделия в работен участък

Маршрутни листи

Справка за всички затворените маршрутни листи към дата.

· Неосчетоводени
· Осчетоводени


Форма Известия

 Top

Изходящи известия

· Форма за въвеждане и редакция на известия с цел комуникация между различните отдели и дирекции.След запис на известието автоматично се генерират нови записи за всеки един получател в формата Отговори на известия с входящ номер -номера на Изходящото известие .

Изходящ #- идентификатор на известието

Отдел- избор на отдел

Изготвил-потребител изготвил известието

Одобрил- потребител одобрил известието

Относно- кратка информация относно предмета на известието

Описание- пълно описание

Дата- дата на създаване

Статуси-

· Нов-
· Чакащ одобрение-
· Активен-
· Приключен-

Таблица Получател

Задават се получатели на известието отдел или дирекция.

Таблица Прикачени документи

Таблица за избор на необходима документална информация свързана с текущото известие.

Меню -Филтри

Позволява филтриране на известията по техния статус.


Форма Отговори на известия

Top

Формата съдържа отговори на известия към дирекции.


Форма Документи-кратка версия

 Top

Документи- кратка версия

· Форма за добавяне и редакция на документи

Документ#- индентификационен номер(генерира се от системата).

Заглавие- кратко описание на документа.

Описание- подробно описание на на съдържанието на документа.

Папка- избор на папка.

Местонахождение- местонахождение на документа.

Тип, Формат, и Език на документа

Създаден от - потребител създал документа.

Създаден на - дата на създаване и последна промяна.

Получен на - дата на получаване.

За общи указания за работа с форми виж.


Абонати

 Top

Subscribers


Форма Документи чакащи изпращане

 Top


Форма Заповеди за изменение

 Top

Съдържа заповеди за изменение на документи с полета за съгласуваност с различните дирекции към дата


Форма Патенти,Дизайни,Марки

 Top
· Форма за въвеждане и редакция на Патенти, Дизайни и Марки с информация за плащания към тях и прикачени документи .

За общи указания за работа с форми виж.


Форма Зап. за въвеждане в техн.архив

 Top

Заповеди за въвеждане в технически архив

· Форма за въвеждане в техническия архив на документи след съответната проверка ,контрол и одобрение към дата. Таблица за добавяне на допълнителни прикачени документи .

Таблица Прикачени документи

Добави документи -добавяне на нов документ.

Таблица Допълнителни прикачени документи

Добави документи -добавяне на нов документ.

Таблицата съдържа техническа документация свързана с заповедта и функционалности за директно Разглеждане на файл и Разглеждане на метаданни

За общи указания за работа с форми виж.


Форма Зап. за внедряване/спиране от редовно произв.

 Top
· Служи за създаване и редакция на заповеди за внедряване, спиране,връщане в разработка и връщане в редовно производство на изделия. Съдържа полета за съгласуваност с дирекции, таблица за добавяне на изделия свързани с избраното и прикачени документи.

Заповед №- индентификационен номер

Тип:

- Заповед за внедряване в редовно производство

- Заповед за спиране от редовно производство

- Заповед за връщане в редовно производство

- Заповед за връщане в разработка

Дата- дата на заповедта

Статус-

-Нов

-Чакащ одобрение

-Одобрен

-Отхвърлен

Свързана заповед /от дата-

Изделие- индентификатор на изделието.

Разгледай- разглеждане на изделието в ПСИ.

Маршрут-разглеждане на маршрута на изделието.

Блок Съгласуване с дирекции

Съдържа полета за избор и въвеждане, на служители от отделните дирекции, които трябва да бъдат информирани за текущата заповед.Предоставя избор на два типа комуникация- съгласуване или уведомяване.

Таблица подизделия - изделия зависещи от основното , които също трябва да кореспондират на съответната заповед. Директно разглеждане на изделията и техния маршрут.

Добави изделия-добавяне на изделия в таблицата

Таблица прикачени документи

Добави документи- добавяне на документи

Таблицата съдържа техническа документация свързана с заповедта и функционалности за Разглеждане на файл и Разглеждане на метаданни

За общи указания за работа с форми виж.